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1 - Le Basi di GeoMedia Professional
1-1 Cominciamo ad Apprendere!
Questa guida contiene sette esercizi che sono stati concepiti come indipendenti perciò
possono essere svolti nell’ordine suggerito dall’indice, o in ordine sparso, compatibilmente
con le esigenze di ogni utente.

Questi esercizi ci guideranno attraverso le funzioni base di GeoMedia® Professional, ed
utilizzando un set di dati degli Stati Uniti che viene consegnato ed installato insieme con il
programma, si porterà a termine una analisi dei dati per localizzare il posizionamento
migliore per una nuova pista da sci. Sarà possibile creare una mappa della pista da sci,
utilizzando le funzioni avanzate per la cattura dei dati. Sarà inoltre possibile creare un
flusso di stampa attraverso la funzione di Batch Plotting. Vedremo inoltre come creare una
connessione a dati di tipo CAD.

Breve spiegazione dei Files utilizzati in questo Tutorial

La tabella che segue, farà da riferimento ad i GeoWorspace ed ai Warehouse files che
verranno utilizzati in ogni esercizio. Tutti i GeoWorkspace sono contenuti nella cartella
GeoWorkspace, (ad esempio C:\Warehouses) mentre tutti i Warehouse sono contenuti
nella cartella Warehouse (ad esempio, C:\Warehouses). Tutti gli altri files che verrano
utilizzati negli esercizi, sono contenuti nella cartella Learning (ad esempio C:\Program
files\GeoMedia Professional\Learning).

Workflow GeoWorkspaces Warehouses

1 - Le basi di
GeoMedia
Professional

- Copiare learn_orig.gws per
modificare learn.gws.

- Creare learn.mdb.

- Utilizzare in sola lettura
USSampleData.mdb.

2 - Analisi dei
Dati

- Utilizzare (modificare)
learn.gws (sia al termine di un
flusso di lavoro precedente sia
copiando learn_data.gws per
learn.gws).

- Utilizzare (modificare)
learn.mdb (sia al termine di un
flusso di lavoro precedente sia
copiando learn_data.mdb per
learn.mdb).

- Utilizzare (in sola lettura)
USSampleData.mdb.
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3 - Creare
una Versione
Stampabile
dei Risultati

- Utilizzare (modificare)
learn.gws (sia al termine di un
flusso di lavoro precedente sia
copiando
learn_beforeplot.gws per
learn.gws).

- Utilizzare (modificare)
learn.mdb (sia al termine di un
flusso di lavoro precedente sia
copiando leran_beforeplot.mdb
per learn.mdb).

- Utilizzare (in sola
lettura)USSampleData.mdb.

4 - Batch
Plotting

- Modificare learn.gws (dalla
fine del workflow precedente o
copiando learn_afterplot.gws
come learn.gws).

- Copy BatchPlotting.gws to
use (modify) Batch_wk.gws.

- Modificare learn.gws (dalla fine
del workflow precedente o
copiando learn_afterplot.mdb
come learn.mdb).

-
UtilizzareMadisonCountyAL.mdb
e BatchPlotting.mdb.

5 - Utilizzare i
Cataloghi
GeoSpaziali

- Utilizzare (modificare)
learn.gws (sia al termine di un
flusso di lavoro precedente sia
copiando learn_afterplot.gws
per learn.gws).

- Utilizzare (modificare)
learn.mdb (sia al termine di un
flusso di lavoro precedente sia
copiando learn_afterplot.mdb
per learn.mdb).

6 –
Acquisizione
dei Dati

- Copiare SkiResort_orig.gws
per modificare SkiResort.gws.

- Copy SkiResort_orig.mdb to
use (modify) SkiResort.mdb.

7 – Utilizzo
del CAD Data
Server

- Utilizzare (modificare)
learn.gws (sia al termine della
Sezione 3, o del flusso di
lavoro 4 sia copiando
learn_afterplot.gws per
learn.gws).

- Utilizzare learn.gws (sia al
termine della Sezione 3, o del
flusso di lavoro 4 sia copiando
learn_afterplot.mdb per
learn.mdb).

- Utilizzare (in sola
lettura)USSampleData.mdb.

- Creare e utilizzare (in sola
lettura) topos.csd.

IMPORTANTE: Se qualunque dei files di tabella, viene modificato, si potrebbero non
ottenere i risultati descritti in questo tutorial. E’ raccomandabile creare una copia di back-
up di questi files con lo scopo di recuperare le informazioni perdute, se si dovesse
presentare la necessità.

ATTENZIONE: Se GeoMedia Professional viene reinstallato, i files descritti sopra saranno
sovrascritti, e tutte le modifiche apportate ad i files di progetto, o ai database associati,
verranno perdute. Nel caso in cui si abbia la necessità di eseguire nuovamente il Setup di
GeoMedia Professional, e si vogliano conservare le modifiche fatte all’interno dei
Geoworkspaces o dei Warehouses, sarà necessario creare manualmente una copia di
back-up dei files che si ritengono utili.
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Prima di Cominciare
Prima di cominciare l’esercizio, si abbia cura di:

1. Creare una copia di back-up del file learn_orig.gws contenuto nella cartella
GeoWorkspaces, che si può rinominare come learn.gws.

Aprire un GeoWorkspace
Per prima cosa si aprirà un file di progetto di tipo GeoWorkspace che permetterà di
visualizzare i dati geografici. Quando si ci connette ad un Warehouse di dati, sarà
possibile, nel caso la connessione sia di tipo read-write, cioè con permessi di lettura e
scrittura, scrivere nuovi dati e modificare quelli già presenti.

1 Avviare GeoMedia Professional.

2. Quando la finestra di dialogo GeoMedia Professional viene visualizzata sullo schermo
scegliere Open an existing GeoWorkspace, e selezionare il file learn.gws contenuto
nella cartella GeoWorkspaces.

-OPPURE-

Selezionare File > Open GeoWorkspace ed aprire il file learn.gws.

Il GeoWorkspace è ora aperto.

Il GeoWorkspace contiene la map window intitolata MapWindow1, cioè la finestra dove
sarà possibile visualizzare e modificare i dati, e la legenda, che serve a visualizzare la
simbologia ed il nome di ogni classe di feature.

E’ possibile notare come la legenda, che contiene due schede, sia ancorata nella zona in
alto a sinistra dello schermo. Sarà possibile spostarla in un’altra zona o disattivarne la
visualizzazione, per facilitare l’utilizzo della map window.
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Sganciare la Legenda
E’ raccomandabile sganciare la legenda dalla finestra di mappa, e renderla flottante, ciò
serve a rendere più comoda la visualizzazione dei dati: tutte le volte che un elemento
viene oscurato dalla legenda, si può scegliere di spostare gli elementi di mappa o di
spostare la legenda.

1. Fare click destro sulla map window e selezionare l’opzione Position Legend >
Floating.

IMPORTANTE: Per cambiare la posizione della legenda, è necessario utilizzare il pulsante
destro del mouse sulla map window e non sulla legenda.

La legenda è stata sganciata ed inoltre è provvista di titolo.

Come Porre le Finestre
Può essere utile mantenere questa finestra di dialogo affiancata verticalmente alla finestra
di programma, accertarsi che questa ultima sia grande abbastanza per poter eseguire
comodamente le istruzioni suggerite, mentre la finestra di tutorial dovrebbe essere grande
abbastanza per poter leggere le istruzioni.

Note:

 Questo tutorial è stato ottimizzato per la risoluzione di 1024x768. Ad un altra
risoluzione si potrebbero affrontare piccole imperfezioni nelle immagini contenute nel
tutorial.

 E’ consigliabile seguire il tutorial mantenendo le finestre affiancate. Se però, mentre si
sta eseguendo una qualunque operazione GeoMedia Professional sembra non
rispondere, accertarsi che la finestra attiva sia quella di GeoMedia Professional e non
quella del tutorial.

Salvare il GeoWorkspace
Prima di continuare, salvare il GeoWorkspace.

1. Selezionare File > Save GeoWorkspace.
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NOTA: Si ricorda di salvare sempre il GeoWorkspace, tutte le volte che si esce dal
programma.

Continuare con la prossima sezione: 1-2 Connettersi ad un Warehouse
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1-2 Connettersi ad un Warehouse
In questa sezione vedremo come connettersi ad un warehouse, che ci permetterà di
visualizzare le informazioni, e creare delle nuove query. Un warehouse è un qualunque
database di dati geografici. Ogni database può contenere solo un tipo di dati, tra i formati a
cui possiamo connetterci utilizzando GeoMedia Professional ci sono: Access, MGE,
FRAMME, MGE Segment Manager, ARC/INFO, Oracle, ArcView, MapInfo, MGDM, e
CAD.

Connettersi ad un Database Access
GeoMedia Professional è capace di connettersi e quindi visualizzare, diversi tipi di dati
spaziali contemporaneamente. Sarà possibile ad esempio connettersi ad un database
MGE, ad un database FRAMME, ad un database ARC/INFO, e visualizzare questi dati
provenienti da fonti diverse in un unica finestra di mappa.

All’interno di GeoMedia Professional si definisce Feature, una entità di tipo spaziale che
comprende una componente geometrica e una componente di tipo tabellare. Una feature
class è un insieme di features che sono state classificate. Ad esempio la feature
Minnesota appartiene alla feature class States, e la feature Boston appartiene alla feature
class States.

Per prima cosa vedremo come creare un collegamento al warehouse USSampleData.mdb
per poterne visualizzare i dati contenuti.

1. Selezionare Warehouse > New Connection.

Viene visualizzata la finestra di dialogo New Connection dove sono visibili i differenti
tipi di warehouse a cui ci si può connettere.

2. Nel campo Connection type, selezionare Access Read-Only.

Quando si apre una connessione in modalità di sola lettura, non è possibile creare
delle modifiche all’interno del database.

3. Cancellare il testo presente all’interno del campo Connection name ed inserire
Connection to US Data.

4. Fare click sul pulsante Browse per selezionare un file.

5. Scegliere USSampleData.mdb, e premere il pulsante Open.

6. Premere il pulsante OK nella finestra di dialogo New Connection.

Aggiungere Elementi alla Legenda
La finestra di mappa e la legenda sono al momento vuote, ma verranno ora aggiunte due
feature class tra quelle disponibili all’interno della connessione di sola lettura.

1. Selezionare Legend > Add Legend Entries.

2. Nella finestra di dialogo Add Legend Entries esplodere la voce Connection to US
Data cliccando sul + che si trova accanto al nome della connessione.

3. Selezionare le feature classes StateNameLabels e States dalla lista degli elementi di
legenda.

4. Premere il pulsante OK.
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Gli elementi sono stati così aggiunti alla legenda, e le feature corrispondenti sono ora
visibili all’interno della finestra di mappa.

5. Se la finestra di mappa non è stata ingrandita, ingrandirla facendo click sull’icona
nell’angolo in alto a sinistra e selezionando la voce di menù Maximize.

6. Selezionare View > Fit All con lo scopo di visualizzare nella finestra di mappa tutte le
features visibili.

Nota: E’ possibile rendere la legenda più grande o più piccola a seconda delle esigenze.

Nota: La feature States può avere l’attributo di colore verde (come mostrato nella figura
sopra), ma anche bianco. Alla fine di questa sezione si vedrà come modificare questo
attributo.

Salvare il Sistema di Coordinate e Localizzare la Cartella Learning

GeoMedia Professional prevede l’utilizzo di un sistema di coordinate, che può essere
salvato e utilizzato secondo le necessità di visualizzazione e di analisi.

1. Selezionare Warehouse > Feature Class Definition.

2. Fare click sul + accanto a Connection to US Data.

3. Nella lista delle feature classes, selezionare States e premere il pulsante Review.

4. Premere il pulsante Properties.

5. All’interno della finestra di dialogo Coordinate System Properties selezionare la
scheda Projection Space.

6. Si può notare che il sistema di coordinate utilizzato in questo caso è Albers Equal
Area.

7. Premere il pulsante Save As.

8. Scegliere la cartella Learning come cartella di destinazione, utilizzare il pulsante Save
As.
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IMPORTANTE: La cartella Learning viene creata automaticamente, quando si installa il
prodotto, il percorso di default è C:\Program files\GeoMedia Professional\Learning. E’
possibile lasciare la cartella nel percorso di default se si hanno i permessi sufficienti
per accedervi. Altrimenti si sposti la cartella in un’area dove si hanno permessi di
lettura e scrittura come ad esempio la cartella Warehouses.

Ogni volta che la cartella Learning viene menzionata all’interno di questo tutorial si da
per scontato che l’utente abbia permessi di lettura e scrittura all’interno della cartella.

9. All’interno del campo File name digitare USSampleData.

10.Premere il pulsante Save.

11.Nella finestra di dialogo Coordinate System Properties premere il pulsante Cancel.

12.Premere il pulsante Close nella finestra di dialogo Review e nella finestra di dialogo
Feature Class Definition.

13.Utilizzando l’esplora risorse di Windows verificare che all’interno della cartella Learning
sia stato creato il file USSampleData.csf. Se il file non è stato creato significa che
l’utente non ha i permessi necessari per eseguire tale operazione. Riprendere dal
punto 8 di questo esercizio.

Caricare un Sistema di Coordinate
In quest’esercizio si utilizzerà il file con le informazioni circa il sistema di coordinate
spaziale che è stato estratto nell’esercizio precedente dalla feature class Stases.

1. Selezionare View > GeoWorkspace Coordinate System.

2. Premere il pulsante Load.

3. Selezionare il file salvato prima: USSampleData.csf e premere il pulsante Open.

4. Scegliendo di visualizzare le informazioni contenute nella scheda Projection Space, si
può verificare che il Projection algorithm è Albers Equal Area, e cioè lo stesso
sistema di coordinate della feature class States.

5. Premere il pulsante di scheda General.

6. In Optional information, digitare USSampleData come Name.

7. Premere il pulsante OK.

Il file USSampleData.csf definisce il sistema di coordinate che viene utilizzato in questo
GeoWorkspace.

Gestire le Proprietà di Visualizzazione
Si vedrà ora il funzionamento dei comandi nominal map scale e display scale associati alla
finestra di mappa. La scala nominale di mappa è associata alla scala di stampa ed il suo
valore dovrebbe essere prossimo alla scala a cui i dati che sono visualizzati sono stati
creati, ma questo valore non può essere sempre noto; inoltre gli elementi di stile associati
con le features possono essere associati a questo valore cioè in modo che siano
visualizzati correttamente alla scala scelta. Il fattore display scale è la scala alla quale gli
oggetti che sono stati caricati in legenda sono visualizzati nella finestra di mappa. Infatti
quando si utilizza il controllo di zoom la scala di visualizzazione aumenta o diminuisce ed
insieme ad essa i dati visualizzati.
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Tutti le impostazioni di stile, come lo spessore di una linea, la grandezza di un simbolo o di
un’etichetta, si comportano differentemente se associati alle impostazioni View o Paper.
View restituisce le dimensioni reali per qualunque scala di visualizzazione, Paper
restituisce dimensioni reali solo alla scala di display. Ad esempio se il testo viene
impostato come View, non si visualizzeranno cambiamenti di stile al variare della scala di
visualizzazione, ma sarà possibile visualizzare i cambiamenti modificando la scala
nominale. Se invece il testo viene impostato come Paper, quando si utilizzano i controlli di
zoom per modificare la visualizzazione, la feature cambierà spessore coerentemente con
la scala utilizzata.

Nota: ci sono due modi che permettono di modificare le impostazioni di stile:

 La finestra di dialogo Display Properties permette di associare tutti gli elementi di
legenda ad una modalità oppure ad un’altra.

 E’ possibile inoltre modificare queste impostazioni per ogni singola feature class:
utilizzando il tasto destro del mouse sulla corrispondente voce di legenda si può
selezionare il comando Style Scaling > Paper per associare la voce alla modalità
Paper oppure Style Scaling > View per associare la voce alla modalità View.

In questo esercizio si imposterà la scala nominale di mappa ed una scala di
visualizzazione iniziale. Tutte le feature verranno impostate con la modalità Paper in modo
che al variare della scala di visualizzazione, cambieranno le dimensioni degli oggetti di
mappa.

1. Selezionare View > Display Properties.

Viene visualizzata la finestra di dialogo Display Properties.

2. Nel menù a tendina Display scale scegliere 25,000,000.

3. Nel campo Nominal map scale, digitare 20,000,000.

4. Attivare Paper (la dimensione è reale alla scala di mappa nominale).
Questa impostazione viene attribuita a tutti gli elementi di legenda.

5. Premere il pulsante Apply.

6. Premere il pulsante Close.

Nota: Non è un problema se gli oggetti di mappa non sono tutti completamente inscritti
nella finestra di mappa. Potrebbero non esserlo a causa delle dimensioni della finestra.
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7. Se si osserva l’angolo in basso a destra della barra di stato, dovrebbe essere possibile
visualizzare il valore della scala di visualizzazione scelta prima (1 : 25,000,000). Se
non si riesce a vedere questa informazione, si seguano i seguenti passi:

8. Selezionare Tools > Options. All’interno della scheda General accertarsi che
l’opzione Show status bar sia stata spuntata e che l’opzione Show display scale sia
stata spuntata.

9. Nella scheda Map Display, accertarsi che l’opzione Use dynamic pan sia attiva e che
l’opzione Use fast pan sia disattiva.

Questa opzione di visualizzazione tornerà utile più avanti in questa guida.

10.Premere il pulsante OK nella finestra di dialogo Options.

Se non è ancora possibile vedere la scala di visualizzazione nell’angolo in basso a
destra della barra di stato, significa che GeoMedia Professional non occupa
abbastanza spazio sullo schermo, perciò sarà necessario estendere la finestra
orizzontalmente per visualizzare tutti gli elementi presenti nella barra di stato.

Introduzione agli Stili
GeoMedia Professional è provvisto di eccellenti proprietà di controllo e gestione degli stili
di visualizzazione. Il comando Legend > Styles permette di creare, manipolare,
rinominare e salvare gli stili.

In questo semplice esercizio, si andrà a modificare lo stile di un elemento di legenda:
verranno cambiate le etichette degli stati.

1. Si faccia doppio click sulla chiave di stile dell’elemento di legenda StateNameLabels,
come mostrato dalla figura sottostante.

La finestra di dialogo Legend Entry Properties è ora visualizzata.

2. Modificare l’attributo Size: selezionare 8.000 dal menù a tendina Size, Premere il
pulsante Bold.

3. Premere il pulsante OK nella finestra di dialogo Legend Entry Properties.

Le etichette degli stati sono state modificate. I valori scelti le fanno apparire più piccole
ed in grassetto.
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Salvare uno Stile
In questo esercizio si cambieranno le proprietà di visualizzazione della feature States, e si
salveranno le impostazioni con un nuovo stile che potrà essere utilizzato nuovamente in
seguito.

Per fare ciò sarà opportuno creare un nuovo stile per le features areali e dargli un nome
significativo utilizzando il comando Legend > Styles, sarà poi possibile associare alla
feature il nuovo stile.

1. Selezionare Legend > Styles.

2. Selezionare la cartella Learning nel lato sinistro della finestra di dialogo e puntare alla
cartella Styles in modo che nel campo Path venga visualizzato il percorso
Styles\Learning.

3. Nella barra degli strumenti che si trova nella parte superiore della finestra di dialogo,
premere il pulsante New e selezionare Area Style.

Nella cartella Styles\Learning è stato posizionato un nuovo stile per le features areali,
si potrà ora inserire un nome per identificarla.

4. Digitare il nome Learning States.

5. Fare doppio click sullo stile Learning States per visualizzare la finestra di dialogo
Style Properties.

Si può notare come lo stile di Learning States consista di due stili: lo stile della linea di
perimetro e lo stile dell’area di riempimento.

Ora andremo a modificare lo stile del perimetro.

6. Accertarsi che sia stato selezionato Simple Line Style tra le opzioni di Boundary
Styles.

Le impostazioni per Simple Line Style sono visualizzati nel lato destro della finestra di
dialogo.

7. Per cambiarne il colore premere il pulsante Color.
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8. Nella finestra di dialogo Color selezionare dalla tavolozza dei colori il quadrato grigio
scuro.

Quando un colore viene selezionato, il numero di tavolozza associato viene
visualizzato.

9. Scegliere il colore della tavolozza contraddistinto dal numero 60.

10.Premere il pulsante OK nella finestra di dialogo Color.

11.Scegliere Simple Fill Style tra i Fill Style.

Le impostazioni per Simple Fill Style sono visualizzati nel lato destro della finestra di
dialogo.

12.Per cambiare il colore di riempimento premere il pulsante Color.

13.Scegliere il colore blu chiaro contraddistinto dal numero 9 nella tavolozza dei colori.

14.Premere il pulsante OK nella finestra di dialogo Color.

15.Lasciare Translucency impostato sul valore 0.

Quando questo valore è impostato a zero, lo stile di visualizzazione è opaco. Se si
imposta il valore a 100, la feature sarà completamente trasparente. E’ possibile
utilizzare il valore compreso tra il massimo e ed il minimo in modo da visualizzare la
feature e ciò che c’è al si sotto di essa in modo appropriato.

16.Premere il pulsante OK nella finestra di dialogo Style Properties.

Si può osservare come lo stile Learning States sia disponibile nella finestra di dialogo
Styles, con i cambiamenti effettuati prima.

17.Premere il pulsante Close nella finestra di dialogo Styles.

Ora che il nuovo stile è stato creato, si vedrà come adattarlo alla voce di legenda della
feature class States.

18.Fare doppio click sull’icona che descrive lo stile della voce di legenda States.

19.Quando viene visualizzata la finestra di dialogo Legend Entry Properties aprire la
cartella Learning folder sotto la voce Named Styles.

20.Selezionare lo stile Learning States.

21.Premere il pulsante OK nella finestra di dialogo Legend Entry Properties.
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Lo stile di visualizzazione della feature class States è caratterizzato da riempimento blu
chiaro e da contorno grigio.

22. Salvare il GeoWorkspace e selezionare File > Save GeoWorkspace.

E’ ora possibile proseguire con la sezione successiva: 1-3 Utilizzare la Legenda
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1-3 Utilizzare la Legenda

La Legenda è un centro di controllo interattivo che determina ciò che è visualizzato nella
map window.

È attraverso la legenda che è possibile controllare quali entità cartografiche (feature class,
immagini, risultati di query, mappe tematiche) sono visualizzate nella map window e la loro
vestizione grafica.

In questo esercizio vedremo come impostare la visualizzazione delle etichette delle regioni
in funzione della scala. Ciò vuol dire che, se il fattore di zoom ci porta al di fuori
dell’intervallo di scala di visualizzazione, le etichette non saranno visualizzate.

1. Fare click destro sulla feature class StateNameLabels, selezionare l’opzione Display
by Scale.

Si può notare come l’icona di una piccola barra di scala rossa e bianca viene
visualizzata sulla sinistra dell’elemento di legenda, per indicare che questa opzione è
stata resa attiva.

2. Fare click destro sulla feature class StateNameLabels, selezionare l’opzione Display
by Range.

La finestra di dialogo Scale Range ci permette di impostare l’intervallo di scala di
visualizzazione delle entità cartografiche. Se la scala di visualizzazione è all’interno
dell’intervallo impostato e la proprietà Display è impostata su By Scale, le entità
vengono visualizzate, altrimenti non vengono visualizzate.

3. Cambiare il valore del campo Minimum a 2,000,000 (2 milioni).

4. Non cambiare il valore del campo Maximum. Premete OK.

Utilizzando i controlli di zoom scopriremo che tutte le volte che ci si trova ad un livello
di zoom inferiore a 1 : 2.000.000 le etichette non verranno mostrate.

Esaminare le Proprietà di Legenda
Anche le caratteristiche di visualizzazione della legenda della Map Window possono
essere modificate a seconda delle esigenze. Vedremo come modificare il colore di
background ed il carattere del titolo.

1. Fare click destro su un elemento di legenda e scegliere Properties.

E’ possibile notare come gli attributi di testo per gli elementi di legenda possono essere
manipolati uno ad uno.

2. Digitare Learning Legend nel campo Title di legenda.

3. Cambiare l’attributo Background color della legenda in giallo chiaro.

4. Possiamo trasformare in grassetto utilizzando il pulsante (Legend entry title) Font,
possiamo ad esempio scegliere il tipo Arial, Bold, e la dimensione 9, e premere il
pulsante OK nella finestra di dialogo Font.
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5. Nella sezione in basso della finestra di dialogo sono presenti tre opzioni di
visualizzazione per le statistiche delle voci di legenda. Mantenere attiva la voce di
default Count of features with geometry.

6. Premere il pulsante OK per chiudere la finestra di dialogo, si possono così visualizzare
i cambiamenti effettuati.

Tutte le voci di legenda sono ora in grassetto, mentre lo sfondo è giallo chiaro.

7. Salvare il GeoWorkspace.

Creare dei Gruppi
Come si può notare la legenda possiede due schede: Display Order e Groups. La scheda
Display Order serve a gestire l’ordine con cui vengono visualizzate le voci dei legenda;
questa scheda verrà utilizzata quando bisogna modificare l’ordine di visualizzazione, per
esempio è raccomandabile posizionare le etichette di una feature sopra la feature stessa.

La scheda Groups, serve invece per creare dei gruppi. E’ possibile creare gruppi
personalizzati ad esempio le features possono essere raggruppate per tematismo, ma
anche per tipo di geometria, o qualunque altra classificazione che l’utente reputi utile.

In questo esercizio si creerà un gruppo dove verrano posizionate le voci di legenda che
non sono utilizzate.

1. Premere il pulsante della scheda Groups di legenda.

2. Fare click con il pulsante destro sulla legenda e scegliere il comando New Group.

E’ possibile scegliere un nome per il nuovo gruppo.

3. Si può chiamare il gruppo Not currently used.

4. Premere il pulsante <ENTER>, o premere il pulsante fuori del nuovo elemento.

Il nuovo gruppo è stato creato e appare all’interno della scheda Groups.
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5. Salvare il GeoWorkspace.

Note:

 Nel seguito di questa guida, quando si chiederà di selezionare un elemento di legenda,
verrà specificato quale scheda di legenda utilizzare per la selezione. Se non dovesse
essere specificato significa che l’operazione che si vuole compiere è indipendente dalla
scheda di legenda.

 A volte si incontreranno i seguenti simboli: o . Il primo sta ad indicare che la
voce di legenda non è valida; può capitare infatti che un attributo venga modificato in
modo da impedirne la visualizzazione. Il secondo indica che la voce di legenda non è
stata caricata, ad esempio, se si disabilita la visualizzazione di un oggetto all’interno
della mappa, si chiude la connessione o il GeoWorkspce, quando la connessione o il
GeoWorkspace vengono aperti nuovamente, l’elemento non viene caricato.

Continuare con la prossima sezione: 1-4 Creare una Nuova Warehouse ed Aggiungere
Dati
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1-4 Creare un Nuovo Warehouse ed Aggiungere Dati
Nella sezione precedente si è creata una connessione ad un warehouse esistente:
USSampleData.mdb. La connessione utilizzata, prevedeva la modalità di sola lettura o
read-only, perciò è stato possibile visualizzare i dati e manipolarne la visualizzazione, ma
non sarebbe stato possibile aggiungerne di nuovi. Vedremo ora come creare una
connessione di tipo read-write, che chiameremo learn.mdb dove sarà possibile leggere e
scrivere nuovi dati.

Per prima cosa aggiungeremo una immagine alla connessione learn.mdb. Poi utilizzando il
comando Output To Feature Classes per scrivere alcuni dei dati contenuti in Connection
to US Data dentro learn.mdb. Si esporteranno le feature classes States e Counties nella
connessione read-write dove sarà possibile fare dei cambiamenti.

Creare un Warehouse Access
In questo progetto creeremo un Warehouse Access, questo tipo di dato può essere creato
e scritto utilizzando GeoMedia Professional. GeoMedia Professional può scrivere anche
all’interno di warehouse di tipo Oracle e SQL, ma il database deve essere creato
esternamente. Le connessioni di tipo MGE, FRAMME e ARC/INFO, sono sempre di tipo
read-only.

1. Selezionare Warehouse > New Warehouse.

2. Selezionare il template di default, normal.mdt, accertandosi che nel campo File name
compaia normal.mdt, poi premere il pulsante New.

3. Nel campo File Name digitare learn.

4. Accertarsi che nel campo Save as type compaia Access Databases (*.mdb), poi
premere il pulsante Save.

Il file è ora salvato nella cartella Warehouse come learn.mdb

Al momento il database è vuoto. Nel prossimo esercizio si cominceranno a caricare dati.

Inserire un Imagine
Nel prossimo esercizio, aggiungeremo un l’immagine USSampleImage.tif che si trova nella
cartella Warehouse, all’interno della Map Window. Una immagine deve essere inserita in
un Warehouse di tipo read-write. Verrà utilizzata a tale scopo la connessione learn.mdb.
Inoltre sarà necessario utilizzare il sistema di coordinate USSampleData.csf, che verrà
attribuito sia all’immagine che al database, in modo che tutte le features aggiunte nel
database avranno lo stesso sistema di coordinate.
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1. Selezionare Insert > Georeferenced Images.

2. Nel menù a tendina Georeference mode selezionare GeoTIFF.

3. All’interno del campo Folder utilizzare, se necessario il pulsante Browse per
selezionare la cartella Warehouses (ad esempio C:\Warehouses).

4. Selezionare il file USSampleImage.tif dalla lista Available files e premere il pulsante >
per aggiungere il file alla lista Selected files.

Note: E’ possibile inserire più immagini contemporaneamente utilizzando il pulsante >
o il pulsante >>.

5. All’interno del gruppo Insert images into accertarsi che all’interno del campo
Warehouse la connessione learn sia stata specificata.

6. All’interno del campo Feature classes with matching coordinate system digitare un
nuovo nome per la feature class associata all’immagine: SampleImages (senza
spazi).

7. Spuntare l’opzione Add new legend entry for feature class.

8. Premere il pulsante OK nella finestra di dialogo Insert Georeferenced Images.

La nuova immagine viene visualizzata nella finestra di mappa.
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Lo stile dell’immagine può essere modificato.

9. Per fare ciò è necessario fare doppio click sulla chiave di stile associata alla voce di
legenda SampleImages.

La finestra di dialogo Legend Entry Properties viene visualizzata a schermo.

10.Digitare 75 per l’attributo Brightness.

11.Premere il pulsante OK nella finestra di dialogo Legend Entry Properties.

12.Selezionare la scheda di legenda Display Order e spostare la voce SampleImages in
basso in modo che sia l’ultima delle voci di legenda.

La voce di legenda SampleImages è stata spostata in basso e per questo motivo non
è più visibile.

13.Fare click con il pulsante destro del mouse sulla voce di legenda SampleImages e
selezionare il comando Locatable Off.

Questa immagine verrà utilizzata come sfondo, non ci sarà perciò bisogno di
selezionarla.

14.Salvare il GeoWorkspace.

Scegliere un Sistema di Coordinate
E’ possibile specificare un sistema di coordinate che verrà attribuito automaticamente a
tutte le features che verranno aggiunte nel database. In questo esercizio si utilizzerà il
comando Feature Class Definition per impostare il sistema di coordinate di default.

1. Selezionare Warehouse > Feature Class Definition.

2. Selezionare la feature class SampleImages dalla connessione learn e premere il
pulsante Review.

3. E’ possibile notare che il sistema di coordinate è impostato su USSampleData, che è
lo stesso sistema di coordinate del GeoWorkspace.

Faremo in modo che il sistema di coordinate venga impostato come predefinito, che
venga cioè attribuito a tutte le features class, che saranno aggiunte nel database.

Quest’ultimo passaggio è necessario solo quando il sistema predefinito è diverso da
USSampleData, altrimenti sarebbe stato possibile saltare questo passaggio.

4. Premere il pulsante Set As Default.
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Il testo (Default) è mostrato alla destra del sistema di coordinate, e sta a significare
che questo sarà il sistema di coordinate predefinito per ogni feature della connessione
learn. Nel prossimo esercizio, si estrarranno delle features dalla connessione
Connection to US Data, per scriverle all’interno della connessione learn attribuendogli
così automaticamente il sistema di coordinate USSampleData.

5. Premere il pulsante OK.

6. Premere il pulsante Close.

7. Salvare il GeoWorkspace.

Esportare dati da un Warehouse Access
Il comando Output To Feature Classes permette di esportare dati da un database di
origine ad uno di destinazione. GeoMedia Professional è capace di esportare da un
qualunque database all’interno di un database Access.

1. Selezionare Warehouse > Output To Feature Classes.

2. Selezionare Connection to US Data come Source connections and queries e
selezionare la connessione learn come Target connection.

3. Nel campo Feature classes selezionare Counties e States.

4. Accertarsi che l’opzione Display target feature classes in map window sia stata
spuntata.

5. Premere il pulsante di scheda Advanced.

6. Rinominare la feature class Counties come OutputCounties cliccando la cella
Counties del Target Feature Class, poi digitare OutputCounties.

7. Rinominare la feature States in OutputStates facendo click sulla cella States della
Target Feature Class, poi digitare OutputStates.

8. Facendo scorrere la finestra verso destra si può verificare che il sistema di coordinate
delle features è USSampleData che è stato impostato come predefinito.

9. Premere il pulsante OK nella finestra di dialogo Output to Feature Classes.

10.Quando viene visualizzato il messaggio che chiede se si vuole continuare, premere il
pulsante Yes.

Le classi di feature di cui si vuole creare un output, cominciano ad essere processate.
La barra di stato indica la percentuale di lavoro effettuato, ed un messaggio viene
visualizzato quando l’output è completo.

11.Premere il pulsante OK quando il messaggio Output complete viene visualizzato.
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12.Il comando Output To Feature Classes creerà anche un file di log GMOTTS.log, che
troveremo nella cartella Warehouses o nella cartella temp. E’ possibile utilizzare il file
per verificare che le operazioni siano state eseguite correttamente.

Le features classes OutputStates e States sono identiche tra loro con la differenza
che OutputStates è una feature class di tipo read-write (così come OutputCounties),
mentre la feature class States è read-only. Ora la feature class States non serve più,
sarà possibile disattivarne la visualizzazione. Anche la feature class OutputCounties
può essere spenta ma, a differenza della feature class States verrà utilizzata
nuovamente nel corso di questa guida.

13.Selezionare le voci di legenda OutputCounties e States ed utilizzare il menù del
pulsante destro del mouse per selezionare Display Off.

Nota: Se si avrà l’esigenza di visualizzare nuovamente le features utilizzare il comando
Display On.

14.Premere il pulsante di scheda Groups.

15.Selezionare le voci di legenda OutputCounties e States e trascinarle all’interno del
gruppo Not currently used.

E’ possibile aprire il gruppo per verificare che le voci siano state aggiunte al gruppo.
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16.Vedremo ora come sia possibile modificare la feature class OutputStates, ad essa
applicheremo lo stile Learning States che abbiamo creato precedentemente.

17.Fare doppio click sulla chiave di stile della voce di legenda OutputStates.

18.Nella finestra di dialogo Legend Entry Properties, aprire la cartella Learning facendo
doppio click su di essa.

19.Selezionare lo stile Learning States

Questo stile è composto da un riempimento azzurro chiaro e da un bordo grigio scuro.

20.Premere il pulsante OK nella finestra di dialogo Legend Entry Properties.

Lo stile Learning States è ora utilizzato per la feature class OutputStates.

21.Nella scheda di legenda Display Order, trascinare l’elemento StateNameLabels
all’inizio della lista delle features, al di sopra di OutputStates, mentre SampleImages
sarà posizionato in fondo alla lista.

Nota: Le altre features non sono visualizzate, quindi il loro ordine non è importante.

22.Salvare il GeoWorkspace.
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Creare una Categoria
GeoMedia Professional offre la possibilità di creare delle categorie, cioè dei gruppi
organizzati di feature classes o di queries. Una volta creata la categoria, sarà possibile
selezionare le features o le queries all’interno della categoria piuttosto che dalle
connessioni o dalle fonti di dati.

Queste categorie possono essere delle classi tematiche (è possibile ad esempio
raggruppare strade e ferrovie sotto la classe trasporti) o delle classi di preferenza (è
possibile ad esempio raggruppare le feature più utilizzate e tralasciare quelle che verranno
utilizzate meno frequentemente).

In questo esercizio, verrà creata la categoria Frequently used che comprenderà tutte le
features che saranno selezionate più frequentemente.

1. Selezionare Warehouse > Categories.

2. Nella finestra di dialogo Categories premere il pulsante New Category.

3. Digitare Frequently used all’interno del campo Name, poi premere il pulsante OK.

4. Mantenendo selezionato Frequently used premere il pulsante Add Features.

5. Aprire la connessione learn e selezionare OutputCounties e OutputStates.

6. Premere il pulsante OK nella finestra di dialogo Add Features.

7. Premere il pulsante Close nella finestra di dialogo Categories.

La categoria Frequently used è stata creata e le features OutputCounties e
OutputStates sono state aggiunte alla categoria. D’ora in poi sarà possibile
selezionare queste features all’interno della categoria come spiegato nella prossima
sezione.

8. Salvare il GeoWorkspace.

Continuare con la prossima sezione: 1-5 Utilizzare le Mappe Tematiche e gli Oggetti di
Mappa
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1-5 Utilizzare le Mappe Tematiche e gli Oggetti di Mappa
Una mappa tematica utilizza colori e trame per evidenziare la distribuzione spaziale delle
entità geografiche rappresentate nella finestra di mappa. Per fare questo GeoMedia
Professional sfrutta gli attributi associati alle entità geografiche che ne descrivono le
caratteristiche. Ricordiamo che gli attributi sono le informazioni non grafiche memorizzate
in una feature class. Gli attributi sono mostrati mediante colonne (campi) nelle finestre
dati. Ogni cella (record) in una colonna contiene un valore di attributo che è associato con
una entità (feature). Ad ogni entità corrisponde, dunque, un vettore di valori uno per ogni
campo.

Creare una Mappa Tematica Utilizzando Colori
Vedremo come creare una mappa tematica con lo scopo di creare una classificazione dei
valori dell’attributo annual snowfall, localizzata nella feature class OutputStates. La
mappa tematica servirà a scegliere uno stato dove costruire degli impianti sciistici. Nel
prossimo esercizio, creeremo una mappa tematica usando dei colori, e modificheremo lo
spessore delle linee di confine degli stati.

1. Prima di creare una mappa tematica, disattiviamo la visualizzazione dell’immagine
raster, premendo il pulsante destro sulla voce della legenda SampleImages e
selezionando Display Off.

2. Selezionare la scheda Groups della legenda, e trascinare l’immagine all’interno del
gruppo Not currently used.

La voce di legenda è ora posizionata all’interno del gruppo di appartenenza.
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3. Selezionare Legend > Add Thematic Legend Entry.

4. Nella finestra di dialogo Add Thematic Legend Entry aprire il menù a tendina Input
feature e premere il pulsante il + accanto alla categoria Frequently used.

5. Selezionare la feature class OutputStates.

6. All’interno del campo Type premere il pulsante Range Thematic.

7. Questa opzione serve a definire la tipologia di mappa tematica che ci si appresta a
creare: il modello Unique Value Thematic si basa sul valore del singolo attributo
all’interno della classe, mentre Range Thematic è basata sul range valori delle
categorie create.

8. Nel menù a tendina Attribute for classification selezionare il campo ANNULSNOW.

9. Premere il pulsante Classify.

10.Selezionare Equal Count nel campo Classification technique.

11.Premere il pulsante OK nella finestra di dialogo Classify.

12.Si lasci spuntata l’opzione Assign colors, poi premere il pulsante nel menù a tendina
al di sotto di esso.

13.Selezionare uno schema di colore.

14.Spostare il cursore sul menù a tendina Assign colors, dove lo schema scelto ed il suo
nome compaiono come tooltip.

15.Notare come i colori scelti nello schema che è stato selezionato appare in basso nella
finestra di dialogo all’interno del campo Style.

16.Premere il pulsante OK nella finestra di dialogo Add Thematic Entry.

La mappa tematica viene visualizzata con i colori scelti che evidenziano la
classificazione per il tematismo dato.

17.La voce tematica di legenda OutputStates è stata creata e posizionata al di sopra
delle altre features, nella legenda si possono leggere le classi create, il range scelto, il
numero delle features appartenenti alle singole classi.

18.Le etichette associate agli stati non sono ora visibili.

19.Utilizzando la scheda di legenda Display Order è possibile trascinare la feature
StateNameLabels in prima posizione.

Le etichette degli Stati sono nuovamente visibili nella mappa, perché sono state
posizionate al di sopra della feature class tematica OutputStates.

IMPORTANTE: L’ordine di visualizzazione può facilitare la lettura della mappa:
tipicamente le etichette vengono posizionate in alto, seguite da simboli, linee mentre le
aree vengono posizionate in fondo.
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20.Salvare il GeoWorkspace.

Modificare una Mappa Tematica
In questo esercizio vedremo come modificare le proprietà della mappa tematica e come
modificare lo spessore delle features areali associate agli stati.

1. Fare doppio click sulla chiave di stile della feature tematica OutputStates.

Viene visualizzata sullo schermo la finestra di dialogo Legend Entry Properties.

2. Premere il pulsante Base style.

3. Nel menù Boundary, impostare il parametro Width a 2.000.

4. Premere il pulsante OK su tutte le finestre di dialogo.

La grandezza del bordo è stata ingrandita per tutte le features appartenenti alla mappa
tematica.
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Selezionare Map Objects
Vedremo come selezionare i Map Objects per poterli utilizzare come input per i comandi di
modifica spostamento, o per cancellare

1. Accertarsi che il tool Select sia selezionato.

Il cursore è una freccia provvista di un indicatore di selezione sulla punta.

L’indicatore di selezione è un cerchio che definisce un range all’interno del quale le
features possono essere selezionati. La grandezza di questa area può essere
modificata utilizzando il comando Tools > Options > SmartLocate. E’ preferibile per
ora non modificare le impostazioni.

2. Spostando il cursore sopra alcune delle features areali che rappresentano gli Stati, ma
senza fare click, si potrà notare come le features cambino colore, questo è il colore di
evidenziazione, ed indica che la feature è stata evidenziata.

3. Spostare il cursore sullo stato Florida.

L’area viene evidenziata.

4. Premere il pulsante sinistro del mouse.

5. Si può notare come lo stato abbia ora un colore differente. Questo colore è il colore di
selezione, e sta ad indicare che la feature è stata selezionata.

Nota: Se viene visualizzata la finestra di dialogo PickQuick chiudere la finestra e
selezionare la feature di nuovo.

E’ possibile modificare i colori che identificano le evidenziazioni e le selezioni.

6. Selezionare Tools > Options.

7. Utilizzare la scheda Map Display, per modificare i colori associati con i controlli Select
e Highlight.

8. Premere il pulsante OK per uscire dalla finestra di dialogo Options quando sono stati
scelti i colori.

9. Utilizzando il pulsante CTRL key, e selezionare due o tre stati.

I pulsanti CTRL o SHIFT, possono essere molto utili in fase di selezione, perché
permettono di selezionare più di un oggetto per volta.

E’ naturalmente possibile sovrapporre oggetti che si sovrappongono, per osservare
come ciò sia possibile, posizionare il mouse su l’etichetta Texas.

10.Se si attende con il mouse in questa posizione, si vedranno comparire tre punti.

11.La simbologia sta ad indicare che in quel punto è presente una sovrapposizione.

12.Senza spostare il mouse, premere il pulsante sinistro del mouse.

Si vedrà apparire la finestra di dialogo PickQuick , che permette di selezionare
l’elemento di interesse tra quelli presenti nell’area di sovrapposizione.
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Nota: Si può notare come nel punto scelto ci sia la sovrapposizione di tre elementi,
infatti la finestra PickQick ha tre caselle, la numero 1 è associate all’etichetta dello
stato, la seconda alla mappa tematica, la terza è la mappa degli stati da cui è stata
originate la mappa tematica.

13.Spostando il cursore sulle finestre, si può leggere il nome della feature e di seguito
selezionarla.

14.Premere il pulsante 2 o 3: entrambe identificano gli stati.

Gli stati sono selezionati.

Note: La finestra di dialog PickQuick viene visualizzata quando il mouse viene
posizionato e lasciato per circa due secondi in punto dove è presente una sovrapposizione
tra features. Tuttavia, in alcuni casi può essere utile visualizzare la finestra di PickQuick
immediatamente, proprio appena il pulsante del mouse viene cliccato.Per ottenere questo
risultato è possibile utilizzare l’opzione Always Display PickQuick dialog on locate
localizzabile all’interno della scheda SmartLocate della finestra di dialogo Option.

Rivedere le Proprietà di Feature
La finestra di dialogo Properties, serve a visualizzare le proprietà di una data feature.

1. Con la selezione ancora attiva, selezionare Edit > Select Set Properties.

E’ ora visualizzata la finestra di dialogo OutputStates Properties.

La finestra di dialogo rivela informazioni sulla feature selezionata, lo stato del Texas,
visualizzando nomi e valori degli attributi associati con la geometria della feature
selezionata.

Note relative alla finestra di dialogo Properties:
- Tutti i campi obbligatori sono visualizzati in rosso, grassetto e sottolineati (il campo
ID, ad esempio).
- E’ possibile lasciare il mouse sulla colonna Value per ottenere il tipo di attributo.
- La finestra di dialogo Properties può essere ridimensionata a piacimento, questo
facilita la fruizione di valori e nomi in essa riportati.

2. Selezionare la scheda General.

Si può notare che l’unità di misura utilizzata per le aree è metri quadri.

Nota: Se non è possibile visualizzare il valore dell’attributo Area ingrandire la finestra.

3. Premere il pulsante Cancel per chiudere la finestra di dialogo.

4. Selezionare View > GeoWorkspace Coordinate System.

5. Selezionare la scheda Units and Formats.

6. Nel campo Type, selezionare Distance. Nel campo Unit selezionare mi utilizzando il
menù a tendina, in modo da impostare le miglia come unità di misura.

7. Selezionare Area nel campo Type, poi selezionare mi^2 (miglia quadrate) dal menù a
tendina Unit.

8. Premere il pulsante OK.

9. Selezionare Edit > Select Set Properties (o fare doppio click sullo stato Texas).
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10.Selezionare la scheda General.

Il campo area viene visualizzato in miglia quadrate.

11.Premere il pulsante Cancel per chiudere la finestra di dialogo OutputStates
Properties.

12.Salvare il GeoWorkspace.

Continuare con la prossima sezione: 1- 6 Utilizzare la Data Window
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1- 6 Utilizzare la Data Window
Una data window è una tabella che contiene gli attributi associati alle geometrie che
vengono inserite in legenda nella map window. Si vedrà ora visualizzare la tavola degli
attributi della feature class OutputStates features.

Prima è necessario scegliere gli attributi che si vogliono visualizzare.

Utilizzo del Comando Attribute Selection
Il comando Attribute Selection serve a scegliere un sottoinsieme di attributi da
visualizzare.

1. Selezionare Analysis > Attribute Selection.

2. Nel campo Select attributes from selezionare OutputStates appartenente alla
categoria Frequently used.

Nel campo Attributes sono elencati i campi di OutputStates.

3. Premere il pulsante Unselect All.

4. Selezionare i seguenti attributi nell’ordine suggerito: ID, STATE_NAME, STAABBRV,
POP, AVETEMP, ANNULRAIN, e ANNULSNOW.

5. Lasciare invariato il campo Query name: Attribute selection of OutputStates.

6. Si può scegliere di non visualizzare l’output della query nè nella map window nè nella
data window.

La query è stata creata ma non aggiunta alla legenda.

Aprire la Data Window
Ora apriremo la finestra dei dati per visualizzare gli attributi che abbiamo selezionato.

1. Selezionare Window > New Data Window.

2. Nella finestra di dialogo New Data Window lasciare il nome predefinito DataWindow1,
poi selezionare la query Attribute selection of OutputStates.

3. Premere il pulsante OK.

La finestra dei dati è ora visualizzata, e contiene una riga per ogni stato.

4. Per poter visualizzare contemporaneamente la finestra dati e la finestra mappa,
utilizzare il comando Window > Tile Horizontally.

5. Per centrare la mappa degli USA nella finestra di mappa, selezionare la map window, e
scegliere View > Pan.

6. Si può ora utilizzare il cursore per centrare la mappa rispetto allo schermo, premere il
pulsante sinistro del mouse e mantenendo il pulsante premuto, trascinare le features.

Accertarsi che la maggior parte della mappa sia visibile, non è un problema se una
piccola parte rimane fuori dalla schermo o coperta dalla legenda.
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7. Accertarsi che la finestra attiva sia la finestra di mappa, poi premere il pulsante ESC,
per uscire dal comando Pan.

8. Selezionare ora una qualunque delle righe utilizzando il selettore di riga, come si può
notare la selezione effettuata si riflette nella map window.

Lo stato corrispettivo viene evidenziato nella map window.

9. Selezionare ora uno Stato utilizzando la map window.

La selezione effettuata si riflette nella data window.

Questo è servito a dimostrare come le selezioni possano essere effettuate sia utilizzando
la geometria, sia utilizzando la tavola degli attributi, in entrambi i casi, la completa
corrispondenza tra un ambiente e l’altro.

Un Esempio delle Capacità di Aggiornamento Dinamico di GeoMedia
Vedremo come GeoMedia Professional gestisce in modo dinamico gli aggiornamenti dei
dati. Utilizzeremo la feature OutputStates, che essendo localizzata tramite una
connessione read-write, si rende disponibile all’editing.

1. Nella finestra dati, si utilizzi il selezionatore di riga per selezionare la prima delle righe
disponibili. Questa riga contiene gli attributi dello stato Alabama.

Viene evidenziato nella map window lo stato dell’Alabama.

2. Accertarsi che almeno una parte dello stato sia visibile nella map window. Se non è
così, rendere la map window attiva, ed utilizzare il comando Pan per rendere lo stato
visibile.

3. Nella finestra di mappa, deselezionare lo stato dell’Alabama facendo click in una
qualunque area bianca dello schermo, in modo da poter vedere nuovamente il colore
attribuito nella mappa tematica allo stato dell’Alabama.

4. Scorrere gli attributi nella data window, per visualizzare la colonna ANNULSNOW.

Si può notare come per questo campo il valore di riga sia 1 per lo stato dell’Alabama.
Nella mappa tematica il colore di questo elemento è lo stesso degli stati confinanti.

5. Modificare il valore del campo ANNULSNOW nella riga corrispondente allo stato
dell’Alabama, cliccando all'interno del campo e digitando il valore 40.

6. Premere il pulsante di un’altra riga dopo aver inserito il valore.

7. E’ interessante notare come all’interno della map window, il colore dello stato
dell’Alabama sia ora differente, esso riflette infatti il cambiamento effettuato all’interno
della tavola degli attributi.
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Come si può osservare, una mappa tematica creata con GeoMedia reagisce
immediatamente ad i cambiamenti effettuati nella tavola degli attributi.

8. Chiudere ora la finestra dati.

9. Ingrandire al finestra di mappa.

10.Selezionare View > Pan per accertarsi che la mappa sia visualizzata in modo
appropriato.

11. Il comando Fit All andrebbe bene per il nostro scopo, tuttavia utilizzando il comando
Pan, non si dovrà modificare la scala di visualizzazione.

12.E’ possibile ora disattivare la visualizzazione della mappa tematica cliccando con il
pulsante destro sulla voce di legenda OutputStates e selezionando Display Off.

La mappa tematica non è ora visibile.

13.Selezionare la scheda Groups, poi trascinare la mappa tematica rappresentata dalla
voce di legenda OutputStates all’interno del gruppo Not currently used.

14.Salvare il GeoWorkspace.

Congratulazioni! Avete completato la prima parte del tutorial di GeoMedia Professional.
Potete ora continuare con la sezione successiva, o scegliere di continuare con un capitolo
di maggiore di interesse.
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2 – Analisi dei Dati
2-1 Utilizzo degli Attributi Funzionali
Si possono utilizzare gli attributi funzionali (Functional Attributes) per svolgere una
grande varietà di operazioni; in questa sezione useremo il comando per creare due nuovi
attributi, AreaOfCounty e PopulationDensity. Nel prossimo esercizio, otterremo area e
densità di popolazione per alcune regioni dello stato del Wisconsin. Vedremo anche come
si può utilizzare l’ouput di un attributo funzionale come input per un altro.

In questo esempio, creeremo prima un filtro spaziale per visualizzare le regioni dello stato
che abbiamo scelto. Successivamente visualizzeremo la feature class OutputCounties,
creata precedentemente. Poi, utilizzeremo il filtro spaziale alla feature class
OutputCounties per visualizzare solo le regioni desiderate. In seguito useremo il
comando Select Set to Query, per selezionare solo alcune regioni di questo stato, e poi
creeremo una interrogazione (query) per selezionare quelle regioni che vogliamo
immettere nel comando Functional Attributes. In ultimo, useremo il comando Functional
Attributes per creare nuovi attributi, e vedremo anche cosa succede all’attributo
PopulationDensity quando vengono modificati i dati per una delle contee.

Prima di Cominciare
Prima di cominciare questo esercizio Data Analysis, fate i seguenti passaggi:

1. Se la sessione precedente è stata completata usando learn.gws (in modo che
learn.gws e learn.mdb siano già stati salvati), fate partire GeoMedia Professional se
non è già aperto, e aprite learn.gws. Passare al punto 3.

- OPPURE -

1. Se non avevate completato il precedente esercizio, copiate il file learn_data.gws nella
vostra cartella del GeoWorkspaces nel learn.gws, e copiate il file learn_data.mdb nella
vostra cartella Warehouses nel learn.mdb (è fortemente raccomandato che conserviate
file learn.gws e learn.mdb originali, se essi esistono con nomi differenti). Poi, aprite
GeoMedia Professional se non è già attivo, e poi aprite learn.gws.

2. Se i files USSampleData.mdb e learn.mdb sono memorizzati in percorsi diversi da
C:\Warehouses, quando si cercherà di aprire il file learn.gws si otterrà il seguente
messaggio di errore: "An error occurred while attempting to open connection
'<connection name>'. Verify that your connection parameters are correct and try again."
Per risolvere il problema, utilizzare il pulsante Browse per localizzare i files.mdb file,

poi premere il pulsante OK

Ricorda: Quando GeoMedia sembra non rispondere ai comandi (ad esempio il tasto ESC
non permette di uscire dai comandi), accertarsi che la finestra attiva sia GeoMedia
Professional e non la finestra di tutorial.
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Definire un Filtro Spaziale Areale
Un filtro spaziale definisce un’area di interesse nella map window. Utilizzando un filtro
spaziale, vengono visualizzate e sono rese accessibili, solo le feature contenute nell’area
definita. I filtri spaziali sono opzionali, vedremo come definirne uno per visualizzare le
regioni dello stato del Wisconsin.

1. Selezionare Spatial Filter Options come mostrato nella figura sottostante.

2. Nel menù a tendina selezionare Overlap come Spatial operator.

3. Lasciare l’opzione Display filter selezionata.

4. Nella finestra di dialogo Spatial Filter Options premere il pulsante OK.

5. Premere il pulsante lo stato del Wisconsin per utilizzare l’area come filtro spaziale.

6. Premere il pulsante l’opzione Select Set nella toolbar Spatial Filters.

La selezione fatta è ora evidenziata.

E’ possibile ora attivare la visualizzazione della feature class OutputCounties
utilizzando la voce di legenda associata.

7. Selezionare la scheda di legenda Display Order.

8. Accertarsi che la voce di legenda OutputCounties si posizionata al di sopra della voce
di legenda OutputStates.

9. Premere con il tasto destro la voce di legenda OutputCounties e selezionare Display
On.

La feature class OutputCounties è ora visualizzata.
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10.Utilizzando la scheda di legenda Groups trascinare la feature class OutputCounties
all’interno del gruppo Not Currently Used.

Convertire una Query in un Insieme di Selezione
E’ possibile creare una selezione e convertire le feature selezionate in una query,
utilizzando il comando Select Set to Query. L’utilità di questo comando è permettere al
contenuto della selezione di essere preso come input verso altri comandi, come la
creazione di etichette o la creazione di zone di rispetto (buffer zone). In questo esercizio,
selezioneremo alcune regioni e poi vedremo come convertirle in una query.
Successivamente invece si mostrerà come utilizzare, la query come un input per il
comando Functional Attributes.

Prima di utilizzare il comando Select Set to Query, sarà opportuno sfruttare il controllo di
zoom per visualizzare meglio le regioni che si trovano nel sud dello stato.

1. Selezionate View > Zoom > In.

2. Posizionare il cursore dello zoom in avanti giusto al confine inferiore dello stato del
Wisconsin, come si vede nella figura sottostante.

3. Premere e tenere premuto il pulsante sinistro del mouse, poi trascinare il cursore in
modo da ottenere una vista simile alla figura sottostante.

La view è stata così ingrandita.
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4. Premere ESC per uscire dal controllo di Zoom.

Con lo scopo di facilitare la selezione, disattiveremo la funzione Locatable per la
feature class che rappresenta gli stati.

5. Premere con il pulsante destro la voce di legenda OutputStates e selezionare
Locatable Off.

Selezioneremo adesso alcune regioni.

6. Tenendo premuto il pulsante SHIFT, selezionare le sei regioni più a sud dello stato del
Winsconsin, come mostrato nella figura sottostante.

7. Selezionare Analysis > Select Set to Query.

8. Tenere selezionata la feature class OutputCounties nel campo Select features from.

Note sulle limitazioni del comando:
- La risultante query conterà dati appartenenti ad una solo feature class, o query.

- Features sprovviste di campo chiave non possono essere processate.

9. Lasciare il nome predefinito per la query di output, Selection of OutputCounties,
come disposto nel campo Query name.

Il risultato della query verrà visualizzato solo nella finestra di mappa.

10.Abilitare l’opzione Display query in map window.

11.Premere il pulsante Style.

12.Premere il pulsante Properties.

13.All’interno della finestra di dialogo Style Properties abilitare l’opzione Simple Fill
Style contenuta in Fill Styles.

14.Premere il pulsante Color, nell’area destra della finestra di dialogo.

15.Selezionare uno tra i colori verde chiaro disponibili e premere il pulsante OK nella
finestra di dialogo Color.

Lo stile con colore di riempimento verde è visualizzato nella area destra della finestra
di dialogo.
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16.Accertarsi che l’attributo Translucency sia impostato a 0.

17.Premere il pulsante OK nella finestra di dialogo Style Properties e nella finestra di
dialogo Select Style.

18.Lasciare disattivata l’opzione Display query in data window.

19.Premere il pulsante OK.

La query composta da sei regioni è stata creata dalla selezione effettuata, visualizzata
nella finestra di mappa e nella legenda.

Creazione di un Attributo Funzionale
Prenderemo i risultati ottenuti con il precedente esercizio, la query ottenuta
dall’impostazione di selezione, e la useremo come imput per il comando Functional
Attributes. Useremo questo comando per creare due nuovi attributi per ognuna di quelle
contee nello stato (sebbene potremmo subito creare in maniera facile nuovi attributi per
tutte le contee dello stato).

Il comando Functional Attributes visualizza la finestra di dialogo Functional Attributes.
La funzione di questa finestra di dialogo è di permetterci di definire i valori dei campi come
attributi calcolati. Questa finestra di dialogo visualizza un’abbondanza di funzioni
statistiche che possono essere applicate a livello del singolo campo: funzioni geometriche
come il Merge, funzioni sulle date come Day o Hour, Funzioni matematiche come il Sin o il
Log, funzioni statistiche come Average o Sum, e molte altre. Oltre a queste, possono
essere usate una varietà di operatori: Aritmetici, Bit Relazionari, Comparativi, Logici,
Concatenatori di Stringhe.

In questo esercizio, per queste 6 contee per lo stato del Winsconsin, creeremo due nuovi
attributi funzionali, AreaOfCounty e PopulationDensity. Prima creeremo AreaOfCounty, e
poi vedremo come questo nuovo attributo può essere usato per creare PopulationDensity.
Vedremo inoltre cosa succede, quando la popolazione di una di queste contee cambia.

1. Selezionare Analysis > Functional Attributes.

2. All’interno del campo Add functional attributes for, aprire Queries utilizzando il menu
a tendina, e selezionare Selection of OutputCounties.

Vedremo ora come creare un nuovo attributo funzionale che contiene la regione.

3. Premere il pulsante New.

4. Appare la finestra di dialogo Functional Attribute.
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Scriveremo un nuovo nome per l’attributo funzionale.

5. Nel campo Functional attribute name digitare AreaOfCounty.

6. Nel campo Categories scegliere Geometry.

7. Nel campo Functions selezionare AREA.

8. E’ possibile notare la sintassi del comando che è descritta nell’area in basso a sinistra
nella finestra di dialogo: AREA(Geometry,MeasType,UnitofMeasure).

9. Fare doppio click su AREA.

Nel campo Expression appare ora l’espressione AREA().

10.Posizionare il cursore all’interno delle parentesi.

11.Nel campo Attributes fare doppio click su Input.Geometry.

L’espressione AREA(Input.Geometry) è ora visualizzata nel campo Expression.

12.Aggiungeremo ora gli altri parametri richiesti per la funzione AREA.

13.Posizionare ora il cursore prima della parentesi più a destra e digitare una virgola (,).

14.Nel campo Categories premere il pulsante Constants.

La lista Constants viene visualizzata nel campo successivo.

15.Scorrere la lista Constants fino alla costante ProjectedMeas. Fare doppio click sulla
costante.

16.Digitare un’altra virgola, poi scorrere la lista fino alla costante SquareMile. Fare doppio
click sulla costante.

L’espressione AREA(Input.Geometry,ProjectedMeas,SquareMile) dovrebbe ora
essere visualizzata nel campo Expression.

17.Premere il pulsante Add per creare un nuovo attributo funzionale, poi premere il
pulsante Close per chiudere la finestra di dialogo.

Vedremo come creare un nuovo attributo funzionale che servirà a calcolare la densità
di popolazione. Utilizzeremo l’output dell’attributo AreaOfCounty come input per la
nuova funzione PopulationDensity.

18.Premere il pulsante New.

La finestra di dialogo Functional Attribute è ora visualizzata.

Bisognerà ora inserire un nome per l’attributo funzionale.

19.Nel campo Functional attribute name digitare PopulationDensity.

20.Scorrere la lista degli attributi. E’ possibile notare come siano presenti gli attributi
standard, ma anche l’attributo AreaOfCounty creato precedentemente, che compare
con il nome Output.AreaOfCounty.

21.Selezionare Input.POP facendo doppio click nel campo Attributes.

22.Premere il pulsante che indica l’operatore divisione.

23.Fare doppio click sull’attributo Output.AreaOfCounty presente nel campo Attributes.

24.L’espressione Input.POP/Output.AreaOfCounty dovrebbe essere presente nel
campo Expression.
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25.Premere il pulsante Add per creare il nuovo attributo funzionale, poi premere il
pulsante Close.

Entrambi gli attributi funzionali creati sono presenti nella lista Output functional
attributes.

25.Nel campo Query cambiare il nome con PopulationDensity of 6 OutputCounties.

26.Visualizzeremo ora le query create, nella map window e nella data window.

27.Mantenere l’opzione Display functional attributes in map window selezionata, ed
utilizzare il nome predefinito.

28.Mantenere l’opzione Display functional attributes in data window selezionata, ed
utilizzare il nome predefinito.

29.Premere il pulsante il pulsante Style che si trova accanto al campo Map window
name.

La finestra di dialogo Select Style è ora visualizzata.

30.Non è stato ancora definito uno stile per questa query, è possibile farlo ora.

31.Premere il pulsante Properties.

32.Nel campo Fill Styles, abilitare e selezionare Simple Fill Style.

33.Premere ora il pulsante Color e selezionare il colore giallo.

34.Premere il pulsante OK nella finestra di dialogo Color.

35.Accertarsi che il valore dell’attributo Translucency sia 0.

36.Premere il pulsante OK nelle finestre di dialogo.

La finestra dei dati viene visualizzata al di sopra della map window.

Osserviamo il Risultato delle Query e le Modifiche ai Dati
In questo esercizio visualizzeremo i risultati nella finestra di mappa e nella finestra dati, ed
osserveremo cosa avviene quando vengono modificati i dati.

1. Selezionare Window > MapWindow1 per portare la map window in primo piano.

2. Spostare la legenda in alto nella map window.

Nota: Rendere o lasciare visibile la legenda durante questo esercizio. Si potrà
disabilitare la visualizzazione degli elementi contenuti nel gruppo Not currently used in
modo da poter visualizzare tutti gli altri elementi.

3. Con lo scopo di visualizzare la map window e la data window contemporaneamente
selezionare Window > Tile Horizontally.

La densità di popolazione viene ora visualizzata nella finestra di mappa, mentre i dati
sono visualizzati nella data window, dove compaiono anche gli attributi creati
precedentemente: AreaOfCounty e PopulationDensity.

4. Se questi campi non sono visibili, è sufficiente scorrere la tabella, AreaOfCounty e
PopulationDensity, sono posizionati in fondo alla tavola.

Nota: Questi campi sono di tipo read-only perciò le colonne associate sono
ombreggiate.
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5. Premere il pulsante sinistro del mouse sulla map window per renderla attiva, poi
selezionare View > Pan per spostare i risultati della query al centro della finestra.

6. Premere il pulsante sinistro sulla regione più grande (Grant County) tra quelle
selezionate. La densità di popolazione per questa regione è circa 41.6.

Vedremo ora cosa succede quando vengono modificati i dati. Per prima cosa
posizionare la feature class OutputCounties in testa alle voci di legenda.

7. Utilizzando la scheda Display Order selezionare la voce di legenda
OutputCounties, poi utilizzare il mouse per trascinarla in alto.

Cambieremo il valore della popolazione di una delle regioni.

8. Nella map window, fare doppio click sulla prima delle regioni a partire da sinistra
(Grant County). Oppure utilizzare il comando Edit > Select Set Properties per
effettuare la selezione.

Viene visualizzata la finestra di dialogo OutputCounties Properties.

9. Modificare il valore POP (Popolazione) e portarlo da 49264 a 60000, e premere il
pulsante OK.

Il valore PopulationDensity della regione Grant nella data window è ora stato
cambiato da circa 41.6 a circa 50.7.

10. Chiudere la data window.

11. Ingrandire la map window.

12. Selezionare View > Fit All per accertarsi che la mappa venga contenuta
interamente nella map window.
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Rimuovere il Filtro Spaziale
E’ ora possibile rimuovere il filtro spaziale.

1. Premere il pulsante Remove Filter, come mostrato nella figura sottostante.

Il filtro spaziale è stato rimosso.

2. Disattivare la visualizzazione delle feature classes PopulationDensity of 6
OutputCounties, OutputCounties, e Selection of OutputCounties selezionando gli
elementi e utilizzando il comando a destro Display Off.

3. Selezionare la scheda Groups e spostare questi tre elementi nel gruppo Not
currently used.

4. Selezionare View > Fit All.

5. Le feature classes StateNameLabels e OutputStates sono visualizzate nella
finestra di mappa.

Assegnare un Nome alla Legenda
Ora daremo un nome alla legenda per la mappa degli Stati Uniti. Assegnare un nome alla
legenda ci permette di applicarla ad un'altra mappa all’interno dello stesso
GeoWorkspace. Le feature class, saranno visualizzate con la simbologia dalla legenda
nominata.
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1. Selezionare Legend > Name Legend.

2. Nel campo Name digitare Learning Legend1.

3. Premere il pulsante OK.

4. Salvare il GeoWorkspace.

Continuare con la prossima sezione: 2-2 Costruire Queries
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2-2 Costruire Queries
Una query è un’interrogazione, una richiesta di estrazione di informazioni. Quando
effettuiamo una query, richiediamo di visualizzare le feature che soddisfino specifici criteri.
Con GeoMedia Professional possiamo costruire le query servendoci di una finestra di
dialogo senza bisogno di conoscere il linguaggio SQL.

Le query estraggono quelle informazioni che soddisfano i nostri criteri, esplorando il
contenuto dei warehouse. Questo vuol dire che ogni volta che viene eseguita una query, si
ottengono risultati aggiornati coerentemente con eventuali modifiche che i warehouse
possono aver subito.

Modificare la View
E’ possibile creare una nuova map window dove visualizzare i risultati. Nella nuova map
window, disporremo di una visione ravvicinata degli stati del Minnesota e del Wisconsin,
che è l’area che contiene i risultati finali delle interrogazioni sulle località sciistiche. Prima
di creare la nuova map window, sarà opportuno assegnare alla map window corrente un
nome più descrittivo.

Assegniamo ora alla map window corrente un nome descrittivo.

1. Selezionare Window > Map Window Properties.

2. Nel campo Map window name digitare US Map.

3. Premere il pulsante OK.

4. Selezionare Window > New Map Window per aprire una nuova map window.

5. Nella finestra di dialogo New Map Window inserire il nome Final Counties.

6. Selezionare Learning Legend1.

7. Premere il pulsante OK.

La nuova finestra di mappa Final Counties, è ora visualizzata.

8. Selezionare View > Zoom > In.

9. Sarà ora possibile zoomare l’area degli USA detta Midwest.

10. Posizionare lo zoom al centro dello stato North Dakota, localizzato al nord nella
parte centrale degli USA.

11. Premere e tenere premuto il pulsante del mouse, poi trascinare il mouse fino al
limite in basso a destra dello stato dell’Ohio.
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12. Lasciare ora il pulsante del mouse.

La vista è ora ingrandita coerentemente con il nostro scopo.

13. Premere ESC per uscire dal controllo di Zoom.

Nota: Le etichette degli stati risultano ingrandite alla scala scelta. Ciò avviene perché
questo elemento è stato settato su Paper (La grandezza è reale alla scala nominale
di mappa) — ovvero le etichette si ingrandisco e rimpiccioliscono quando viene
utilizzato un controllo di zoom.

14. Salvare il Geoworkspace.

Costruire una Query
Ora vedremo come utilizzare una attribute query, cioè il comando che ci permette di
interrogare il database per specifici valori o rispetto un range di valori di un attributo o una
combinazione di attributi che si vogliono estrarre da una feature class.

Vogliamo sapere ad esempio quali stati hanno abbondanti precipitazioni nevose e
contemporaneamente basse temperature. Questi stati potrebbero essere buoni candidati
per la localizzazione di nuovi impianti sciistici.

1. Selezionare Tools > Options.

2. All’interno della scheda General accertarsi che l’opzione Confirm show value
operations sia selezionata.

3. Quando l’opzione Confirm show value operations è abilitata, quando viene
cliccato il pulsante Show Values della finestra di dialogo Filter, appare un messaggio
sullo schermo. Il messaggio avverte che visualizzare tutti i valori disponibili per
l’attributo scelto potrebbe servire molto tempo.

4. Premere il pulsante OK nella finestra di dialogo Options.
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5. Selezionare Analysis > Attribute Query per visualizzare la finestra di dialogo
Attribute Query dialog box.

6. Selezionare OutputStates della categoria Frequently used dal menù a tendina
Select Features in.

7. Premere il pulsante Filter, serve a visualizzare la finestra di dialog filter per la
feature OutputStates.

8. E’ possibile ora specificare quali features si vogliono ispezionare attraverso l’uso
del filtro.

9. All’interno della lista degli attributi, selezionare ANNULSNOW (precipitazione
nevosa annuale).

10. Premere il pulsante contraddistinto da una freccia che punta verso il basso, situata
al di sotto del campo Attributes.

11. L’attributo, ANNULSNOW, è ora visualizzato nel campo Filter.

Nota: Alternativamente all’utilizzo della freccia, si può ottenere lo stesso risultato
facendo doppio click sull’elemento scelto.

12. Selezionare l’operatore > maggiore di.

Attributo ed operatore compaiono nel campo Filter nella parte bassa della finestra di
dialogo. E’ anche possibile inserire un comando SQL all’interno del campo.

13. Premere il pulsante Show Values.

14. Quando viene chiesto se si vuole continuare, confermare cliccando su Yes.

Dalla lista di valori, selezionare 40 poi premere il pulsante contraddistinto da una
freccia che punta verso il basso situata al di sotto del campo Values.

Nel campo Filter è ora visualizzata l’espressione ANNULSNOW > 40.

15. Selezionare l’operatore AND.

16. Selezionare l’attributo AVETEMP (temperatura media) poi premere il pulsante la
freccia che punta verso il basso situata al di sotto del campo Attributes.

17. Selezionare l’operatore < minore di.

18. All’interno del campo Filter digitare il valore 50.

Ora l’espressione ANNULSNOW > 40 AND AVETEMP < 50 è visualizzata nel campo
Filter.

19. Premere il pulsante OK nella finestra di dialogo OutputStates Filter.

20. Nel campo Query name nella finestra di dialogo Attribute Query digitare States
by Snow/avetemp.

Utilizzare un nome descrittivo per le queries, può risultare conveniente, fare ciò può
infatti aiutarci a localizzarle e riutilizzarle.

21. Visualizzeremo l’output della query solamente nella map window.

22. Deselezionare l’opzione Display query in data window.

23. Premere il pulsante Style.
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24. Premere il pulsante Properties.

25. All’interno di Fill Styles, abilitare e selezionare Simple Fill Style.

26. Selezionare Trellis dal menù a tendina Fill type.

27. Selezionare 30 come valore di Translucency, selezionare azzurro chiaro come
Color.

28. Premere il pulsante OK nella finestra di dialogo Style Properties e selezionare
Select Style dialog box.

29. Premere il pulsante OK nella finestra di dialogo Attribute Query per visualizzare a
schermo i risultati dell’interrogazione.

I risultati della query States by Snow/avetemp sono ora visualizzati nel fogli di mappa
con i colori ed il pattern scelti.

Le etichette sono state parzialmente oscurate dal risultato delle query.

Avendo impostato il parametro Translucency a 30, riusciamo a vedere attraverso le
features. Se questo parametro fosse stato nullo, le features sarebbero state
completamente opache, perciò non avremmo potuto vedere ciò che c’è sotto.

30. Utilizzando la scheda Display Order trascinare la feature StateNameLabels in
testa alle voci di legenda.

Ora le etichette degli stati sono visibili.
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31. Salvare il GeoWorkspace.

Definire un Filtro Spaziale – Fence Rettangolare
Un filtro spaziale definisce un’area all’interno della map window. Come visto in
precedenza, quando si utilizzano i filtri spaziali, solo le feature nell’area definita sono
visualizzate e accessibili. I filtri spaziali sono opzionali, vedremo tuttavia come definire un
filtro di recinzione (by Fence) per visualizzare le features all’interno di due stati.

Vogliamo ora focalizzarci sugli stati Minnesota e Wisconsin dove si vogliono localizzare le
aree più adatte alla creazione dei nuovi impianti sciistici.

1. Selezionare Spatial Filter Options.

2. Accertarsi che l’opzione Overlap sia selezionata, poi premere il pulsante OK.

3. Selezionare l’opzione Rectangular Fence.

Il cursore assume la forma di croce.

Con lo scopo di definire un filtro, si posizioni un rettangolo che contenga il confine
degli stati del Minnesota e Wisconsin, come descritto dalla figura sottostante.
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Il rettangolo si fatto contiene alcune regioni appartenenti ad altri stati, vedremo di
seguito come modificare la query per visualizzare solo le features contenute negli stati
di Wisconsin e Minnesota.

4. Posizionare il primo punto nell’angolo in alto a sinistra, appena al di sopra del
angolo in alto a sinistra dello stato del Minnesota.

5. Premere e tenere premuto il pulsante sinistro del mouse, fino a raggiungere il punto
limite in basso a destra dello stato del Wisconsin, poi lasciare il pulsante.

Il filtro con limiti rettangolari è ora visualizzato sullo schermo.

6. Premere il pulsante per accettare il filtro.

D’ora in poi quando verranno aggiunte features o queries, verranno visualizzate solo le
componenti che si trovano all’interno del filtro spaziale.

Aggiungere Voci alla Legenda
Aggiungeremo ora due feature classes dalla connessione read-only che potremo
visualizzare ed interrogare.

1. Selezionare Legend > Add Legend Entries.

2. Nella finestra di dialogo Add Legend Entries aprire Connection to US Data.

3. Nella lista delle feature classes spuntare Cities e Interstates.

4. Premere il pulsante OK.

Sono state ora aggiunte città e autostrade, ma solo le features che si trovano all’interno
del filtro spaziale vengono visualizzate nella map window.
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Come si può ricordare ricordare, un filtro spaziale è il modo più conveniente per
visualizzare la porzione dei dati a cui si è interessati.

Andremo ora a selezionare lo stile di visualizzazione predefinito per la feature Interstates.

5. Fare doppio click sull’elemento di stile della voce di legenda Interstates.

6. Nella finestra di dialogo Legend Entry Properties aprire la cartella Learning e
selezionare lo stile con il nome Interstates.

Lo stile predefinito è visualizzato nel lato destro della finestra di dialogo.

7. Premere il pulsante OK nella finestra di dialogo Legend Entry Properties.

8. Disabilitare la visualizzazione della feature class Cities: fare click destro sulla
corrispondente voce di legenda Cities e selezionare Display Off.

9. Nella scheda Groups trascinare l’elemento Cities all’interno del gruppo Not
currently used.

10. All’interno della scheda Display Order spostare la voce di legenda
StateNameLabels in testa alla legenda di modo che abbia priorità massima.

Costruire un’altra Query
Vedremo ora come utilizzare il filtro sugli attributi, per trovare la città più grande tra quelle
comprese nel filtro spaziale.

1. Selezionare Analysis > Attribute Query per visualizzare la finestra degli attributi
Attribute Query.

2. Dal menù a tendina Select features in selezionare la feature class Cities dalla
connessione Connection to US Data.

3. Premere il pulsante Filter per visualizzare la finestra di dialogo Cities Filter.
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4. Selezionare POP (popolazione) dalla lista degli attributi, poi premere il pulsante
sulla freccia verso il basso situata al disotto della lista.

5. Selezionare l’operatore > maggiore di.

Attributo ed operatore appaiono nel campo Filter.

6. Digitare il valore 100000 (cioè 100.000) all’interno del campo Filter.

7. L’espressione POP > 100000 è ora visualizzata nel campo Filter.

8. Premere il pulsante OK nella finestra di dialogo Cities Filter.

9. All’interno del campo Query name, nella finestra di dialogo Attribute Query
digitare Major Cities.

Si visualizzino i risultati solo nella map window.

10. Accertarsi che l’opzione Display query in data window sia disabilitata.

11. Premere il pulsante OK per visualizzare la query.

I risultati della query sono visualizzati nella map window.

E’ possibile osservare come solamente le città che soddisfano i criteri della query e che
sono localizzate all’interno del filtro spaziale vengono visualizzate.

Nota: Le città possono essere di numero variabile compatibilmente con la grandezza del
filtro spaziale applicato.

Modificare una Interrogazione
Vedremo ora come si può modificare la query Major Cities con lo scopo di visualizzare
solo le features contenute all’interno degli stati Minnesota o Wisconsin.

1. Selezionare Analysis > Queries per visualizzare la finestra di dialogo Queries.

2. Dalla lista delle query selezionare Major Cities.

3. Premere il pulsante Properties.
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4. Nella finestra di dialogo Query Properties premere il pulsante Filter.

5. Nella finestra di dialogo Cities Filter premere il pulsante all’interno del campo
Filter, posizionare il cursore davanti alla stringa da modificare POP > 100000.

6. Premere il pulsante che individua l’operatore AND.

7. Premere il pulsante che individua l’operatore parentesi ().

Spostare il punto di intersezione all’interno delle parentesi. Poi selezionare, nell’ordine qui
descritto:

 L’attributo STATE_NAME

 La freccia verso il basso che si trova al di sotto della lista

 L’operatore = uguale

 Show Values

 Yes al messaggio

 MINNESOTA dalla lista dei valori

 L’operatore OR

 L’attributo STATE_NAME

 La freccia verso il basso

 L’operatore = uguale

 WISCONSIN dalla lista dei valori

 La freccia verso il basso

Il testo dovrebbe figurare come POP > 100000 AND (STATE_NAME = 'Minnesota' OR
STATE_NAME = 'Wisconsin').

IMPORTANTE: verificare che il testo contenuto nel campo Filter sia identico al testo
mostrato sopra. Se le due stringhe non sono identiche è possibile avere dei risultati non
corretti.

8. Premere il pulsante OK nella finestra di dialogo Cities Filter e nella finestra di
dialogo Query Properties.

9. Premere il pulsante Close nella finestra di dialogo Queries.

I risultati della query e la voce di legenda sono stati aggiornati includendo solo quelle città
che si trovano all’interno degli stati Minnesota e Wisonsin
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10. Salvare il GeoWorkspace.

Assegnare un Simbolo alle Città Principali

E’ possibile evidenziare le Major Cities (città principali) assegnando alla feature
corrispondente una simbologia di rilievo.

1. Fare doppio click sulla chiave di stile della voce di legenda Major Cities.

2. Premere il pulsante Properties.

3. Nella finestra di dialogo Style Properties selezionare GeoMedia Feature Symbol
Files dal menù a tendina Type.

4. Premere il pulsante Browse per aprire il file di simbologia transportation.fsm.

Il percorso predefinito per i simboli è GeoMedia Professional\Symbols.

5. Dal menù a tendina Name selezionare City Symbol #4.

6. Selezionare 10.000 per l’attributo Size.

7. Accertarsi che l’opzione Define override color sia abilitata in modo da utilizzare i
colori predefiniti per il simbolo.

8. Premere il pulsante OK per tutte le finestre di dialogo.

I simboli sono correttamente posizionati.

9. Nella scheda Display Order spostare la voce di legenda StateNameLabels al
primo posto, seguita da Major Cities, Interstates, States by Snow/avetemp, e
OutputStates.

10. Salvare il GeoWorkspace.



54 di 213

Continuare con la sezione 2-3 Utilizzo della Simbologia
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2-3 Utilizzo della Simbologia
Nella sezione precedente, abbiamo visto come modificare una query e la simbologia
associata per rendere più significativa la mappa. In questa sezione si vedrà come
modificare la simbologia coerentemente con i valori di attributo (verranno utilizzati i valori
di popolazione, il campo POP), poi come creare dei simboli, da utilizzare nella Map
Window, con la condizione che il nome del simbolo coincida con il valore di un attributo
(verrà utilizzato il nome della città memorizzato nell’attributo CITY_NAME).

Esempio #1 – Associare la Simbologia ai Valori di Attributo
E’ già stata creata la query Major Cities, che include quattro città cioè Minneapolis e St.
Paul, nel Minnesota, e Milwaukee e Madison nel Wisconsin. La simbologia utilizzata è
composta da 4 piccoli punti.

In questo esercizio, si vedrà un esempio che servirà a chiarire come sia possibile utilizzare
una simbologia differente per valori differenti di attributo: modificheremo lo stile di
visualizzazione dei punti associati con le città proporzionalmente all’attributo di
popolazione (POP).

1. Fare doppio click sulla chiave di stile dell’elemento di legenda Major Cities.

2. Premere il pulsante Properties.

3. Premere il pulsante di scheda Advanced.

4. Premere sulla riga Size della colonna Attribute Based.

5. Dal menù a tendina scegliere Expression.

La finestra di dialogo Expression è ora visualizzata.

La finestra di dialogo permette di creare un nuovo attributo funzionale.

6. Utilizzando il Blocco note di Windows, aprire il file di testo ABS_IF_SIZE.txt
contenuto nella cartella Learning.

7. Copiare il contenuto del file.

8. Incollarne il contenuto nel campo Expression.

9. E’ possibile osservare che il testo che stiamo utilizzando, contiene:

La stringa utilizzata contiene il comando IF. La sintassi del comando è:

IF (condizione, valore se vero, valore se falso)

Nel nostro caso la condizione prevede che il valore di popolazione (POP) sia compreso tra
0 e 200.000. Se la condizione è verificata, come nel caso della città di Madison -nel
Wisconsin, che ha valore di popolazione 191.262, l’attributo Size vale 150.

Nota: E’ possibile specificare l’unità di misura per i simboli visualizzati all’interno della
scheda Symbol Style della finestra di dialogo Style Properties utilizzando la finestra di
dialogo Style Units (da Legend > Styles, scegliere lo strumento Units nella toolbar). In
questo caso l’unità è points. (E’ possibile scegliere millimetri, centimetri o pollici). In ogni
caso all’interno della scheda Advanced della finestra di dialogo Style Properties
l’attributo Size è espresso in unità di tipo HiMetric (0.01 millimetri). La dimensione 352
corrisponde approssimativamente a 10 punti.

Per le rimanenti tre città la cui popolazione non è compresa tra 0 e 200.000 viene utilizzato
il valore contenuto nella terza parte dell’istruzione IF, quindi quando la popolazione è
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compresa tra 200,000 e 300,000, l’attributo size vale 300 come nel caso della città St.
Paul, Minnesota, la cui popolazione è 272.235.

Per le rimanenti due città, il cui valore non si trova compreso negli intervalli descritti sopra,
è stata utilizzata una seconda espressione IF. Questa espressione impone che quando il
valore di popolazione è compreso tra 300.000 e 400.000, come nel caso della città
Minneapolis nel Minnesota, l’attributo size deve valere 450. Per quanto riguarda l’ultima
delle quattro città (Milwaukee nel Wisconsin, dove il valore di popolazione è 628.088),
viene utilizzato il valore 600 per l’attributo size.

10. Premere il pulsante OK nella finestra di dialogo Expression.

Ora il testo che è stato copiato dal file di testo appare all’interno della riga Size nella
colonna Attribute Based.

11. Premere il pulsante OK nella finestra di dialogo Style Properties.

12. Premere il pulsante OK nella finestra di dialogo Legend Entry Properties.

I simboli associati con le città sono ora visualizzati con grandezza differente e
proporzionale al valore della popolazione. La città con il valore di popolazione più alto è
Milwaukee, il simbolo che la rappresenta è più grande degli altri.

13. Queste impostazioni sono più evidenti quando il parametro Style Scaling viene
impostato sulla modalità Paper.

14. Fare click con il pulsante destro sull’elemento di legenda Major Cities e
selezionare Style Scaling > Paper.

15. Per poter vedere e modificare i simboli con maggiore facilità, disabilitare la
possibilità di selezionare le features OutputStates e States by Snow/avetemp
utilizzando il comando del menù di pulsante destro del mouse Locatable Off.

16. Salvare il GeoWorkspace.

Esempio #2 – Visualizzazione di Simboli basata sul Valore degli Attributi
In questo esercizio verrà utilizzata la layout window per creare alcuni simboli che
utilizzeremo per visualizzare i simboli in modo differente da quanto fatto prima. Dopo aver
creato il simbolo si procederà a salvarlo come .fsm, poi si provvederà a visualizzarlo
quando si verificano delle condizioni per l’attributo CITY_NAME.
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Creare un Symbol File (.sym) tramite la Layout Window
Utilizzeremo un nuovo foglio per creare un nuovo simbolo.

Consigli per la creazione di nuovi simboli: E’ raccomandabile creare un simbolo alla
scala a cui si intende utilizzarlo. E’ ovviamente possibile ridimensionare un simbolo,
quando viene compiuta questa operazione la geometria e lo spessore vengono
ridimensionati proporzionalmente. Può succedere di dover ridimensionare i simboli dopo
averli creati, è comunque preferibile, quando è possibile, lavorare alla scala di utilizzo.

Nota: Se la finestra di tutorial e la finestra di GeoMedia Professional sono affiancate sullo
schermo e ci si sposta da un ambiente all’altro, accertarsi sempre che la finestra dove si
intende compiere le operazioni sia la finestra attiva.

1. Selezionare Window > Show Layout Window.

2. Nella finestra di layout, selezionare Sheets > Insert Sheet.

3. Selezionare Sheets > Rename Sheet, digitare Symbol come nuovo nome, poi
Premere il pulsante OK.

4. Se l’ambiente Drawing non è visualizzabile nella parte in basso della finestra di
layout, come mostrato nella figura sottostante, selezionare View > Drawing Toolbox.

5. Verrrano posizionate ora delle utili abbreviazioni.

6. Selezionare Text nella Drawing Toolbox.

7. Utilizzando la toolbar Text selezionare 72 punti per l’attributo size.

8. Selezionare View > Fit.

9. Premere il pulsante in qualunque area del foglio per posizionare un punto di
intersezione per la prima delle stringhe di testo.

10. Digitare MN.

11. Premere il pulsante in qualunque altra area del foglio per posizionare un punto di
intersezione per la seconda stringa di testo.

12. Digitare MW.

13. Premere il pulsante in qualunque area del foglio per posizionare un’altra
intersezione per la per le stringhe di testo.

14. Digitare MD.

15. Premere il pulsante in qualunque area del foglio per posizionare un punto di
intersezione per la nuova stringa di testo.

16. Digitare SP.

17. Premere ESC per uscire dal comando Text.
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18. Utilizzando lo strumento Select tracciare un rettangolo intorno alla stringa di testo
'MN', per fare ciò spostare il mouse nell’angolo in alto a sinistra della stringa, poi
premere il pulsante sinistro, e tenendolo premuto raggiungere l’angolo in basso a
destra dell’etichetta di testo, poi lasciare il pulsante.

Il testo è ora selezionato.

Nota: Se il testo non risulta selezionato dopo questa operazione, disegnare un rettangolo
più grande ed accertarsi che la selezione avvenga.

19. Selezionare il comando Create Symbol dal menù di pop-up Draw presente nella
Drawing Toolbox (premere il pulsante Draw).

Nota: Questo stesso comando è disponibile nella toolbar Symbols.

Verrà richiesto di definire il simbolo di origine.

20. Spostare ora il cursore approssimativamente al centro della stringa “MN”, poi
premere il pulsante con il pulsante sinistro del mouse.

Viene visualizzata a schermo la finestra di dialogo Save As.

21. Scegliere la cartella di destinazione Learning nel campo Save in.

22. Dopo aver scelto il tipo di dato Symbol (*.sym) all’interno del campo Save as type,
digitare MINNEAPOLIS, MN all’interno del campo File name.

Nota: Accertarsi che ci sia solo uno spazio tra la virgola e l’acronimo di stato.

23. Premere il pulsante Save.

Il simbolo scelto è stato salvato nella cartella Learning con il nome . MINNEAPOLIS,
MN.sym.
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24. Ripetere I passaggi dal 15-20 con lo scopo di salvare gli altri simboli MADISON,
WI (per la stringa di testo MD), MILWAUKEE, WI (per la stringa MW), e ST PAUL,
MN (per la stringa di testo SP), rispettivamente. Accertarsi sempre che tra la virgola
che segue il nome e la sigla che distingue lo stato sia presente solo uno spazio.

Salvare i Simboli in un File .fsm
Vedremo ora come utilizzare l’utility Define Symbol File per inserire i .sym files all’interno
di un file .fsm. in modo da poter essere letti e in modo da utilizzare una simbologia basata
sugli attributi.

1. Selezionare Start > All Programs > GeoMedia Professional > Utilities > Define
Symbol File.

La finestra di dialogo Define Symbol File viene visualizzata.

Aggiungeremo ora un file .fsm.

2. Premere il pulsante New.

3. Nella finestra di dialog Add From File settare il parametro Files of type a
GeoMedia Layout Symbol File (*.sym).

4. Selezionare MINNEAPOLIS, MN.sym dalla cartella Learning, poi premere il
pulsante Open.

Il simbolo creato è selezionato nella finestra di dialogo Add Symbols, e visualizzato nella
finestra di dialogo Preview.

5. Premere il pulsante Insert.

6. Premere il pulsante Close nella finestra di dialogo Add Symbols.

Il simbolo è ora memorizzato nel file .fsm creato.

7. Premere il pulsante Add nella finestra di dialogo Define Symbol File.

8. Nella finestra di dialogo Add From File scegliere GeoMedia Layout Symbol File
(*.sym) come Files of type.

9. Selezionare MADISON, WI.sym nella cartella Learning poi premere il pulsante
Open.

Il simbolo creato è selezionato nella finestra di dialogo Add Symbols, e visualizzato nella
finestra di dialogo Preview.

10. Premere il pulsante Insert.

11. Premere il pulsante Close nella finestra di dialogo Add Symbols.

Il simbolo è ora memorizzato nel file .fsm creato.

12. Ripetere i passaggi da 7 a 11 per i simboli rimanenti.

13. Premere il pulsante Save per salvare un nuovo .fsm.

Viene visualizzata la finestra di dialogo Save As.

14. Accertarsi che il campo Save as type sia impostato come GeoMedia Feature
Symbol File (*.fsm), poi selezionare la cartella Learning nel campo Save in e digitare
Learning all’interno del campo File name.

15. Premere il pulsante Save.
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Il nuovo .fsm file è stato creato.

16. Premere il pulsante Close.

Visualizzare i Simboli contenuti nel file .fsm nella modalità basata
sull’attributo
E’ possibile ora tornare nella layout window il file .fsm dove i files .sym sono stati
memorizzati. Così facendo verrà visualizzata la simbologia basata sui valori dell’attributo
CITY_NAME.

1. Chiudere la finestra di layout, cliccando la X della barra del titolo.

2. Fare ora doppio click sulla chiave di stile dell’elemento di legenda Major Cities di
map window.

3. Selezionare Properties, e selezionare la scheda Advanced.

4. Premere il pulsante sulla riga Source della colonna Attribute Based.

5. Dal menù a tendina selezionare Expression.

Viene visualizzata la finestra di dialogo Expression.

Questa finestra di dialogo permette di creare un nuovo attributo funzionale.

6. Aprire ora, utilizzando il blocco note il file ABS_CONCATENATE.txt localizzabile
nella cartella Learning.

7. Copiare il contenuto del file.

8. Incollare il contenuto del file nel campo Expression.

Prestare attenzione al contenuto della stringa.

Questa stringa contiene l’istruzione CONCATENATE. Questa istruzione può due formati,
quello che si sta utilizzando ora è:

CONCATENATE(Separatore, Stringa1, Stringa2, Stringa3, ...)

Stiamo utilizzando l’istruzione CONCATENATE come segue:

CONCATENATE(";", "Percorso del Simbolo", Attributo)

Nota: Il percorso del simbolo è quello della cartella Learning. Se la cartella Learning è
localizzata diversamente dai valori predefiniti, modificare "Percorso del Simbolo" in modo
da puntare al file.

9. Premere il pulsante OK nella finestra di dialogo Expression.

Il testo è stato incollato nella riga Source della colonna Attribute Based.

10. Premere il pulsante OK nella finestra di dialogo Style Properties.

11. Premere il pulsante OK nella finestra di dialogo Legend Entry Properties.

I simboli associati alle città, sono proporzionali al valore della popolazione, ma i simboli
utilizzati sono differenti: sono stati sostituiti con i simboli che hanno il nome identico
all’attributo CITY_NAME.
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E’ possibile ora utilizzare il controllo di zoom per visualizzare in modo più chiaro la
simbologia utilizzata.

Nota: Questo tipo di visualizzazione, funziona con tutti i tipi di dato che contengono
simbologia multipla, come ad esempio .fsm, .svg, or .cel.

12. Salvare il GeoWorkspace.

Utilizzo dei Simboli SVG con Testo Parametrizzato
E’ possibile utilizzare files di tipo SVG, con lo scopo di sfruttare le proprietà parametriche
di questo tipo di testo. Ad esempio nel caso in cui si voglia posizionare l’etichetta di una
strada, si può creare l’etichetta a partire da un attributo che contenga il testo desiderato.

Per avere maggiori informazioni, consultare l’appendice Supported SVG Element Types
contenuta nel documento Working with GeoMedia Professional.

Continuate con la sezione successiva: 2-4 Utilizzo di Buffer, Query Spaziali e Join
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2-4 Utilizzo di Buffer, Query Spaziali e Join
In questa sezione, creeremo una una zona di rispetto (Buffer Zone) intorno ai risultati della
query. Una Buffer Zone è un’area definita attorno o all’interno di una o più feature. Poi
creeremo query spaziali, che estraggono informazioni dal database rispetto alle feature
classes o alle queries, basandosi sulla relazione spaziale con le altre features. Infine,
vedremo la capacità di GeoMedia Professional di eseguire join.

Ripristinare la Visualizzazione dei Simboli
I passi seguenti servono a ripristinare la visualizzazione originale dei simboli associati alle
città.

1. Fare doppio click sulla chiave di stile della voce di legenda Major Cities.

2. Premere il pulsante Properties.

3. Selezionare la scheda Advanced.

4. Cancellare il testo nella colonna Attribute Based per le righe Source e Size.

5. Clicccare OK nelle finestre di dialogo Style Properties e Legend Entry
Properties.

6. Fare click con il pulsante destro, sulla voce di legenda della feature class Major
Cities e selezionare Style Scaling > View.

7. Se necessario, sistemare la scala di visualizzazione utilizzando i tools di zoom in
modo da visualizzare comodamente l’area dove è stato applicato il filtro spaziale.

8. I simboli che rappresentano le città sono dei cerchi di grandezza uguale.

Creare una Zona di Rispetto
Una Buffer Zone è un’area definita dall’utente attorno o all’interno di una o più feature,
costruita a partire dalla feature o dalle features. La buffer zone viene utilizzata in ambito di
analisi spaziali. Una buffer zone può essere creata a partire da una feature class o dal
risultato di una query, inoltre se generata come query può essere modificata. In questo
esercizio, creeremo una buffer zone di 90 miglia intorno alle città principali.

1. Selezionare Analysis > Buffer Zone.

2. Dal menù a tendina Buffer zone around aprire Queries, e selezionare Major
Cities.

3. All’interno del gruppo Distance accertarsi che Constant sia selezionato, poi
digitare 90.

4. Quest’ultimo passaggio serve a specificare la distanza di 90 miglia.

5. Spuntare l’opzione Merge touching buffer zones.

6. Nel campo Query name lasciare la stringa predefinita Buffer zones around Major
Cities come nome per la zona di rispetto.

7. Accertarsi che Display buffer zones in map window sia selezionato.

8. Premere il pulsante Style.



63 di 213

9. Nella finestra di dialogo Select Style aprire la cartella Learning e selezionare lo
stile predefinito Buffer Zones Around Major Cities (e non PLOT Buffer Zones), poi
premere il pulsante OK su tutte le finestre di dialogo.

Le zone di rispetto sono ora visualizzate nella map window. Lo stile di visualizzazione
prevede il colore arancione e lo spessore 2.000.

10. Per rendere più evidente la visualizzazione delle zone di rispetto disabilitare la
visualizzazione della feature class States by Snow/avetemp cliccando la
corrispondente voce di legenda e selezionando Display Off.

11. All’interno della scheda Groups trascinare la feature class States by
Snow/avetemp nel gruppo Not currently used.

12. Salvare il GeoWorkspace.

Creare una Query Utilizzando una Zona di Rispetto

Si procederà ora con la creazione di nuove query; saranno delle query spaziali, che
estraggono informazioni dal database rispetto ad altre feature classes o rispetto ad altre
query basate su relazioni spaziali.

La prima query ci permetterà di trovare tutte le regioni con valori di popolazione sotto una
certa soglia, che ricadono nella buffer zone che abbiamo appena creato. Queste regioni
potrebbero essere buoni candidati per gli impianti sciistici.

1. Selezionare Analysis > Spatial Query.

2. Utilizzando il menù a tendina Select features in selezionare Counties dalla
connnessione Connection to US Data.

3. Premere il pulsante Filter per visualizzare la finestra di dialogo Counties Filter.

4. Selezionare l’attributo POP (Popolazione), poi premere il pulsante la freccia verso il
basso.

5. Selezionare l’operatore minore di <.

6. Digitare il valore (cioè 30.000) 30000 nel campo Filter.

La stringa POP < 30000 è visualizzata nel campo Filter.
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7. Premere il pulsante OK nella finestra di dialogo Counties Filter.

8. Nel campo That selezionare are contained by dal menù a tendina.

9. Nel campo Features in, selezionare la feature class appena creata, Buffer zones
around Major Cities, dal menù a tendina Queries.

10. Nel campo Query name digitare Small Counties Around Major Cities.

11. Visualizzare la query nella finestra di mappa Final Counties e non nella finestra dei
dati.

12. Premere il pulsante OK per visualizzare la query.

Le regioni che si trovano nella zona di rispetto sono ora visualizzate nella map window .

13. Salvare il GeoWorkspace.

Costruire una Query a partire da una Query
Si vuole ora costruire una query che estragga tutto ciò che, si trova nella query precedente
e che non sia distante più di 9 miglia delle autostrade.

1. Selezionare Analysis > Spatial Query per creare la seconda query.

2. Dal menù a tendina Select features in aprire Queries, e selezionare la query
appena creata, Small Counties Around Major Cities.

Nota: Nella cartella Queries, sarà presente un messaggio del tipo: "Errors in..." e di
seguito la lista delle queries spaziali, come ad esempio "Errors in Small Counties Around
Major Cities." Queste query sono vuote perciò non possono contenere errori, (ad esempio
conflitto di relazione spaziale tra features). Tutte le volte che ci sono errori, un messaggio
di errore viene visualizzato.

3. Nel campo That selezionare l’opzione are within distance of utilizzando il menù a
tendina.

4. Nel campo Distance digitare 9.

Questo fattore specifica il valore 9 miglia.

5. Nel campo Features in selezionare la feature class Interstates dalla connessione
Connection to US Data utilizzando il menù a tendina.
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6. Cambiare il nome alla query: digitare Final Counties nel campo Query name.

7. Visualizzare la query nella finestra di mappa Final Counties, ma non nella finestra
di dati.

8. Premere il pulsante OK per visualizzare la query.

Il risultato dell’interrogazione è ora visualizzato nella map window, la visualizzazione può
essere facilitata, gestendo in maniera più efficiente la legenda.

9. Disabilitare la visualizzazione della feature class Small Counties Around Major
Cities, utilizzando il comando del menù destro del mouse, Display Off.

10. Utilizzando la scheda Groups trascinare la feature class Small Counties Around
Major Cities all’interno del gruppo Not currently used.

11. Il risultato dell’operazione è disponibile nella finestra di mappa.

12. Salvare il GeoWorkspace.

Aggiungere Features alla Categoria Frequently used
Si possono aggiungere altre features alla categoria creata precedentemente, con lo scopo
di accedere più facilmente alle informazioni contenute.

1. Selezionare Warehouse > Categories.

2. Selezionare la categoria Frequently used.

3. Premere il pulsante Add Features.

4. Aprire ora Queries, spuntare Buffer Zones Around Major Cities, Final Counties,
e Major Cities.

5. Premere il pulsante OK.

6. Premere il pulsante Close.
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Creare un Join
Il join è un operatore che permette di creare una relazione tra due feature class o query in
modo che gli attributi possano essere condivisi tra di loro in una query risultante.

Creeremo una join per le sei contee della query Final Counties con lo scopo di vedere le
informazioni degli attributi delle regioni insieme con le informazioni degli attributi dei
corrispondenti stati nei quali le regioni sono localizzate.

1. Selezionare Analysis > Join.

2. Nella finestra di dialogo Join selezionare Final Counties appartenente alla
categoria Frequently used all’interno del campo Left side of join.

3. Selezionare OutputStates appartenente alla categoria Frequently used nel campo
Right side of join.

4. Per il lato destro e sinistro del campo Available attributes, selezionare l’attributo
STATE_NAME, che è l’attributo che rende il join possibile.

5. Premere il pulsante contraddistinto da una freccia verso il basso, per aggiungere
l’attributo al campo Selected attribute pairs.

6. Nel campo Selected attribute pairs è ora presente la stringa
STATE_NAME=STATE_NAME.

Si supponga di voler paragonare le condizioni metereologiche (ad esempio le
precipitazioni nevose, le pioggie e la temperatura media) di ogni regione con quelle dello
stato a cui la regione appartiene.

7. Premere il pulsante Attributes

8. Nella finestra di dialogo Output Attributes premere il pulsante Unselect All.

Spuntare solo le seguenti colonne:

- COUNTY_NAME
- AVETEMP
- ANNULRAIN
- ANNULSNOW
- STATE_NAME1
- AVETEMP1
- ANNULRAIN1
- ANNULSNOW1

9. Premere il pulsante AVETEMP poi premere il pulsante Rename.

10. Cambiare il nome in COUNTY_AVETEMP, poi premere il pulsante OK.

11. Rinominare ANNULRAIN come COUNTY_ANNULRAIN, e ANNULSNOW come
COUNTY_ANNULSNOW.

12. Rinominare AVETEMP1 come STATE_AVETEMP, ANNULRAIN1 come
STATE_ANNULRAIN, e ANNULSNOW1 come STATE_ANNULSNOW.

13. Premere il pulsante OK nella finestra di dialogo Output Attributes.

14. Accertarsi che sia selezionato Inner come Type of join.
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Nota: Per avere maggiori informazioni su differenti tipi di Join, riferirsi al GeoMedia
Professional Help Topics

15. Nel campo Query name, lasciare il nome predefinito per la query, Join of Final
Counties and OutputStates.

16. Accertarsi che Display join in data window sia selezionato.
E’ possibile visualizzare i risultati nella data window.

17. Lasciare il nome predefinito per la finestra dei dati: DataWindow1.

18. Premere il pulsante OK.

Il risultato dell’operazione di Join è visualizzato con il titolo Join of Final Counties and
OutputStates nella data window. Sono visualizzabili sei righe, una per ogni regione.

Scorrere la finestra dei dati, per vedere le informazioni che riguardano le condizioni
metereologiche, e’ possibile inoltre osservare che gli attributi selezionati sono presenti con
il nome scelto.

19. Chiudere la data window.

20. Utilizzando la scheda di legenda Display Order, spostare le voci di legenda e
disporle con il seguente ordine: StateNameLabels, Major Cities, Interstates, Final
Counties, Buffer zones around Major Cities, e OutputStates.

21. Salvare il GeoWorkspace.

Continuare con la sezione 2-5 Geocodifica di Coordinate e Analisi Spaziale
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2-5 Geocodifica di Coordinate ed Analisi Spaziale
In questa sezione vedremo un esempio di analisi spaziale di tipo esclusivo. Si potranno
localizzare aree non adatte alla costruzione di nuovi impianti sciistici. Si seguirà il
seguente flusso di operazioni.

Verrà creata una nuova feature class mediante importazione di un file di testo. Il file
contenuto nella cartella Learning contiene le coordinate ed i nomi di alcune località, la
funzione Geocode Coordinates possiede infatti la capacità di creare punti da un file di
coordinate. Verrano poi create delle zone di rispetto che potremmo considerare aree off-
limits. Verrà poi utilizzato il comando Spatial Difference che permetterà di estrarre a
partire dalle regioni le aree che sono buoni candidati per la localizzazione di nuovi impianti
sciistici. Poi, la funzione Analyze Geometry servirà a misurare i risultati ottenuti.

Escludere il Filtro Spaziale
Il filtro spaziale definito precedentemente non è più utile.

1. Premere il pulsante Remove Filter.

Il filtro spaziale è stato rimosso.

Importare una Tabella
La fase di geocodifica, comincia con l’importazione di un file esterno che contenga
informazioni geografiche, indirizzi, o altri attributi aggiuntivi. GeoMedia Professional è
provvisto del comando Attach che permette di importare testo in formato tabulare, nel
nostro caso le informazioni nella tabella conterranno le coordinate e altri attributi delle
località con divieto di accesso.

Per prima cosa diamo un occhiata al file di testo

1. Utilizzare il Blocco Note di Windows per aprire il file point_coordinates.txt che si
trova nella cartella Learning.

Si può osservare come la prima riga del file contiene l’intestazione, e le prime tre
colonne contengono il nome degli attributi. Nelle altre righe possiamo leggere il valore
degli attributi. Si possono notare gli attributi Longitude e Latitude ed I loro valori.
Questi valori sono le coordinate che verranno importate nell’esercizio.

Si può notare che le intestazioni sono separate da virgole e così i valori di attributo.

2. Chiudere il file di testo.

3. Selezionare Warehouse > Feature Class Definition.

4. Premere il pulsante learn (non premere sul simbolo + accanto) per selezionare la
connessione.

Il pulsante Attach è ora attivo.
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Questa opzione è valida solo quando viene selezionata una connessione di tipo read-
write.

5. Premere il pulsante Attach.

Viene visualizzata la finestra di dialog Attach.

6. Nel menù a tendina Type selezionare Text.

7. Sono molti i tipi di files esterni che possono essere importati, nel nostro caso
utilizzeremo un file di testo.

8. Premere il pulsante Browse.

9. Aprire il file di testo point_coordinates.txt localizzato nella cartella Learning.

10. Una volta ritornati alla finestra di dialogo Attach notare che il file di testo compare
ora nella lista Tables to attach. Inoltre come da impostazione la tabella appare già
selezionata, ad indicare che verrà importata.

E’ possibile modificare la tabella di destinazione, il cui nome verrà utilizzato come nome
per la nuova feature class.

11. Fare doppio click sulla prima riga nella colonna Target table che contiene il nome
point_coordinates_txt.

12. Introdurre il nome Restricted_Sites.

13. Premere il pulsante OK nella finestra di dialogo Attach.

Si è ora ritornati alla finestra di dialogo Feature Class Definition dove la feature class
Restricted_Sites e nella lista learn come tavola da importare.

14. Si può utilizzare il comando review per rivedere gli attributi.

15. Una volta selezionato Restricted_Sites, premere il pulsante Review.

16. Premere il pulsante di schedaAttributes.

17. La lista degli attributi della feature class compare nella colonna Name: Name,
Longitude, e Latitude. Si potrà riconoscere l’intestazione del file di testo.

18. Premere il pulsante Cancel nella finestra di dialogo Review.

19. Premere il pulsante Edit.

20. Il campo Data Source serve invece a localizzare il file. If the text file viene spostato
per qualche ragione, si potrà specificare in questo campo la nuova posizione.

21. Premere il pulsante Cancel nella finestra di dialogo Edit.

22. Premere il pulsante Close nella finestra di dialogo Feature Class Definition.

Geocodifica di Coordinate
Il comando Geocode Coordinates permette di generare una geometria puntuale per
feature class o queries a partire dalle coordinate memorizzate nei valori delle tavole di
attributo. Utilizzeremo le coordinate contenute nella tabella importata.

1. Utilizzare il controllo di zoom per avvicinare la vista alle due zone di rispetto, poi
utilizzare il pulsante ESC per uscire dal comando.
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2. Selezionare Analysis > Geocode Coordinates.

3. Nel campo Geocode attributes in selezionare la feature class Restricted_Sites
dalla connessione learn.

4. Si utilizzi il pulsante Coordinate System per specificare il sistema di coordinate
che si vuole utilizzare.

5. Premere il pulsante Coordinate System.

Il sistema di coordinate predefinito è impostato su Geographic.

6. Selezionare la scheda Geographic Space.

7. Geodetic datum è impostato su WGS84, che è quello dei punti da importare.

8. Click the Units and Formats tab.

9. Selezionare d:m:s nel menù a tendina Unit.

10. Premere il pulsante OK nella finestra di dialogo Coordinate System Properties.

11. Nella finestra di dialogo Geocode Coordinates premere il pulsante il menù a
tendina Latitude.

I nomi degli attributi della feature class Restricted_Sites sono visualizzati.

12. Selezionare l’attributo Latitude.

Ciò serve a specificare la prima delle coordinate spaziali.

13. Nel menù a tendina Longitude selezionare l’attributo Longitude.
Ciò serve a specificare la seconda delle coordinate spaziali.

14. Nel campo Query name utilizzare il nome predefinito Geocoded Points of
Restricted_Sites.

15. Accertarsi che l’opzione Display points in map window sia spuntata,e che la
finestra di mappa Final Counties sia selezionata, nel campo Map window name.

I risultati saranno visualizzati solo nella finestra di mappa.

16. Premere il pulsante OK.

I punti sono stati geocodificati e visualizzati nella map window.



71 di 213

Creare una Zona di Rispetto Intorno ai Punti
Posizioneremo ora una zona di rispetto di 10 migli intorno ai punti. Le zone
rappresenteranno aree dove non si possono localizzare nuovi impianti sciistici.

1. Selezionare Analysis > Buffer Zone.

2. Nel menù a tendina Buffer zone around aprire Queries, e selezionare Geocoded
Points of Restricted_Sites.

3. Nel gruppo Distance accertarsi che Constant sia selezionato, poi digitare il valore
10 che significa 10 miglia.

4. Accertarsi che l’opzione Merge touching buffer zones sia stata spuntata.

5. Nel campo Query name, digitare Restricted Zones.

6. Accertarsi che Display buffer zones in map window sia selezionato, e che il
nome della map window di destinazione sia Final Counties.

7. Premere il pulsante Style.

8. Selezionare lo stile Restricted Zones dalla cartella Learning.

9. Premere il pulsante OK per tutte le finestre di dialogo.

Le zone di rispetto, Restricted Zones, sono ora visualizzate nella map window. Sono
visualizzate in magenta con un spessore pari a 2.000 come prevede lo stile selezionato.

10. Salvare il GeoWorkspace.
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Il comando Spatial Difference
Il comando Spatial Difference si utilizza quando in fase di analisi si ha la necessità di
creare delle maschere, come risultato della sottrazione di un area da un altra. Si
considereranno come aree adatte alla costruzione di nuovi impianti sciistici, l’area che è il
risultato della differenza spaziale tra le feature classes Final Counties e Restricted Zones.
Le regioni la cui area è completamente al di fuori della feature class Restricted Zones
saranno candidati migliori.

1. Selezionare Analysis > Spatial Difference.

2. Nel menù a tendina From features in selezionare Final Counties dalla categoria
Frequently used.

3. Nel menù a tendina Subtract features in selezionare la query Restricted Zones.

4. Specificare il nome Usable Areas nel campo Query name.

5. Accertarsi che Display difference in map window sia selezionato e che Final
Counties, sia il nome della map window scelta nel campo Map window name.

6. Lasciare l’opzione Display difference in data window non spuntata.

7. Premere il pulsante Style.

8. Selezionare lo stile Usable Areas nella cartella Learning.

9. Premere il pulsante OK nella finestra di dialogo Select Style.

10. Premere il pulsante OK nella finestra di dialogo Spatial Difference.

L’operazione di differenza spaziale è stata conclusa, il risultato è visualizzato nella finestra
di dialogo con il nome dello stile scelto. Il risultato mostra le aree delle regioni che possono
essere utilizzate per posizionare nuovi impianti sciistici.
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11. Salvare il GeoWorkspace.

Analisi delle Geometrie delle Aree
Per misurare le aree risultanti dall’operazione di differenza spaziale, è possibile utilizzare il
comando Analyze Geometry. Si supponga di voler trovare le più grandi regioni che hanno
delle aree disponibili per gli impianti sciistici.

1. Selezionare Analysis > Analyze Geometry.

2. Nella finestra di dialogo Analyze Geometry, selezionare Usable Areas dal menù a
tendina Features to analyze.

3. Spuntare le opzioni Area e Perimeter per effettuare le misure di area e perimetro.

4. Premere il pulsante Units and Formats.

5. Nel campo Type selezionare Area.
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E’ possibile notare che il campo Precision è impostato dopo il primo decimale (.1).

Questa sarà la precisione con cui si vogliono ottenere i risultati.

6. Premere il pulsante OK nella finestra di dialogo Coordinate System Properties.

7. Nel campo Query name, digitare Info on Usable Areas.

8. Accertarsi che i risultati vengano visualizzati sia nella map window che nella data
window.

9. Premere il pulsante OK.

I risultati sono visualizzati nella finestra dati e mostrano sei righe, una per ogni regione.

10. Si possono osservare quali sono le aree con la maggiore superficie disponibile per
il nostro scopo.

11. Per visualizzare insieme la finestra di mappa e la finestra dei dati utilizzare il
comando Window > Tile Horizontally.

12. Attivare la finestra Final Counties ed allungare il bordo in basso della finestra Final
Counties in modo da coprire la finestra US Map.

13. Utilizzare il controllo Pan se non si riesce a visualizzare tutte le regioni. Spostare o
chiudere la legenda come da necessità.

14. Per ordinare gli elementi presenti nella data window, selezionare l’intestazione
Area.

La colonna viene evidenziata.

15. Selezionare Data > Sort Descending.

Gli elementi sono stati ordinate da maggiore al minore.

16. Selezionare le righe che si vogliono evidenziare utilizzando la data window.

Le aree corrispondenti vengono evidenziate nella map window.

17. Chiudere ora la finestra dei dati ed ingrandire la map window Final Counties.
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Ora potremo rimuovere alcuni elementi dalla legenda e dalla mappa.

18. Se si è chiusa la legenda, utilizzare il comando View > Legend.

19. Disattivare la visualizzazione delle seguenti voci di legenda: Info on Usable Areas,
Usable Areas, Restricted Zones, e Geocoded Points of Restricted_Sites.

20. Nella scheda Groups trascinare le feature che sono state disattivate nel gruppo
Not currently used group.

21. Alcuni dei risultati verranno utilizzato nella prossima sezione, ma ora si è preferito
disattivarli in modo da lasciare spazio ad altri elementi, come le etichette, ad esempio.

22. Selezionare la scheda Display Order.

La legenda dovrebbe ora contenere nell’ordine, solo i seguenti elementi:
StateNameLabels, Major Cities, Interstates, Final Counties, Buffer zones around
Major Cities, and OutputStates.

23. Salvare il GeoWorkspace.

Continuare con la sezione successiva: 2-6 Aggregare i Risultati
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2-6 Aggregare i Risultati
In questo esercizio, verrà eseguita un’altra importante operazione di analisi spaziale: con
lo scopo di valutare quali tra le aree estratte precedentemente meglio soddisfa le
condizioni al contorno, calcoleremo la popolazione totale delle regioni che si trovano
all’interno delle aree conformi. Per prima cosa creeremo delle zone di rispetto, attorno alle
aree scelte che sono vicine tra loro. Poi utilizzeremo la funzione Aggregation per
sommare la popolazione delle regioni che sono incluse nella zona di rispetto. Infine
modificheremo l’area sottesa alle zone di rispetto per vedere come i risultati cambiano.

Creare Queries per le Zone di Rispetto
Supponiamo di voler verificare quale sia la popolazione delle aree che sono intorno alle
sei regioni scelte per capire quali aree tra quelle estratte sono candidati migliori per gli
impianti sciistici. Prepareremo due nuove aree di rispetto per le aree che sono accoppiate.

Prima di tutto disabilitiamo temporaneamente le voci di legenda associate alle aree di
rispetto create precedentemente.

1. Fare click con il pulsante destro del mouse Buffer zones around Major Cities e
selezionare Display Off.

Creeremo la prima query per le due regioni più a nord del Minnesota tra quelle mostrate
dalla mappa.

2. Selezionare Analysis > Attribute Query.

3. Nel campo Select features in selezionare la feature class OutputCounties
appartenente alla categoria Frequently used.

4. Utilizzando l’Explorer di Windows aprire il file Queries for Aggregation.txt contenuto
nella cartella Learning.

Il file contiene tre righe di testo.

5. Spuntare l’opzione Filter nella finestra di dialogo Attribute Query.

6. Copiare la prima linea del testo Queries for Aggregation.txt file, ed incollarla nel
campo Filter della finestra di dialogo OutputCounties Filter.

7. Premere il pulsante OK nella finestra di dialogo OutputCounties Filter.

8. Cambiare il nome del risultato della query in Query 1 utilizzando il campo Query
name.

Si voglia visualizzare il risultato dell’operazione solamente all’interno della map window.

9. Accertarsi che l’opzione Display query in map window sia attiva.

10. Accertarsi che l’opzione Display query in data window non sia spuntata.

11. Premere il pulsante Style.

12. Selezionare lo stile Query 1 dalla cartella Learning.

13. Premere il pulsante OK per tutte le finestre di dialogo.

La query è stata creata con successo, è visualizzata nella map window con lo stile
predefinito che è stato selezionato.
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14. Creare ora altre due interrogazioni di attributo per le altre regioni. Ogni query
conterrà due regioni. Seguire i passi precedenti utilizzando le altre righe del file di testo
ed utilizzando i nomi Query 2 e Query 3 rispettivamente. Si vogliano visualizzare le
queries utilizzando lo stile predefinito il cui nome coincide con il nome della query.

15. Chiudere il file di testo Queries for Aggregation.txt.

16. Salvare il GeoWorkspace.

Posizionare una Zona di Rispetto intorno alle Regioni
In questo esercizio, posizioneremo una zona di rispetto di 20 migli intorno ad ognuno dei
tre gruppi ognuno formato da una coppia di regioni confinanti.

1. Selezionare Analysis > Buffer Zone.

2. Dal menù a tendina Buffer zone around aprire Queries, e selezionare Query 1.

3. All’interno del gruppo Distance selezionare Constant.

4. Digitare 20 per la distanza e scegliere mi ad indicare le miglia.

5. Attivare l’opzione Merge touching buffer zones.

6. Nel campo Query name, digitare Zone 1.

Visualizzeremo i risultati solamente all’interno della map window.
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7. Accertarsi che l’opzione Display buffer zones in map window sia attiva.

8. Premere il pulsante Style.

9. Selezionare lo stile Zone contenuto nella cartella Learning.

10. Cliccare OK per tutte le finestre di dialogo.

11. Premere il pulsante OK.

La zona di rispetto è ora visualizzata nella map window.

12. Posizionare una zona di rispetto di 20 miglia per ognuna delle nuove queries
(Query 2 e Query 3), e nominare le nuove zone di rispetto Zone 2 e Zone 3,
rispettivamente.

13. Salvare il GeoWorkspace.
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Aggregare le Zone di Rispetto e le Regioni
Il comando Aggregation ci permette di copiare un o più attributi da una feature class o
query ad un altra feature class o query, basandoci sulla relazione spaziale tra i due
elementi coinvolti. In questo esercizio, copieremo l’attributo POP (popolazione) dalle
regioni alle zone di rispetto, in modo da ottenere il valore di popolazione delle regioni che
confinano con le aree di rispetto.

1. Selezionare Analysis > Aggregation.

2. Nel campo Aggregate to summary features in selezionare la query Zone 1.

3. Nel campo From detail features in selezionare OutputCounties dalla categoria
Frequently used.

Il tipo di aggregazione che ora andremo ad utilizzare è definita di tipo spaziale, infatti
coinvolge tutte le regioni che sono all’interno delle aree di rispetto. Un aggregazione
basata sugli attributi invece si basa sull’aggregazione di valori di attributo equivalenti.

4. Nella scheda Spatial Aggregation accertarsi che l’opzione Aggregate where
summary features sia attiva.

5. Nel menù a tendina scegliere l’opzione touch.

6. L’opzione touch serve ad includere nella selezione tutte le regioni che sono
all’interno o sul bordo dell’area di rispetto.

7. Selezionare la scheda Output.

8. Utilizzeremo ora gli attributi funzionali per sommare i valori di popolazione delle
regioni.

9. Lasciare l’operatore Resolution impostato sul valore All.

Questo campo ci permette di specificare come si vuole agire nel caso in cui la feature in
ingresso può essere aggregata a più di un’altra tra le feature disponibili. Nel nostro
esempio tuttavia non ci saranno conflitti di utilizzo.

10. Premere il pulsante New per creare un nuovo attributo funzionale.

11. La finestra di dialogo Functional Attribute viene visualizzata sullo schermo.

12. E’ possibile ora introdurre il nome per il nuovo attributo funzionale.

13. All’interno del campo Functional attribute name digitare BufferZonePopulation.

14. Nel campo Categories scegliere l’opzione Statistical.

15. Nel campo Functions selezionare SUM facendo doppio click.

16. L’espressione SUM() appare nel campo Expression.

17. Posizionare ora il cursore tra le due parentesi.

18. Nel campo Attributes selezionare Detail.POP facendo doppio click su di esso.

L’espressione SUM(Detail.POP) appare nel campo Expression.

19. Premere il pulsante Add, poi premere il pulsante Close quando la finestra di
dialogo viene visualizzata.

Il nuovo attributo funzionale creato, BufferZonePopulation, appare nella lista Output
functional attributes della finestra di dialogo Aggregation.
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20. Cambiare il nome della query utilizzando il campo Query name in Aggregation 1.

21. Accertarsi che l’aggregazione venga visualizzata solamente nella finestra di mappa
e non nella finestra dati.

22. Premere il pulsante Style.

23. Selezionare lo stile predefinito Aggregation contenuto nella cartella Learning.

24. Premere il pulsante OK per tutte le finestre di dialogo.

Il risultato dell’aggregazione è ora visualizzato nella map window con lo stile scelto.

25. Fare doppio click sull’elemento all’interno della map window.

E’ possibile così visualizzarne l’attributo di popolazione: il valore 2,371,396, compare nella
finestra di dialogo Aggregation 1 Properties.

26. Premere il pulsante Cancel.

27. Utilizzando i passi precedenti utilizzare la funzione di aggregazione per Zone 2 e
Zone 3 rispettivamente. Rinominare i risultati Aggregation 2 e Aggregation 3.
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28. Verificare che i valori di popolazione siano 783,737 per Aggregation 2, e 721,049
per Aggregation 3.

Modificare le Proprietà di una Zona di Rispetto
Siccome le aree di rispetto sono delle queries, possono essere modificate. In questo
esercizio, modificheremo l’area di questi elementi. Si può notare come il valore di
popolazione risultante per la query Aggregation 1 è maggiore di un milione, mentre il
valore di popolazione delle altre aree è minore. Supponiamo di volere modificare il limite
della zona di rispetto a 30 miglia per il secondo ed il terzo elemento ed osservare come i
risultati dell’analisi spaziale cambino di conseguenza.

1. Selezionare Analysis > Queries.

2. Selezionare Zone 2, poi premere il pulsante Properties.

La finestra di dialogo Query Properties è ora visualizzata.

3. Nel gruppo Distance selezionare Constant e digitare 30 ad indicare 30 miglia.

4. Cliccare OK.

5. Eseguire gli stessi cambiamenti per l’elemento Zone 3.

6. Dopo aver cliccato OK nella finestra di dialogo Query Properties notare che
l’aggregazione è stata ricalcolata utilizzando i nuovi valori introdotti.

7. Premere il pulsante Close nella finestra di dialogo Queries.

8. Fare doppio click su ognuna delle aggregazioni e notare che ora il valore di
popolazione è maggiore di 1 milione.

9. Utilizzando la legenda disattivare la visualizzazione delle voci di legenda:
Aggregation 3, Aggregation 2, Aggregation 1, Zone 3, Zone 2, Zone 1, Query 3,
Query 2, e Query 1.

10. Utilizzando la scheda Groups tab, trascinare le voci di legenda che sono state
disattivate nel gruppo Not Currently used.
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11. Disabilitare la visualizzazione delle voci di legenda Buffer zones around Major
Cities.

12. Salvare il GeoWorkspace.

Continuare con la prossima sezione: 2-7 Posizionare le Etichette
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2-7 Posizionare le Etichette
Le etichette possono essere generate attraverso GeoMedia Professional utilizzando valori
presenti in un warehouse, o semplicemente inserite come testo.

Inserire un Etichetta da una Query
Un etichetta può essere una feature class o una query. Nel prossimo esercizio
posizioneremo un etichetta come query.

Come potremo notare, creare una etichetta come una query, permette di associare in
modo automatico l’etichetta con la feature class che si sta etichettando. Per questa
ragione le etichette vengono aggiornate automaticamente quando vengono modificati i
valori delle features corrispondenti.

1. Selezionare Insert > Label.

2. Nella finestra di dialogo Label selezionare la query Info on Usable Areas nel menù
a tendina Label features in.

3. Nel campo Attributes selezionare COUNTY_NAME.

L’attributo appare nel campo Layout.

4. Premere il pulsante il campo Layout ed inserire un spazio vuoto dopo l’attributo
COUNTY_NAME. Digitare COUNTY.

5. Premere il pulsante CTRL insieme ad ENTER per passare alla riga successiva.

6. Nel campo Layout, digitare Usable Area:.
7. Utilizzare la combinazione CTRL e ENTER per passare alla linea successiva.

8. Nel campo Attributes, selezionare Area.

L’attributo appare nel campo Layout.

9. Nel campo Layout, nella stessa linea, inserire uno spazio vuoto Sq Mi.
10. Impostare l’opzione Alignment su Top left.

11. Selezionare Query nel gruppo Output labels as.

12. Nel campo Query name digitare Usable Area Labels.

13. Abilitare l’opzione Enable Leader Lines.

14. Nel campo Connection selezionare learn.

Le linee di riferimento saranno esportate nella connessione learn.

15. Mantenere il nome Final Counties, e premere il pulsante il pulsante Style.

16. Premere il pulsante Bold per avere le etichette in grassetto.

17. Premere il pulsante OK per tutte le finestre di dialogo.
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Le etichette appaiono ora nella map window.

Posizionare Leader Lines per le Etichette
Ci sono due passaggi operativi per inserire delle singole linee di riferimento: nel
precedente esercizio si è vista la prima parte (sono state posizionate le etichette delle
query con l’opzione Enable Leader Lines spuntata). Il secondo passaggio è quello di
utilizzare il comando Insert Leader Line per mettere le linee di riferimento per ognuna
delle etichette.

1. Selezionare l’etichetta per la regione Adams del Wisconsin.

2. Selezionare Insert > Leader Line.

Inizieremo a digitalizzare posizionando il primo punto , cioè il punto a cui faranno
riferimento le linee guida.

3. Premere il pulsante in un punto qualunque del confine in alto della regione Adams
(la regione che si estende più a nord).

4. Posizionare un altro punto utilizzando il cursore a croce, come indicato nella figura
sottostante.
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Nota: Se si desidera rimuovere il punto posizionato, è possibile utilizzare il pulsante
BACKSPACE.

5. Quando tutti i punti sono stati posizionati (in questo caso, solo il punto di inizio ed il
punto di fine), fare doppio click ad indicare che la linea guida è completa.

Nota: E’ anche possibile, chiudere la feature utilizzando il comando End Feature
disponibile dal menù di tasto destro del mouse.

La linea guida appare a schermo, l’etichetta viene spostata alla fine della linea guida.

6. Fare doppio click sulla chiave di stile dell’elemento di legenda Leader Terminators
for UsableArea Labels

7. Fare click su Properties.

8. Fare click sul menù Type e selezionare GeoMedia Feature Symbol Files.

9. Utilizzare il pulsante Browse per selezionare il file terminator.fsm contenuto nella
cartella GeoMedia Professional\Symbols, poi fare click su Open.

10. Nel campo Name selezionare Terminator 4.

11. Accertarsi che l’opzione Define override color sia stata spuntata e che il colore
nero sia stato scelto.

12. Selezionare l’attributo Size con il valore 10.000 (10 punti).

13. Fare click su OK.

14. Selezionare ora un’altra etichetta e posizionare una nuova linea guida.

15. Posizionare le linee guida per le rimanenti etichette (si selezioni ogni etichetta
prima) in modo da avere un etichetta per ognuna delle sei regioni.

La figura sottostante mostra un esempio di dove possano essere posizionate le
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etichette; posizionate le etichette dove si ritiene più opportuno, è inoltre possibile
utilizzare più di due punto per posizionare una linea guida.

16. Salvare il GeoWorkspace.

Inserire una Feature Class di Etichette
Posizioneremo ora un’etichetta come feature class, questo permette di modificare
l’etichetta indipendentemente dalla feature a cui appartiene, per questo motivo il valore
dell’etichetta non verrà modificato quando si modifica il valore di attributo della feature
class corrispondente.

1. Selezionare Insert > Label.

2. Nella finestra di dialogo Label utilizzare il menù a tendina Label features in per
selezionare la feature class Final Counties dalla categoria Frequently used.

3. Selezionare ANNULSNOW nella lista degli attributi.

4. L’attributo appare nel campo Layout.

5. Digitare" (ad indicare i pollici) proprio dopo l’attributo nel campo Layout.

6. Accertarsi che l’attributo Alignment sia impostato su Center center.

7. Selezionare Feature class nel gruppo Output labels as.

8. Selezionare learn nel campo Connection.

9. Nel campo Feature class digitare SnowfallLabels (senza spazi).
10. Utilizzare il nome Final Counties per le etichette da visualizzare.

11. Premere il pulsante OK per chiudere la finestra di dialog.
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Le etichette appaiono ora nella map window.

Modifichiamo lo Stile del Testo della Legenda
E’ possibile modificare il testo che è stato creato in una connessione read-write, come il
testo che abbiamo creato per usare il comando Insert Feature, o il testo che è stato creato
per usare il comando Label, quando questo è generato da una feature class, come fatto
nell’esercizio precedente. Possiamo anche cambiare lo stile del testo (colore, spessore, e
altro), modificando lo stile nella legenda. Dopo aver apportato questo cambiamento
cambierà tutto il testo delle features che sono interessate da quella voce di legenda.

E’ inoltre possibile modificare lo stile nella legenda con lo scopo di modificare lo stile del
testo delle singole features. Così facendo si cambierà solo lo stile delle singole feature,
mentre lo stile delle restanti features della feature class continuerà ad essere governato
dalla definizione dello stile della legenda.

In questo esercizio, modificheremo lo stile di testo di una feature solamente, quella delle
precipitazioni nevose nella contea di Adams. Per esempio, supponiamo di voler
differenziare queste regioni dalle altre (ad esempio, si supponga che questa regione, sia
stata scelta tra le altre per la costruzione di nuovi impianti sciistici).

1. Selezionare l’etichetta delle precipitazioni nevose al centro della regione di Adams.
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2. Selezionare Edit > Edit Text.

La finestra di dialogo Edit Text viene visualizzata sullo schermo.

3. Spuntare Override Style.

4. Spuntare l’icona Bold per avere l’etichetta in grassetto.

5. Premere il pulsante OK nella finestra di dialogo Edit Text.

Il testo dell’etichetta ora è visualizzato con uno stile differente dalle alter etichette di testo.

Posizionare Freccia del Nord e Barra di Scala
GeoMedia Professional ci permette di inserire nelle mappe la freccia del Nord e la barra di
scala.

Il simbolo Nord Arrow è costituito da una freccia che punta la direzione del Polo Nord in
funzione della posizione del punto di inserimento.

In una proiezione conica, come la Albers Equal Area, la direzione dell’indicatore del nord
varia in base alla sua posizione nella map window. L’origine della proiezione è all’incirca
nel centro degli Stati Uniti. Se l’indicatore del nord è posizionato sulla costa occidentale,
esso punta in direzione nord. Se è posizionato sulla costa est, punterà in direzione nord
ovest.
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La barra di scala è un simbolo che serve a spiegare la relazione tra le dimensioni della
mappa e le unità di misura reali. Il simbolo può essere definito specificando numero e
dimensione degli intervalli che lo costituiscono. La barra di scala predefinita in GeoMedia
Professional è il 20 % della larghezza della mappa ed è capace di adattarsi
dinamicamente alle operazioni di zoom.

1. Selezionare View > North Arrow per posizionare la freccia del nord.

La freccia del nord è stata posizionata.

Nota: Se la freccia del nord non risulta visibile, potrebbe essere stata posizionata al di
sotto della legenda, per risolvere questo problema, spostare la legenda e disporre il
simbolo in una posizione più adeguata.

2. Fare click con il pulsante destro sulla freccia, poi selezionare Properties per
visualizzare la finestra di dialogo North Arrow Properties.

3. Premere il pulsante Browse per modificare la simbologia della freccia.

E’ possibile effettuare la propria scelta tra un cospicuo numero di frecce del nord.

4. Selezionare arrow3.wmf, e premere il pulsante Open.

Nella finestra di Preview è possibile visualizzare la nuova simbologia.

5. Si vogliano ora ridurne le dimensioni, modificando l’attributo Size con il valore 54.

6. Premere il pulsante Save As Default.

Per utilizzare la freccia scelta come predefinita, o per utilizzare la freccia durante le
operazione di batch plotting è necessario salvare il simbolo come simbolo predefinito.

7. Premere il pulsante OK per chiudere la finestra di dialogo.

Si voglia spostare la freccia, nell’angolo in alto a destra della map window.

8. Selezionare View > Scale Bar per posizionare la barra di scala.

La barra di scala è stata posizionata.

Nota: Se la barra di scala non risulta visibile, potrebbe essere stata posizionata al di sotto
della legenda, per risolvere questo problema, spostare la legenda e disporre il simbolo in
una posizione più adeguata.
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9. Fare click destro sulla barra di scala, poi selezionare Properties per visualizzare la
finestra di dialogo Scale Bar Properties.

10. Premere il pulsante di scheda Intervals and Units.

11. Cambiare il valore di Interval unit in mi che sta ad indicare le miglia.

12. Accertarsi che Miles si ora il valore di Label.

13. Premere il pulsante di scheda Style.

14. Verificare che l’attributo Type sia impostato su Single Block with Centerline.

15. Cambiare l’attributo colore per Lines con un altro colore, blu ad esempio, poi
premere il pulsante OK nella finestra di dialogo Color.

16. Premere il pulsante Save As Default.

17. Se si desidera utilizzare questo prototipo di barra di scala in altre finestre di layout,
o in una procedura di batch plotting, sarà necessario salvare la barra di scala scelta
come predefinita.

18. Premere il pulsante OK.

19. Salvare il GeoWorkspace.

Escludere le Voci di Legenda
Al fine di preparare gli output finali, è necessario escludere le voci di legenda che non si
vogliono far apparire nella mappa.

1. Se al momento la legenda non è visibile, selezionare View > Legend.

2. All’interno della scheda Groups, verificare che tutte e sole le seguenti voci di
legenda appartengano al gruppo Not currently used (le features e le queries
potrebbero essere in un ordine differente da quello riportato di seguito):

- Aggregation 3
- Aggregation 2
- Aggregation 1
- Zone 3
- Zone 2
- Zone 1
- Query 3
- Query 2
- Query 1
- Info on Usable Areas
- Usable Areas
- Restricted Zones
- Geocoded Points of Restricted_Sites
- Small Counties Around Major Cities
- Cities
- States by Snow/avetemp
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- PopulationDensity of 6 OutputCounties
- OutputCounties
- Selection of OutputCounties
- OutputStates (thematic map)
- States
- SampleImages

3. Verificare che nessuna delle voci dell’elenco riportato di seguito appartenga al
gruppo Not currently used, utilizzando la scheda di legenda Display Order
accertarsi che l’ordine di visualizzazione sia il seguente:

- SnowfallLabels
- Usable Area Labels
- Leader Terminators for Usable Area Labels
- Leader Lines for Usable Area Labels
- StateNameLabels
- Major Cities
- Interstates
- Final Counties
- Buffer zones around Major Cities
- OutputStates

4. Si faccia doppio click nel campo Leader Terminators for Usable Area Labels
(utilizzare la stringa di testo, e non la chiave di stile), poi digitare un titolo più breve per
questo elemento: Leader Terminators.

5. Si faccia doppio click nel campo Leader Lines for Usable Area Labels, poi
introdurre il seguente nome: Leader Lines.

6. Si faccia doppio click nel campo Buffer zones around Major Cities poi introdurre il
seguente nome: Buffer Zones.

7. Salvare il GeoWorkspace.

Congratulazioni! Avete completato con successo il flusso di lavoro Analisi dei dati. Potete
continuare ora con il prossimo flusso di lavoro, o con qualunque altro flusso si ritenga utile,
utilizzando l’indice dei contenuti di Impariamo GeoMedia Professional.
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3 - Creare una Versione Stampabile dei Risultati
Possiamo stampare i risultati delle nostre analisi utilizzando la finestra di layout di
GeoMedia Professional. La finestra di layout usa i frames di layout, che sono i contenitori
delle informazioni. La mappa finale si compone almeno un frate di mappa creato a partire
dal map window e di altre informazioni: la legenda, l’indicatore del nord e la barra di scala.
Un frame di layout contenente la mappa e le informazioni di supporto, sono chiamate
gruppo. Ogni struttura di layout dentro un gruppo sa quale tipo di mappa grafica contiene,
ovvero se la struttura di layout è una mappa o una legenda, e così via. Ogni foglio di
layout nella finestra di layout può contenere multipli gruppi di strutture di layout, dove ogni
gruppo contiene una sola mappa grafica, come la mappa delle Final Counties o la mappa
degli US.

In questa sezione, importeremo un layout da un Layout Template di GeoMedia (tipo di
dato .glt). Il template definisce automaticamente i parametri di organizzazione della pagina
e contiene 4 frames: per una mappa, per l’indicatore del nord, la legenda, e la barra di
scala. Aggiungeremo un’immagine, poi popoleremo tutte le strutture di layout con i
contenuti delle due map window. Che sono state realizzate in precedenza.

In seguito, inseriremo una mappa d’insieme, e modificheremo le proprietà della legenda e
la posizione dell’indicatore del nord, ed inseriremo una seconda barra di scala.
Modificheremo il nome del foglio di layout, posizioneremo un rettangolo, e poi
aggiorneremo lo stile per la mappa grafica. Quindi inseriremo una griglia cartografica,
adegueremo le dimensioni della struttura della mappa, faremo una panoramica dentro di
essa, e opereremo uno zoom sulla reale misura del foglio per creare un’anteprima
dell’output grafico. In fine, esporteremo in un formato raster e stamperemo i risultati.

Prima di Cominciare
Prima di cominciare questa sessione eseguire i seguenti passaggi:

1. Se avevate completato la sessione precedente usando learn.gws (così che
learn.gws e learn.mdb sono stati salvati), eseguire GeoMedia Professional ed aprire il
file learn.gws.

- OPPURE -

1. Se l’esercizio precedente non è stato completato, copiare il file
learn_beforeplot.gws nella cartella GeoWorkspaces come learn.gws, poi copiare il file
learn_beforeplot.mdb nella cartella Warehouses come learn.mdb (si consiglia di fare
una copia di archivio dei files learn.gws e learn.mdb, utilizzando un nome differente).
Poi eseguire GeoMedia Professional ed aprire il file learn.gws.

2. Se i files USSampleData.mdb e learn.mdb sono in percorsi differenti da
C:\Warehouses, quando si cercherà di aprire il file learn.gws, si otterrà il seguente
messaggio: "An error occurred while attempting to open connection '<connection
name>'. Verify that your connection parameters are correct and try again." Per
risolvere questo problema, utilizzare il pulsante Browse con lo scopo di localizzare i
files .mdb associati al file di progetto, poi premere il pulsante OK.
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3. Se GeoMedia Professional è stato installato in qualunque percorso diverso da
C:\Program files\GeoMedia Professional, quando si cercherà di aprire il file learn.gws si
otterrà il seguente messaggio: "An error was encountered loading data for Usable Area
Labels legend entry. Do you want to continue loading remaining legend entries?" Per
correggere l’errore, premere il pulsante Yes per questo ed altri messaggi di errore. Poi
nella finestra di mappa Final Counties, selezionare Warehouse > Feature Class
Definition. Selezionare Restricted_Sites dalla connessione learn poi premere il
pulsante Edit. Nel campo Data source digitare il percorso della cartella Learning.
Premere il pulsante OK, poi Close. Fare doppio click sulla chiave di stile della voce di
legenda Leader Terminators poi premere il pulsante Properties. Utilizzare il pulsante
Browse per navigare fino alla corretta locazione del file terminator.fsm. Nel menù a
tendina Name selezionare Terminator 4, e la Size di 10.000, poi abilitare l’opzione
Define override color e scegliere il colore nero. Premere il pulsante OK per tutte le
finestre di dialogo. Fare doppio click sull’elemento di stile della voce di legenda Major
Cities, poi premere il pulsante Properties. Utilizzare il pulsante Browse per
localizzare il file transportation.fsm. Nel menù a tendina Name selezionare City
Symbol #4, poi impostare l’attributo Size a 10.000, accertarsi che l’opzione Define
override color non sia spuntata, poi premere il pulsante OK per tutte le finestre di
dialogo.

4. Nella map window Final Counties fare click destro sulla barra di scala e
selezionare Properties. Nella finestra di dialogo Scale Bar Properties, premere il
pulsante Save as Default, poi OK. Fare click destro sulla freccia del Nord e scegliere
Properties. Nella finestra di dialogo North Arrow Properties selezionare arrow3.wmf,
poi premere il pulsante Save as Default. Premere il pulsante OK.

IMPORTANTE: Quando GeoMedia sembra non rispondere ai comandi (ad esempio il
tasto ESC non permette di uscire dai comandi), accertarsi che la finestra attiva sia
GeoMedia Professional e non la finestra di tutorial.

Preparare la Map Window per la Stampa
Accertarsi ora che le features che si stanno visualizzando siano quelle che si intende
utilizzare nella mappa finale. Per prima cosa assicurasi che l’area geografica che si vuole
utilizzare nella layout window sia adeguatamente visualizzata nella map window. Inoltre è
necessario assicurarsi che le impostazioni delle simbologie per la grafica, essendo
visualizzate, siano definite in maniera adeguata per essere visualizzate nella layout
window.

Come si può notare, le features attive possono essere visualizzate differentemente in base
alle impostazioni della scale di visualizzazione e della legenda. Durante la fase di analisi
sono utili alcune impostazioni della simbologia, grazie alle quali la scala di visualizzazione
viene costantemente modificata. La mappa finale generalmente visualizza in maniera
diversa i risultati, e bisogna che le impostazioni scelte assicurino che le features siano
visualizzate correttamente o ad una fissata scala di mappa nominale o ad una scala di
layout.

Inoltre, può risultare difficoltoso disegnare la mappa come era stata costruita. Ad esempio,
è richiesto frequentemente di creare tutte le feature prima di assegnare la simbologia
finale. GeoMedia Professional utilizza un approccio di plotting che permette di rendere alla
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scala di visualizzazione le features che si vogliono stampare utilizzando la finestra di
layout.

Nota: In questo esercizio, prepareremo la map window per rappresentare l’area della
mappa di layout desiderata poi imposteremo le proprietà di visualizzazione, in modo che le
features appaiano nella map window proprio come nella mappa finale. Questo approccio
di lavoro è buono per mappe di stampa piccole, come la misura A o la grandezza del foglio
A4, che sono generalmente più piccoli dello schermo.

Per mappe di dimensioni più grandi, che superano la grandezza del monitor, non saremo
capaci di visualizzare nella map window, sullo schermo, tutta l’area geografica alla scala di
mappa desiderata. Quando questo accade, si può ovviare attraverso le operazioni
specificate prima. (Impostare le proprietà di visualizzazione, così che le features appaiano
nella map window proprio come le vorreste vedere nella mappa finale, usando un
sottoinsieme di questa, visualizzato nella map window alla scala di stampa). Potete usare
il comando Pan per navigare intorno alla map window per avere un’anteprima dell’intera
mappa di stampa. Quando si è soddisfatti delle impostazione di simbologia, utilizzare il
controllo di zoom out per accertarsi che l’area della mappa di stampa desiderata appaia
nella map window.

1. Selezionare Window > Cascade per vedere tutte le finestre.

2. Rendere attiva la finestra US Map e ingrandirla il più possibile modificando la
grandezza dei bordi.

3. Utilizzare i controlli Fit e Pan come da necessità, per centrare la mappa nella map
window.

4. Selezionare Window > Final Counties per attivare la finestra Final Counties
ingrandirla il più possibile modificando la grandezza dei bordi.

Ora la finestra Final Counties copre la finestra US Map.

5. Utilizzare i controlli Fit e Pan come da necessità, per centrare la mappa nella map
window.
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E’ possibile notare come la visualizzazione della finestra di mappa Final Counties
contenga alcune features. Alcune delle features hanno il controllo Style Scaling impostato
su View (size is true at any display scale), mentre altre hanno sono impostate su Paper
(size is true at nominal map scale).

Quando i dati vengono trasferiti dalla finestra di mappa alla finestra di layout, viene
utilizzata una scala di proporzioni che regola il rapporto tra la visualizzazione in map
window che dipende dal rapporto che la realtà che si vuole rappresentare, e la layout
window, le cui impostazioni sono legate con la grandezza della carta su cui si produrranno
le stampe. Per questa ragione quando la scala di plottaggio e quella di visualizzazione
coincidono, c’è una corrispondenza perfetta tra le proporzioni descritte dalla finestra di
mappa e dalla finestra di layout. Quando questa proporzione non viene rispettata, tutte le
features che sono impostate su View risulteranno proporzionate diversamente, per questa
ragione tutte le features andrebbero impostate su Paper. Quando ci si sente soddisfatti dei
risultati raggiunti, si può salvare la legenda, utilizzando un nome appropriato.

6. Accertarsi che la finestra attiva sia Final Counties selezionare poi Legend > Name
Legend.

7. Nella finestra di dialogo Name Legend digitare Final Counties - Analysis, poi
premere il pulsante OK.

8. Selezionare View > Display Properties.

9. Impostare sia la Display scale che la Nominal map scale a 1:5,000,000 (che è
approssimativamente la scala di visualizzazione), selezionando 5,000,000 sia nel
menù a tendina Display scale che nel Nominal map scale menù a tendina.

La scala di visualizzazione attuale potrebbe essere maggiore o minore di questo valore,
ma l'uso di questo valore, 1:5.000.000, assicurerà la coincidenza tra i risultati e la guida.

10. Selezionare Paper (size is true at nominal map scale).

Questo servirà ad accertarsi che il parametro Style Scaling sia correttamente impostato
su Paper per tutte le feature classes. Nel nostro esempio la scala di visualizzazione è
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circa 1:5,000,000, allora è necessario impostare sia Display Scale che Nominal map
Scale sul valore 1:5,000,000.

11. Premere il pulsante Apply, poi Close, nella finestra di dialogo Display Properties.

Tutte le features che prima erano impostate su View, potrebbero essere ora visualizzate
differentemente. Ora è possibile modificare lo stile di visualizzazione con la certezza che i
risultati di queste operazioni verranno visualizzati nella display window esattamente come
nell’output finale che come detto corrisponde alla scala 1:5,000,000.

Si può ora ridefinire la simbologia, si consiglia di cominciare dalle features areali, disposte
sul fondo della legenda, per concludere con le etichette, che sono disposte in alto.

12. Fare doppio click sulla chiave di stile della voce di legenda OutputStates.

13. Selezionare lo stile PLOT OutputStates contenuto nella cartella Learning.

14. Premere il pulsante OK nella finestra di dialogo Legend Entry Properties.

Lo stile di visualizzazione di OutputStates è stato correttamente.

15. Ripetere i passaggi da 12 a 14 per le seguenti voci di legenda, utilizzando lo stile
predefinito PLOT <name of legend entry>, (ad esempio PLOT BufferZones per
BufferZones): BufferZones, Final Counties, StateNameLabels, UsableAreaLabels,
e SnowfallLabels.

16. Dopo aver apportato le modifiche richieste, la mappa Final Counties dovrebbe
assomigliare a quella descritta nella figura sottostante.
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L’immagine ottenuta, potrebbe contenere delle sconvenienti sovrapposizioni nel testo.
Questo è abbastanza comune quando il testo viene posizionato o spostato prima di
impostare la simbologia finale. Dopo aver concluso la mappa, è comunque possibile
effettuare dei cambiamenti alla simbologia di testo.

17. Accertarsi che la finestra attiva sia US Map (selezionare Window > US Map), poi
disattivare la visualizzazione della feature StateNameLabels.

Queste features sono troppo piccole per essere leggibili nella versione finale.

18. Salvare il GeoWorkpace.

Importare un Layout Preesistente
Di seguito importeremo un layout esistente da un Template di Layout di GeoMedia (file
.glt). Il template automaticamente definisce i parametri di organizzazione della pagina e
contiene 4 strutture di layout (per una mappa, per il north arrow, la legenda, e la barra di
scala). Si potranno distinguere il primo piano e lo sfondo dei fogli di template.

1. Selezionare Window > Show Layout Window.

La finestra di Layout è ora visualizzata.

Nota : Se la finestra della guida è collocata a lato della finestra di layout, mentre ci si
sposta avanti e indietro tra una finestra e l'altra, potrebbe essere più facile dapprima fare
click sulla finestra di layout per assicurarsi che sia attiva e poi effettuare qualsiasi azione
particolare nella finestra di layout.

2. Ingrandire la finestra di Layout.

3. Selezionare View > Toolbars.

4. Selezionare le toolbars Aligning, Editing, Layout, Placing, Ribbon, e Standard.

5. Premere il pulsante OK nella finestra di dialogo Toolbars.

Le toolbars selezionate sono ora visualizzate.

6. Utilizzare il comando View > Drawing Toolbox per visualizzare la toolbar Drawing,
che è mostrata nella figura sottostante, nel caso in cui non sia già visibile.
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Disporre le toolbar nel modo che si reputa più conveniente, in modo da facilitarne l’utilizzo.

7. Selezionare Sheets > Import Layout.

8. La finestra di dialogo Import Layout viene visualizzata sullo schermo.

9. All’interno del menù a tendina Files of type accertarsi che il tipo di dati GeoMedia
Layout Templates (*.glt) sia selezionato.

10. Selezionare il file LearningTemplate.glt, che si trova all’interno della cartella
Learning.

11. Premere il pulsante Open.

Il template è ora aperto e pronto ad essere utilizzato.

12. Selezionare View > Fit.

13. Utilizzeremo un foglio chiamato A Wide. La finestra di layout provvede ad un foglio
per lavorare e un foglio per l’ambiente di sfondo, che verrà esaminato nel dettaglio più
avanti. Rimuoveremo il foglio di lavoro predefinito, chiamato Sheet 1.

14. Quando invece si è alle prese con un flusso di lavoro che non richiede l’utilizzo dei
template, può risultare conveniente, piuttosto che modificare dei fogli o cancellarli,
partire da zero.

15. Selezionare Sheet 1 Cliccando sulla scheda Sheet 1 nell’angolo in basso a sinistra
della finestra di layout.

16. Selezionare Sheet 1 ed al fine di eliminare il foglio, utilizzare il comando Sheets >
Delete Sheet.

17. Premere il pulsante OK quando viene richiesta conferma.

18. Il foglio Sheet 1 è stato cancellato.

Se è presente un altro foglio con il nome Symbol si cancelli anche questo foglio.
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Il foglio A Wide è ora il foglio di lavoro, e descrive il primo piano del layout.

La Funzione Page Setup
Quando si utilizza un template, l’organizzazione del foglio è definita a priori. Si può
utilizzare il comando Page Setup per apportare modifiche alla grandezza del foglio,
all’orientamento, ed alle altre impostazioni della pagina.

1. Selezionare File > Page Setup.

Nella finestra di dialogo Layout Window Page Setup si può notare che l’attributo Name è
impostato su A Wide, l’attributo Background su A Wide - Background, mentre Paper
Size vale A Size Sheet, ed Orientation è stato impostato su Landscape.

Inoltre è possibile notare che il controllo Image Quality che ha cinque possibili
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impostazioni, da Draft a Best, questa funzione serve a gestire il rapporto tra qualità
dell’immagine e la velocità di visualizzazione.

Nota: quando si utilizzano fogli multipli, ogni foglio dovrebbe contenere il proprio layout di
pagina. Se si vuole utilizzare la stessa configurazione di layout per tutti i fogli, è possibile
tramite il comando Save as Default, salvare tutte le impostazioni descritte dal comando
Page Setup.

2. Sganciare il foglio di background selezionando il campo bianco (il primo campo) nel
menù a tendina Background.

3. Premere il pulsante OK nella finestra di dialogo Layout Window Page Setup.

Notare che i frames di layout ed il Plot Title sono localizzati nel foglio di lavoro. Gli altri
titoli invece come Map e Legend, sono oggetti grafici non più visibili in quanto collocate
nel foglio di sfondo.

4. Selezionare View > Background Sheets per visualizzare gli oggetti grafici che
sono nel foglio di background.

5. E’ possibile notare i bordi e il testo addizionale che sono localizzati nel foglio di
sfondo.

6. Selezionare View > Working Sheets.
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7. Per visualizzare gli oggetti grafici sul foglio di sfondo e sul foglio di lavoro
contemporaneamente, è necessario collegarli.

Per collegare nuovamente A Wide - Background con A Wide i fogli di lavoro devono
essere visibili. Due fogli di sfondo non possono essere collegati.

8. Selezionare File > Page Setup.

9. Selezionare A Wide - Background nel menù a tendina Background.

10. Premere il pulsante OK.

Il foglio di sfondo è ora visualizzato insieme con il foglio di primo piano.

Inserire un’Immagine
Inseriremo ora nella finestra di layout una immagine di GeoMedia.

1. Selezionare Insert > Object.

La finestra di dialogo Insert Object è ora visualizzata.

2. Mantenere abilitata l’opzione Link.

3. Premere il pulsante Browse.

4. Selezionare il file logo.bmp nella cartella Learning poi premere il pulsante Open.
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5. Premere il pulsante OK nella finestra di dialogo Insert Object.

6. Fare in modo che l’immagine venga adattata ai bordi del template.

Nota: Può risultare necessario ridimensionare l’immagine, a questo proposito notare che i
manici sugli angoli ridimensionano l’immagine in scala, mentre quelli laterali permettono di
modificarne le proporzioni.

7. Mentre l’immagine è ancora selezionata, e i manici sono visibili come mostrato nella
figura sottostante, fare click destro e selezionare Properties.

8. Selezionare la scheda General.

9. Togliere la spunta Display boundary.

10. Premere il pulsante OK nella finestra di dialogo Object Properties.

11. Una volta premuto il pulsante al di fuori dell’immagine, sarà possibile notare i bordi
scomparire.

12. Salvare il GeoWorkspace.
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Inserire i Grafici nelle Strutture di Layout
Una volta disegnato il layout di mappa, è possibile popolare la struttura di layout.
Utilizzeremo il comando Insert Graphics into the Layout Frames, che permette di
inserire mappe ed elementi al contorno su un foglio di layout.

Nel foglio di layout selezionare il gruppo di frames di layout.

Tutti i frames del gruppo sono ora selezionati, la finestra di layout dovrebbe apparire simile
alla figura sottostante.

1. Mantenendo selezionato il gruppo, selezionare Insert > Graphics into Layout
Frames.

2. La finestra di dialogo Insert Graphics into Layout Frames è ora visualizzata.

3. Nel menù a tendina Map window selezionare Final Counties.

4. Accertarsi che Map Window sia selezionata nel campo Method di Geographic
extent.

5. Selezionare Fit to Frame tra le opzioni di Plot scale.

6. Accertarsi che i tre oggetti Associated marginalia siano stati spuntati: Legend,
North Arrow, and Scale Bar.

7. Accertarsi che Dynamic sia stato selezionato nel campo Mode.

Questa opzione serve ad assicurare che la finestra di layout venga modificata quando la
finestra di mappa viene modificata.

8. Premere il pulsante OK.

La mappa la legenda, la freccia del nord, la barra di scala sono ora posizionate all’interno
del frame di layout.
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Inseriamo una Nuova Mappa
Il comando Insert Map permette di inserire una mappa nel foglio di layout nella finestra di
layout senza richieste predefinite di frames di layout. Inseriremo ora un’altra mappa,
insieme all’altro gruppo di frames di mappa e di elementi al contorno che era già stato
usato con il template. Questa mappa non avrà nessun elemento al contorno associato, ma
utilizzando i comandi Insert Layout, Insert Scale Bar, e Insert North Arrow, è sempre
possibile aggiungere gli elementi che si desiderano per completare il layout come
desiderato.

1. Selezionare Insert > Map.

2. La finestra di dialogo Insert Map viene visualizzata sullo schermo.

3. Nel menù a tendina Map window selezionare US Map.

4. Accertarsi che Map Window sia selezionato nel campo Method di Geographic
extent.

5. Nel campo Plot scale, digitare 100,000,000.

6. Selezionare Static.

7. Selezionare questa opzione, farà si che quando un cambiamento viene effettuato
nella map window US Map, questo non si rifletterà sulla proiezione della mappa nel
foglio di layout. Se necessario, è possibile utilizzare il comando Update Map
Graphics, quando si intende aggiornare le immagini statiche.

8. Premere il pulsante OK.

9. Viene richiesto di posizionare la Map Window US Map.

10. Posizionare il frame in alto nel template accanto al più grande dei frames (riferirsi
se alla figura sottostante), poi premere il pulsante con il mouse.
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11. Salvare il GeoWorkspace.

Modificare la Legenda
E’ possibile utilizzare la finestra di dialogo Layout Legend Properties per modificare la
leggenda come vogliamo che appaia. E’ possibile modificare alcuni aspetti della legenda,
come specificare il numero delle colonne e distribuire le voci uniformemente da una parte
all’altra delle colonne, modificando lo stile predefinito delle singole voci di legenda, ed
ordinare le voci alfabeticamente o per geometria. E’ anche possibile aggiungere,
rimuovere o rinominare le voci o le colonne. Inoltre, possiamo modificare lo stile del testo
delle voci di legenda, e possiamo impostare la spaziatura tra voci di legenda e le colonne.
Possiamo anche definire un bordo (e selezionare il suo colore, lo stile, o lo spessore) di
legenda.

In questo esercizio, aggiungeremo un titolo alla legenda, ordineremo le voci, cambieremo
il nome di una voce, e modificheremo lo stile di ogni voce.

Prima, verrà eliminato il testo nel foglio di sfondo.

1. Selezionare View > Background Sheets.

2. Utilizzando il pulsante CTRL selezionare Map, Scale Bar, Legend, e North Arrow.

3. Premere DELETE.

Tutto il testo nel foglio di sfondo è stato cancellato.

4. Ritornare al foglio di lavoro selezionando View > Working Sheets.

5. Premere il pulsante sulla legenda per visualizzarne le maniglie, poi fare click con il
pulsante destro.

6. Selezionare Properties dal menù di tasto destro del mouse.

7. La scheda Legend della finestra di dialogo Layout Legend Properties viene
visualizzata, potremo all’interno di questa finestra, compiere tutti i cambiamenti
necessari.
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8. Premere il pulsante sull’elemento Legend, quello più in alto all’interno del campo
Right click to manipulate legend items e scegliere Properties.

9. Nella finestra di dialogo Legend Properties visualizzata, accertarsi che l’opzione
Display title in legend si stata abilitata.

10. Digitare Map Legend nel nome del titolo Name.

11. Nella porzione in alto a sinistra della finestra di dialogo accertarsi che l’opzione
Alignment sia giustificata, poi premere il pulsante Font.

12. Selezionare Bold, poi scegliere 14 nel campo Size, poi premere il pulsante OK.

Osservare anche le restanti opzioni nelle finestre di dialogo.

13. Il gruppo Columns permette di decidere il numero delle colonne nella legenda e lo
spazio tra gli elementi.

14. Il gruppo Names permette di specificare il font utilizzato per gli elementi di legenda,
lo spazio tra essi, e se le chiavi di stile delle voci di legenda saranno visualizzate a
destra o a sinistra delle voci di legenda.

15. Il gruppo Graphic key defaults permette di specificare le forme e le dimensioni
predefinite per le features lineari ed areali.

16. Per il momento, si voglia modificare solo una di queste impostazioni.

17. Selezionare Font nel gruppo Names specificare 10 per l’attributo Size.

18. Premere il pulsante OK nella finestra di dialogo Font poi premere il pulsante OK
nella finestra di dialogo Legend Properties.

19. Sarà ora possibile ordinare gli elementi di legenda.

20. Fare click con il pulsante destro su Column 1 (10 Entries) nella finestra di dialogo
Layout Legend Properties.

21. Selezionare Sort Entries by Geometry.

Si vogliano visualizzare le voci di legenda nel seguente ordine: Testi, Punti, Linee,
Composti, e Aree.

22. Fare click con il pulsante destro sulla voce di legenda Interstates.

23. Selezionare Properties nel menù di tasto destro.

24. Spuntare l’opzione Override default graphic key.

25. Nel campo Shape selezionare ZigZag.

26. Premere il pulsante OK.

27. Premere il pulsante OK nella finestra di dialogo Layout Legend Properties.

La legenda è stata aggiornata.

28. Salvare il GeoWorkspace.
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Utilizzo della North Arrow
Il comando Nudge è utilizzato per regolare gli elementi che si trovano nell’impostazione di
selezione, ovvero per spostarli con precisione nel foglio. Sono 4 i comandi di Nudge:
Nudge Up, Nudge Down, Nudge Left, e Nudge Right. Ognuno di essi muove gli oggetti
nel reticolato di un passo nella direzione stabilita.

Useremo questo comando per spostare leggermente l’indicatore del nord in una o più
direzioni, affinché venga posizionato al di sotto della legenda che è stata modificata
precedentemente.

1. Selezionare la freccia del Nord.

2. Selezionare Draw > Nudge > Up nella toolbox Drawing o similarmente utilizzare la
freccia verso l’alto della tastiera. (Accertarsi che GeoMedia Professional sia la finestra
attiva).

3. Utilizzare il comando Nudge finchè la freccia del nord è posizionata in una
posizione conveniente.

Posizionare una Seconda Barra si Scala
Il comando Insert Scale Bar ci permette di posizionare una barra di scala associata alla
mappa precedente, nel foglio di layout. Questo comando permette di definire le proprietà
della barra di scala prima che questa venga inserita.

La prima barra di scala posizionata era in miglia, ora, invece, verrà posizionata una
seconda barra di scala in chilometri.

Si selezioni il più grande dei map frame nel foglio di layout.

1. Selezionare Insert > Scale Bar.
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2. Nel campo Type selezionare il tipo Double Block.

3. E’ possibile notare come il campo Preview mostri un anteprima della nuova barra di
scala.

4. Nel campo Unit, selezionare km

L’etichetta Unit label cambia in Kilometers.

5. Premere il pulsante Properties.

E’ naturalmente possibile specificare le proprietà della barra di scala prima di posizionarla,
anche se le proprietà di questo elemento possono essere modificate anche dopo
l’avvenuto posizionamento nella mappa.

6. Premere il pulsante di scheda Intervals and Units.

7. E’ possibile definire la lunghezza ed il numero degli intervalli spuntando l’opzione
Define intervals ed introducendo i valori che si vogliono, oppure si può lasciare che il
sistema calcoli automaticamente i valori.

8. Lasciare disabilitata l’opzione Define intervals.

9. Se si desidera è possibile selezionare Label e Position per l’etichetta.

10. Premere il pulsante di scheda Style.

11. Scegliere i colori che si preferiscono per Lines, Major fill, e Minor fill.

12. Premere il pulsante di scheda Labels.

E’ possibile mantenere o modificare le impostazioni predefinite per le etichette.

13. Il pulsante Save as Default può essere utilizzato tutte le volte che si desidera
salvare i cambiamenti effettuati. Se salvate le impostazioni scelte, vengono utilizzate
come predefinite quando si utilizza il comando Insert Scale Bar.

Per questa volta non scegliere il comando Save as Default.

14. Quando si sono portati a termine i cambiamenti desiderati, premere il pulsante OK
nella finestra di dialogo Scale Bar Properties ed OK nella finestra di dialogo Insert
Scale Bar.

Viene richiesto di posizionare la scale bar.

15. Posizionare la scale bar, al di sopra ed a sinistra della prima scale bar, come
mostrato nella figura sottostante.
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16. Salvare il GeoWorkspace.

Allineare le Barre di Scala
Ci sono molti comandi per allineare gli elementi tra loro: Align Left, Align Right, Align
Top, Align Bottom, Align Middle, ed Align Center. Gli elementi selezionati vengono
allineati con la regola scelta.

1. Selezionare la seconda barra di scala, e, premendo il pulsante SHIFT key,
selezionare la prima.

2. Selezionare il comando Align Bottom nella toolbar Layout Align.

La nuova barra di scala si allinea con la vecchia.

3. Utilizzare il comando Nudge se necessario per regolare il posizionamento relative
delle barre di scala.
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Modificare il Testo
Modificheremo ora il testo nel per la finestra di layout.

1. Premere il pulsante sul testo Plot Title, poi fare doppio click sul testo.

Il punto di intersezione è posizionato nella stringa di testo.

2. Cancellare il testo, e digitare Learning.

E’ possibile modificare il carattere o la dimensione di una stringa di testo, selezionando il
testo e utilizzando la toolbar Text per apportare i cambiamenti del caso.

Posizionare un Rettangolo
Ora posizioneremo un rettangolo sulla mappa d’insieme.

1. Selezionare il pulsante Rectangle nella toolbar Placing.

Il rettangolo verrà posizionato in modo da evidenziare un’area nella mappa.

2. Premere il pulsante sulla mappa con lo scopo di posizionare il punto in alto a
sinistra nella finestra US Map, poi posizionare il punto in basso a destra come indicato
nelle figure sottostanti.

3. Il rettangolo è stato disegnato.

4. Premere ESC.

5. Selezionare il rettangolo, premere il pulsante Line Color nella toolbox Drawing poi
scegliere il colore rosso.

6. Con il rettangolo selezionato, impostare l’attributo Line Width a 2.000.

7. Premere il pulsante fuori dal rettangolo per visualizzare l’avvenuto cambiamento
negli attributi.
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Se si vogliono ulteriormente modificare le proprietà dell’oggetto, è possibile, dopo aver
cliccato con il tasto destro, utilizzare il comando Properties.

Aggiornare lo Stile delle Componenti Grafiche della Mappa
Apporteremo ora un cambiamento alla mappa Final Counties. Come vedremo, è
possibile cambiare lo stile del grafico di mappa direttamente dalla finestra di layout, senza
passare per la map window.

1. Selezionare il più grande dei frames, poi premere il pulsante destro.

2. Selezionare il comando Map Window Legend Properties dal menù di pulsante
destro del mouse.

3. Fare doppio click sulla chiave di stile della voce di legenda Buffer Zones poi
premere il pulsante Properties.

4. Nella finestra di dialog Style Properties selezionare Simple Line Style come
Boundary Styles.

5. Nel lato destro della finestra di dialogo, selezionare il menù Line type, poi scegliere
Short Dash.

6. Premere il pulsante OK nella finestra di dialogo Style Properties e nella finestra
Legend Entry Properties.

7. Chiudere utilizzando la X presente nella barra di titolo, la finestra di dialogo Map
Window Legend Properties.

Le buffer zone vengono visualizzate con linee spezzate invece che continue.

8. Salvare il GeoWorkspace.

Nota: Dal momento che la mappa più grande è stata inserita come mappa dinamica,
alcuni cambiamenti apportati nella map window dovrebbero riflettersi nella finestra di
layout, mentre la mappa più piccola è stata posizionata come statica, ed i cambiamenti
apportati nella map window non si dovrebbero riflettere nella relativa finestra di layout. Se
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si vuole aggiornare un oggetto statico, come la mappa d’insieme, si avrà bisogno di
utilizzare il comando Update Map Graphics.

Utilizzo della Griglia Cartografica
Vedremo ora il comando Insert Cartographic Grid che permette di inserire reticolati e
graticole.

1. Selezionare la più grande delle finestre di mappa.

2. Selezionare Insert > Cartographic Grid.

Selezionare tutte le schede presenti per avere una visione d’insieme di tutti i possibili
settaggi, ma non apportare cambiamenti.

3. Premere il pulsante OK per posizionare una grigia cartografica.

La griglia cartografica è disegnata, con il colore rosso che era stato specificato utilizzando
il comando Line Color della toolbox Drawing.

E’ ora possibile rimuovere la griglia.

4. Selezionare la grigia cartografica, poi DELETE.

La grigia cartografica è stata rimossa.

5. Salvare il GeoWorkspace.

Ridimensionare il Frame della Mappa: il Comando Side File Handles
Ci sono due differenti modi di ridimensionare una struttura di mappa dopo averla
posizionata: quando si vuole modificare la scala delle strutture di mappa, si possono
utilizzare i “manici angolari del file” (corner file handles) con lo scopo di ridimensionare i
frames. In questo caso, la barra di scala viene modificata in relazione alla nuova scala
della mappa. In altri casi, se si vuole ridurre o allargare la grandezza delle strutture di
mappa senza influenzare la scala della mappa, si utilizzeranno i manici laterali del file
(side file handles).
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In questo esercizio, si può ridurre la dimensione dei map frame utilizzando gli appositi
strumenti.

1. Selezionare il più grande dei map frame.

2. Posizionare il cursore sulla maniglia laterale sul limite sinistro del frame di layout.

Il cursore viene modificato.

3. Selezionare la maniglia laterale e trascinarla verso l’interno fino a raggiungere la
dimensione mostrata nella figura sottostante.

4. Lasciare il cursore.

5. Ripetere il processo per l’altro lato del frame di mappa.

Il frame di mappa ora comprende una porzione minore della mappa.

Il Comando Pan in sede di Layout

E’ possibile utilizzare il comando Map Pan per muoversi nella map window.

1. Selezionare il frame di mappa più grande, che è stato ridimensionato nel
precedente esercizio.

2. Utilizzando il menù di tasto destro del mouse, selezionare il comando Map Pan.

3. Posizionare il cursore all’interno della Map Window e trascinarne il contenuto nel
modo che si reputa più conveniente.

Il contenuto del frame di mappa è stato spostato all’interno del layout.

4. Premere ESC per uscire dal comando Map Pan.

5. Utilizzando i controlli di dimensione, ripristinare la disposizione originale del frame.

Zoom to Actual Size
Il comando Zoom to Actual Size permette di visualizzare un layout sulla schermo
utilizzando le dimensioni che verranno utilizzate sulla carta. Questo comando risulta



114 di 213

essere molto utile ed è necessario utilizzarlo prima di andare in stampa per verificare le
dimensioni relative degli oggetti presenti nella mappa. Spesso la dimensione di stampa è
maggiore di quella dello schermo per questo motivo, utilizzeremo il comando Pan per
muoverci all’interno del documento.

1. Selezionare View > Zoom > to Actual Size.

Il contenuto della mappa è disegnato utilizzando le dimensioni di stampa sulla
schermo.

2. Salvare il GeoWorkspace.

Esportare il Layout in un formato Raster
Il comando Export Layout permette di esportare il risultato dell’impaginazione utilizzando
numerosi formati: GeoMedia Layout Template (*.glt), GeoMedia Layout Sheet (*.gls),
bitmap (*.bmp), JPEG (*.jpg), and TIFF (*.tif). nel seguito utilizzeremo il formato JPG.

1. Selezionare Sheets > Export Layout.

2. Nel campo Save as type sceglier JPEG File Interchange Format (*.jpg).

3. Accertarsi che la cartella Learning sia selezionata nel campo Save in.

4. Digitare FinalPlot nel campo File name.

5. Premere il pulsante Save.

6. Premere il pulsante OK nella finestra di dialogo JPEG Export Options utilizzando
la risoluzione 300 dei, e la JPEG Quality Factor predefinita.

E’ ora possibile FinalPlot.jpg visualizzare il file creato all’interno della cartella Learning. Il
file può essere aperto con un qualunque programma per la visualizzazione di immagini.

Stampare la Finestra di Layout
Il comando File > Print permette di stampare il contenuto della finestra di layout. Quando
una map window o una finestra dati è attiva, questo comando consente di stampare
attivando o disattivando le opzioni che più incontrano le nostre esigenze.

1. Con la finestra di layout attiva, selezionare File > Print.

La finestra di dialogo Print Layout Window viene visualizzata.

2. Selezionare Selected Sheet nel Print Range.

3. Impostare il campo Number of copies ad 1.

4. Nel caso in cui si abbia bisogno di modificare le opzioni di stampa, si utilizzi il
pulsante Properties. Dopo aver fatto i cambiamenti opportuni, premere il pulsante OK
to per tornare alla finestra di dialogo Print Layout Window.

5. Premere il pulsante OK nella finestra di dialogo Print Layout Window.

Il foglio selezionato nella layout window, è stato stampato.

6. Salvare il GeoWorkspace.



115 di 213

Congratualazioni! Avete completato il capitolo Creare una Versione Stampabile dei
Risultati: potete ora continuare i tutorials di GeoMedia scegliendo quello più appropriato
utilizzando l’apposito indice dei contenuti.
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4 - Batch Plotting
In questa sessione verrà utilizzata l’utilità di Batch Plotting Select con lo scopo di produrre
alcuni layout provenienti da differenti Geoworkspaces, mentre attraverso l’utilizzo della
procedura di Compose sarà possibile generare delle mappe utilizzando i layout prodotti.

Prima di Cominciare
Prima di iniziare il flusso di Batch Plotting, effettuare le seguenti operazioni:

1. Se la sezione precedente è stata completata, utilizzando il file learn.gws in modo
che learn.gws e learn.mdb sono già stati salvati, allora verrano utilizzati questi files nel
primo esercizio. Si proceda con il punto 4.

- OPPURE -

1. Se invece non si è completato l’esercizio precedente, si copi il file
learn_afterplot.gws nella cartella GeoWorkspaces come learn.gws, si copi inoltre il file
learn_afterplot.mdb nella cartella Warehouses come learn.mdb, è raccomandabile
creare copie di back up dei files learn.gws e learn.mdb, utilizzando nomi differenti.
Questi files verrano utilizzati nel primo esercizio.

2. Se i files USSampleData.mdb e learn.mdb sono in cartelle differenti da
C:\Warehouses, avviare GeoMedia Professional, se non già attivo, e aprire il file
learn.gws. Quando viene visualizzato il messaggio: "An error occurred while attempting
to open connection '<connection name>'. Verify that your connection parameters are
correct and try again", si navighino le cartelle fino a puntare i files corretti, per tutti i files
.mdb, poi chiudere cliccando OK.

3. Se avete installato GeoMedia Professional in una cartella differente da C:\Program
files\GeoMedia Professional, quando verrà aperto il file learn.gws verrà visualizzato il
seguente messaggio: "An error was encountered loading data for Usable Area Labels
legend entry. Do you want to continue loading remaining legend entries?". Per risolvere
questo errore, bisogna prima premere il pulsante Yes per ogni elemento di legenda
che presenta questo errore, poi selezionare Window > Final Counties. Selezionare
Warehouse > Feature Class Definition. Selezionare Restricted_Sites dalla
connessione learn e premere il pulsante Edit. Nel campo Data source indicare la
collocazione della cartella Learning, dopo il simbolo di uguale. Premere il pulsante OK,
e poi Close. Fare doppio click sulla chiave di stile dell’elemento di legenda Leader
Terminators e scegliere Properties. Selezionare il file terminator.fsm. Dal menù a
tendina Name scegliere Terminator 4, con il valore di Size impostato a 10.000,
spuntare l’opzione Define override color e scegliere il colore nero. Scegliere OK per
tutte le finestre di dialogo. Fare doppio click sulla chiave di stile della voce di legenda
Major Cities e scegliere Properties. Selezionare il file di simbologia
transportation.fsm. Dal menù Name scegliere il simbolo City Symbol #4, in modo che
l’attributo Size valga 10.000, assicurarsi inoltre che il Define override color non sia
spuntato, poi Premere il pulsante OK per tutte le finestre di dialogo. Scegliere Window
> Layout Window.

4. Si copi il file BatchPlotting.gws nella cartella GeoWorkspaces utilizzando il nome
“Batch_wk.gws”, è inoltre raccomandabile creare una copia di back up del file
Batch_wk.gws, se questo esiste già, utilizzando un nome differente. Questo file sarà
utilizzato nel primo esercizio.
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5. Se i files BatchPlotting.mdb e MadisonCountyAL.mdb sono localizzabili nella
cartella C:\Warehouses, passare al punto successivo. Se i files si trovano invece in una
cartella differente da C:\Warehouses, aprire il file BatchPlotting.gws con GeoMedia
Professional. All’apparire del messaggio: "An error occurred while attempting to open
connection '<connection name>'. Verify that your connection parameters are correct
and try again", utilizzare il pulsante Browse, con lo scopo di localizzare tutti i files di
tipo .mdb e rendere attive le connessioni, in ultimo scegliere OK.

6. Se GeoMedia Professional è stato installato in C:\Program files\GeoMedia
Professional, recarsi al punto successivo. Se invece GeoMedia Professional è stato
installato in una cartella differente da C:\Program files\GeoMedia Professional, quando
verrà eseguito il file BatchPlotting.gws, si avranno tre simboli visualizzati non
correttamente. Con lo scopo di correggere questi errori, si selezioni Window >
Madison County Alabama. Si faccia doppio click sulla chiave di stile dell’elemento di
legenda Church, si scelga Properties. Utilizzando il pulsante Browse è possibile
caricare il file di simbologia BaseMap.fsm. Dal menù Name scegliere Church - light,
con l’attributo Size impostato sul valore 10.000, poi premere il pulsante OK. Si faccia
doppio click sulla chiave di stile dell’elemento di legenda Cemetery si scelga
Properties, e si navighi utilizzando il comando Browse il file di simbologia
BaseMap.fsm. Dal menù Name scegliere Cemetery, con l’attributo Size impostato sul
valore 10.000, poi premere il pulsante OK. Si faccia doppio click sulla chiave di stile
dell’elemento di legenda School, si scelga Properties, e si navighi utilizzando il
comando Browse il file di simbologia BaseMap.fsm. Dal menù Name scegliere School
- light, con l’attributo Size impostato sul valore 10.000, poi premere il pulsante OK.

7. Chiudere GeoMedia Professional avendo cura di salvare i cambiamenti effettuati.

Creazione di File di Batch Plotting (.gbp) e Utilizzo del Workflow di tipo
“Select
In questo esercizio, verrà creato un file .gbp cioè un file GeoMedia Batch Plotting, che
serve a memorizzare le informazioni necessarie a generare fogli di layout da differenti
Geoworspaces con una procedura di tipo batch.

1. Selezionare Start > All Programs > GeoMedia Professional > Utilities > Batch
Plotting.

Per scoprire come affiancare verticalmente la finestra del tutorial e quella del programma,
riferirsi a Come Porre le Finestre (Sezione 1-1).

1. Premere il pulsante Add.

2. Localizzare il file learn.gws e premere il pulsante Open.

Tutti i fogli di layout contenuti in learn.gws (in questo caso, è presente solo un layout), si
rendono disponibili nel campo Available sheets by GeoWorkspace.

3. Premere il pulsante Add.

4. Localizzare anche il file Batch_wk.gws, che si trova nella cartella GeoWorkspaces e
scegliere Open.

5. Tutti i fogli di layout contenuti in Batch_wk.gws si rendono disponibili nel campo
Available sheets by GeoWorkspace.

Questo Geoworkspace contiene alcuni esempi.
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E’ possibile selezionare i fogli che si vogliono utilizzare, si proceda con il selezionare tutti i
fogli da entrambe le sorgenti

6. Premere il pulsante contraddistinto da una doppia freccia che punta verso il basso.

Tutti i fogli che provengono da entrambe le sorgenti sono così visualizzati nel campo
Selected sheets by GeoWorkspace.

7. Selezionare File > Save.

8. Nel campo Save in selezionare la cartella Learning.

9. Utilizzare l’opzione Save as type per scegliere il tipo di dato GeoMedia Batch
Plotting File (*.gbp), poi digitare Learning_Select, quale nome per il file.

10. Premere il pulsante Save.

Il file di batch plotting è così salvato come Learning_Select.gbp.

Se si vorrà stampare questo file più tardi, sarà possibile selezionare nuovamente l’opzione
di Batch Plotting dal menù delle Utility e premere il pulsante ancora su File > Open.

11. Se si vuole invece stampare il file subito, scegliere File > Print.

Tutti i fogli appartenenti alle fonti sono così stampati.

Nota: E’ anche possibile aggiungere e stampare tipi di files .gls utilizzando la procedura
Select.

12. Scegliere File > Exit per uscire dal Batch Plotting utility.

Preparare un Batch Plotting Composition attraverso il flusso Compose
I files di tipo Compose Batch Plotting, possono servire ad immagazzinare informazioni
necessarie a comporre un nuovo foglio di layout. Verrà utilizzato un template, con lo scopo
di generare una mappa di base (Base Map) ed una mappa di overview (Overview Map),
che comprenderanno quattro aree appartenenti alla regione Madison County, nello stato di
Alabama. Si avranno così quattro mappe. Ognuna di esse sarà formata da una area di
dettaglio, e da una mappa di overview, che serve a mettere in relazione la mappa di
dettaglio con la regione a cui appartiene.

Ad esempio, due delle quattro mappe, avranno un aspetto simile alle figure qui sotto.
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La mappa di base occupa il frame più grande, mentre il frame più piccolo nell’angolo in
alto a destra, è occupato dalla mappa di overview.

Con lo scopo di generare una composizione di tipo batch plotting, si richiedono i seguenti
elementi:

 La Map Extent per ogni mappa che deve essere disegnata, cioè l’estensione
geografica di ogni foglio: in questo caso servono le map extent per la mappa di
base e per la mappa di overview. Le map extent possono essere rappresentate da
una feature areale (o compound) o da una query di una feature areale (o
compound). Si possono definire attraverso GeoMedia Professional oppure
utilizzando l’opzione di Batch Plotting. In questo esercizio le map extent sono state
definite come query di GeoMedia Professional.

 Il contenuto e la simbologia di ogni mappa che si è interessati a stampare, sono
definiti dalle legende contenute all’interno del Geoworspace.

 Il file di tipo Template (.glt) contiene il posizionamento dei frame che vengono
utilizzati, quando infatti si è in presenza di più di un frame, sarà necessario
associare al frame un attributo, tramite il quale si potrà richiamare il frame all’interno
dell’Utility di Batch Plotting.

 Se si è scelto di utilizzare un Cartographic Grid (reticolo cartografico), sarà
necessario creare un cartographic grid definition file che verrà specificato nel Batch
Plotting Utility.

I passi seguenti mostrano, a titolo di esempio, come creare una composizione di tipo
Batch Plotting che contengano una mappa di base ed una mappa di overview.

Definizione del Map Extents
1. Lanciare GeoMedia Professional, ed aprire il GeoWorkspace Batch_wk.gws.

There are two windows: the map window that is called Madison County Alabama and the
layout window.

In questo Geoworkspace ci sono due finestre: una map window il cui nome è Madison
County Alabama, ed una layout window.

2. Portare la map window in primo piano selezionando: Window > Madison County
Alabama.
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Nota: Se GeoMedia Professional sembra non rispondere ai comandi assicurarsi che la
finestra attiva sia GeoMedia Professional e non la finestra di tutorial.

3. Ingrandire la finestra di map window.

4. Se la legenda è ancorata al lato destro o sinistra della map window, è possibile
sganciarla facendo click destro sul map window e selezionando il comando Position
Legend > Floating.

IMPORTANTE: Per cambiare la posizione della legenda, è sempre possibile fare click con
il pulsante destro, all’interno del map window o data window.

La legenda è ora mobile, e possiede una barra di titolo.

5. Per visualizzare il contenuto di questa finestra selezionare View > Fit All.

Una mappa della Madison County, Stato di Alabama, è ora visualizzata nella map window.

Si possono osservare le map extent che servono a definire le zone della regione che si
andranno a plottare.

6. Selezionare Legend > Add Legend Entries, selezionare la Feature Class
MapSheet della connessione BatchPlotting e premere il pulsante OK.

Si può ora visualizzare l’intera area suddivisa in trenta quadranti, che corrispondono a
trenta fogli di mappa.
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Questi fogli di mappa, definiscono le mappe di base che verrano disegnate. E’ possibile
tanto stamparle tutte quanto creare una query contente il subset utile alla stampa. In
questo esercizio, solo quattro quadranti saranno selezionati per la stampa finale.

7. Spegnere ora l’elemento di legenda MapSheet, cliccando con il destro e scegliendo
il comando Display Off.

8. Selezionare Analysis > Queries.

9. Selezionare la query Subset of MapSheet, poi premere il pulsante Properties.

10. Notare che l’interrogazione che verrà utilizzata, è basata sull’attributo Title. Se
l’attributo Title è uguale ad uno dei quattro valori scelti: Capshaw, Greenfield,
Huntsville South, or New Market, il foglio sarà utilizzato dalla feature class MapSheet.

Nota: Siccome l’attributo Title identifica le aree che sono state scelte, questo attributo
sarà utilizzato più avanti dalla utilità di batch Plotting per richiamare i fogli che saranno
esportati o stampati. Come si potrà notare, sia l’attributo Title che l’attributo Number (cioè
il numero che identifica il foglio) sono le variabili di sistema utilizzate e si potrà scegliere di
far apparire il loro valore su ognuno dei fogli.

11. Premere il pulsante ora il pulsante Cancel della finestra di dialogo Query
Properties.

12. Mantenendo selezionato Subset of MapSheet selezionare Display, per
visualizzare la query nella map window (con questo scopo, togliere la spunta al data
window setting e premere il pulsante OK.

Ora le quattro mappe possono essere visualizzate.
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13. Premere il pulsante Close sulla finestra di dialogo Queries.

14. Fare doppio click su uno o due degli elementi delle feature class Subset of
MapSheet, facendo attenzione agli attributi Title e Number.

15. Si rendano invisibili i fogli di mappa facendo click destro su Subset of MapSheet e
selezionando Display Off.

16. Selezionare Analysis > Queries.

17. Selezionare la query Overview of Map Extent, premere il pulsante Properties, e
ancora Properties.

Questo oggetto definisce il contorno della mappa di overview, ed è l’unione dei trenta
quadranti che compongono la Feature MapSheet.

18. Premere il pulsante Cancel fino a quando si ritorna alla finestra di dialogo Queries.

19. Mantenendo selezionata la query Overview of Map Extent selezionare Display,
per visualizzare la query nel map window (togliere la spunta all’opzione di
visualizzazione della data window), poi Premere il pulsante OK.

Il confine rettangolare della regione, appare nella map window.
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20. Premere il pulsante Close nella finestra di dialogo Queries.

21. Rendere invisibile la feature class Overview of Map Extent utilizzando il comando
Display Off che appare facendo click destro sull’elemento di legenda.

Definire il Contenuto e la Simbologia
Sarà ora possibile richiamare le legende e le feature in esse contenute, così come la
simbologia scelta sia per le mappe di base che per le mappe di overview.

1. Selezionare Legend > Legends.

La lista delle legende disponibili compare ora a schermo.

2. Premere il pulsante Close nella finestra di dialogo Legends.

Si possono osservare le legende ed i loro nomi.

3. Aprire una nuova map window selezionando Window > New Map Window,
scegliere Base Map nel campo Select legend to display.

4. Premere il pulsante OK.

La legenda contenente gli elementi della mappa di base è ora visualizzata a schermo.
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Nota Bene: Se GeoMedia Professional è stato installato in una cartella differente da
C:\Program files\GeoMedia Professional, allora tre simboli non saranno visualizzati
correttamente nella legenda di Base Map. Per risolvere questo problema, seguire i
seguenti passi:

 Ripetere il passo 6 della sezione Prima di Cominciare in modo da visualizzare la
simbologia di legenda.

 Selezionare Legend > Named Legend.

 Scegliere Base Map dalla lista di drop-down del campo Name e premere il pulsante
OK.

 Verrà visualizzato il messaggio: "Do you want to replace the existing Base Map?",
scegliere Yes.

5. Aprire una nuova Map Window utilizzando il commando Window > New Map
Window, scegliere Overview Map nel campo Select legend to display.

6. Premere il pulsante OK.

Si può ora visualizzare la legenda della mappa di overview.
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Come si può osservare, la mappa di overview contiene strade, i confini delle regioni e i
quadrangoli che delimitano le aree della regione.

7. Selezionare Window > Cascade per poter vedere le finestre disponibili, poi
chiudere le due nuove map window che sono state aperte.

8. Premere il pulsante Yes per confermare la chiusura delle finestre.

9. Tornare alla map window Madison County Alabama.

10. Ingrandire questa finestra.

11. Selezionare View > Fit All per vedere l’intero contenuto di questa map window

12. Se si vogliono visualizzare North Arrow e la Scale Bar è possibile attivarle
attraverso il menù View.

13. Fare click destro sulla north arrow e selezionare Properties.

14. Nella finestra di dialogo North Arrow Properties, è possibile scegliere una tra le
north arrows predefinite, e scegliere Save as Default.

E’ possibile, posizionare anche più di una north arrow per ogni map window, ma la quella
che verrà utilizzata durante la procedura di Batch Plotting, sarà quella impostata come
default.

15. Premere il pulsante OK nella finestra di dialogo North Arrow Properties.

16. Premere il pulsante con il destro sulla barra di scala e scegliere Properties.

17. Nella finestra di dialogo Scale Bar Properties, specificare il tipo di barra di scala
che si vuole utilizzare (è possibile utilizzare il commando Preview per pre-visualizzare
il risultato finale), utilizzando la scheda Style, sarà possibile invece modificare gli altri
settaggi di stile.

E’ possibile posizionare più di una barra di scala, a seconda delle esigenze, ma la
procedura di Batch Plotting utilizzerà la barra di scala che è stata scelta come default.

18. Premere il pulsante OK nella finestra di dialogo Scale Bar Properties.
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Creare un Template
1. Rendere attiva la finestra di layout, selezionando Window > Show Layout

Window.

La finestra di layout è ora attiva e mostra i fogli di map window presenti nel progetto.

Nota: Se si sta lavorando mantendo la finestra di Tutorial e GeoMedia Professional
contemporaneamente a schermo come suggerito inizialmente, è importante accertarsi che
GeoMedia sia la finestra attiva, prima di fare qualunque operazione nella finestra di layout.

2. Ingrandire la finestra di layout.

Verrà ora utilizzato il template che è stato creato precedentemente.

3. Si selezioni Sheets > Import Layout.

La finestra di dialogo Import Layout è ora visualizzata a schermo.

4. Dalla lista di drop-down Files of type accertarsi che il tipo di dato selezionato sia
GeoMedia Layout Templates (*.glt).

5. Scegliere il file BatchComposition.glt dalla cartella GeoMedia
Professional\Templates\Layouts.

6. Premere il pulsante Open.

Il template è stato ora aperto ed è pronto all’uso.

7. Selezionare View > Fit.

Si può notare che questo template contiene due frames: quello più grande verrà utilizzato
come base map nella fase di Batch Plotting, mentre quello più piccolo sarà utilizzato come
mappa di overview. Come si potrà notare procedendo con i passi seguenti, a questi
frames sono stati dati nomi specifici in modo che, utilizzando la Batch Plotting Utility, sarà
possibile distinguere i frames all’interno del file di progetto.

Nota: Se il template fosse stato composto da un frame solo, non ci sarebbe stato bisogno
di specificare un nome per poterlo identificare.

8. Selezionare il frame più piccolo, cliccandoci sopra.
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9. Ora fare click destro e scegliere Properties.

10. Appare ora la finestra di dialogo Group Properties, e come si può notare il nome
del Map Frame: Map frame name è “SmallMapFrame” ed è contenuto nel gruppo di
Batch Plotting

11. Premere il pulsante Cancel nella finestra di dialogo Group Properties.

12. Premere il pulsante sinistro del mouse sul frame più grande in modo da selezionare
l’intero gruppo (il frame di mappa, la north arrow, la barra di scala e la legenda).

13. Fare click destro all’interno del frame di mappa più grande, e scegliere Properties.

14. Viene visualizzata la finestra di dialogo Group Properties, e come si può notare, il
nome del frame di mappa Map frame name, è LargeMapFrame, all’interno del gruppo
di Batch Plotting

15. Premere il pulsante Cancel nella finestra di dialogo Group Properties.

16. Come si può notare tutto il testo che è contenuto tra parentesi quadre [], sarà
automaticamente popolato durante la fase di Batch Plotting.
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Le variabili di sistema [GM-Date], [GM-Scale], [GM-Projection], e [GM-ZoneName]
identificano, data, scala di plottaggio, proiezione e nome della zona rispettivamente.

Gli attributi [Title] e [Number] sono invece riferiti ai quadrangoli, ad esempio, il nome di uno
di questi quadranti è Huntsville South, un altro è Greenfield, i nomi indicano quale parte
della regione è racchiusa dal quadrante. Allo stesso modo il numero è un attributo
univoco, che serve ad identificare una zona piuttosto che un altra. Si può ad esempio
costruire una query che abbia in output alcuni quadranti i cui numeri identificativi siano 12,
13, 18, e 28.

17. Salvare il Geoworkspace.

18. Uscire da GeoMedia Professional

Creare un Batch Plot
E’ giunto il momento di creare un composizione attraverso la Batch Plotting Utility.

1. Lanciare la Batch Plotting Utility: Start > All Programs > GeoMedia Professional
> Utilities > Batch Plotting.

2. Scegliere ora File > New Sheet Composition.

Ora la finestra di dialogo Sheet Composition è visualizzata.

3. Nella scheda General selezionare il pulsante Browse ed aprire il Batch_wk.gws.

Come Layout template selezionare ed aprire, utilizzando il pulsante Browse il file
BatchComposition.glt dalla cartella GeoMedia Professional\Templates\Layouts.

4. Notare che, quando viene selezionato un elemento dai Map frames, il frame viene
evidenziato nella finestra di Template Preview.

Sarà necessario ora specificare all’interno dell’Utility quale frame si vorrà utilizzare come
mappa di overview, e quale frame si vorrà utilizzare come base map.

5. Nella sezione Map frames, premere il pulsante il campo Map type alla riga che
contiene LargeMapFrame, e scegliere Base Map dalla lista di pull-down Map type.

6. Notare che la mappa di base è descritta dal grafico Map type sulla destra del
campo.

7. Sempre sotto il menù di Map frames, premere il pulsante la riga che contiene
SmallMapFrame del campo Map type, e selezionare Overview Map dalla lista di Map
type.

8. Notare che la mappa di overview è descritta nel grafico Map type alla destra del
campo.

E’ interessante notare che ci sono altre due schede in questa finestra di dialogo, una per
ognuna dei frame che devono essere posizionati.

9. Selezionare la scheda LargeMapFrame.

10. Nella scheda LargeMapFrame, definire la map extent scegliendo la query Subset
of MapSheet.

Nota: Alternativamente, è possibile utilizzare il bottone Filter per definire una query
utilizzando l’Utility di Batch Plotting invece GeoMedia Professional (come è stato fatto in
questo esercizio).
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11. Specificare l’attributo Title all’interno del campo Select attribute to be used for
file name or sheet name.

12. Scegliere la legenda di Base Map per definire il contenuto della mappa.

13. Definire ora la scala di plottaggio: selezionare User-defined e scrivere la scala di
63,360 (cioè 1 pollice = 1 miglio).

14. Spuntare l’opzione Place cartographic grid e premere il pulsante Browse per
caricare BatchPlottingGrid.xml dalla cartella Learning.

15. Selezionare la scheda SmallMapFrame.

16. Nella scheda SmallMapFrame è opportuno definire la map extent che utilizzeremo
come overview (cioè i confini di Madison County, AL) selezionando la query Overview
of Map Extent.

17. Definire il contenuto della mappa scegliendo la legenda di Overview Map.

18. Premere il pulsante Style.

Notare che è stato scelto un riempimento di tipo grigio pieno. E’ naturalmente possibile
cambiare lo stile se si desidera, confermare la scelta con il pulsante OK.

Fruire dei Risultati della Composizione
Vedremo ora i risultati del Batch Plotting.

1. Salvare il file: File > Save.

2. Nel campo Save in scegliere la cartella Learning.

Scegliere GeoMedia Batch Plotting File (*.gbp) nel campo Save as type settato su e
digitare Learning_Compose come nome.

3. Premere il pulsante Save.

Ora il file di Batch Plotting è salvato come Learning_Compose.gbp.

4. Se si desidera stampare questo file più avanti, sarà possibile richiamarlo tramite la
Batch Plotting Utility, scegliendo File > Open.

5. Selezionare File > Export e scegliere la cartella Learning.

6. Premere il pulsante OK.

7. Nella finestra di dialogo Export Options, scegliere JPEG File Interchange Format
(*.jpg) come tipo di file utilizzando il campo Export as type.

8. Impostare la risoluzione a 300 dpi e premere il pulsante OK.

9. Scegliere File > Exit, una volta che il file è stato creato.

Visualizzare ora i risultati. I file di output, si chiamano <GeoWorkspace_Unique sheet
attribute name> (come Batch_wk_Greenfield.jpg), e sono stati create nella cartella
Learning.

Si possono stampare i files utilizzando la Batch Plotting Utility, o da linea di comando con
lo scopo di mandare i files in stampa. A questo scopo riferirsi alla sezione dell’Help in linea
Batch Plotting.
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Congratulazioni! Avete completato il tutorial di Batch Plotting. Potete ora continuare i
tutorials di GeoMedia Professional scegliendo quello più appropriato utilizzando l’apposito
indice dei contenuti.
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5 - Utilizzare i Cataloghi Geospaziali
Un Catalogo Geospaziale è un database che viene utilizzato per memorizzare metadati. Il
metadato consiste di informazioni che riguardano il dato. Un Metadato Spaziale è un tipo
di dato che descrive il contenuto, la qualità, lo stato, o altre informazioni su i dati spaziali
come ad esempio, quando e chi lo ha creato, con quali intenzioni, o altre informazioni che
possano chiarirne la funzione, la storia e la disponibilità.

Dopo aver completato questa sessione, sarete in grado di connettervi a Cataloghi
Geospaziali, interrogare i metadati, e creare connessioni di tipo GDO (quando il dato è già
associato ad una feature class) utilizzando GeoMedia Professional. In questa sessione,
visualizzeremo i metadati per gli stati e le regioni di Minnesota e Wisconsin.

Prima di Cominciare
Prima di cominciare questa sessione, si seguano i seguenti passi:

1. Se avete completato l’esercitazione “Creare una Versione Stampabile dei Risultati”
utilizzando learn.gws (di modo che sia learn.gws che learn.mdb siano già stati salvati a
questo punto), lanciate GeoMedia Professional, ed aprite il file learn.gws (Non fa
differenza se avete già completato la sessione 4). Passare al punto 4.

– OPPURE –

1. Se non avete ancora completato l’esercitazione “Creare una Versione Stampabile
dei Risultati” copiate il file “Learn Afterplot.mdb” nella cartella Warehouses e
rinominatelo “learn.mdb” (è infatti raccomandabile fare una copia di archivio dei file
learn.gws e learn.mdb con nomi differenti). E’ poi possibile eseguire il file learn.gws di
GeoMedia Professional.

2. Se i files “USSampleData.mdb” e “learn.mdb” sono archiviati in cartelle differenti da
C:\Warehouses, si avrà un messaggio di errore: “An error occurred while attempting to
open connection '<connection name>'.” quando si cercherà di aprire “learn.gws”, per
rimediare a questo problema è necessario localizzare ogni files tramite il pulsante
“Browse”, e di seguito confermare cliccando su OK.

3. Se GeoMedia Professional è stato installato in cartelle differenti da C:\Program
Files\GeoMedia Professional, quando verrà lanciato il file “learn.gws”, si avrà un
messaggio di errore: "An error was encountered loading data for Usable Area Labels
legend entry. Do you want to continue loading remaining legend entries?" Per
rimediare a questo errore, ciccate su SI per questo e ogni altro messaggio simile. Si
scelga poi Window > Final Counties. Selezionare di seguito Warehouse > Feature
Class Definition. E ancora: Restricted_Sites dalla connessione learn, poi premere il
pulsante Edit. Nel campo Data source, potete digitare il percorso, della cartella
“Learning” (subito dopo il simbolo di uguale). Scegliete prima OK e poi Close.. Fate
ora doppio click sulla icona di stile per la voce di legenda, “Major Cities” e scegliete
Properties, navigate e selezionate il file “transportation.fsm”. Dal menù a tendina
“Name” scegliete “City Symbol #4” e la dimensione 10.000, assicurasi inoltre che
l’opzione “Define override color” non sia stata spuntata, e confermate cliccando su
OK per tutte le finestre di dialogo successive.
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4. Per assicurarsi che la finestra “Final Counties”, sia la finestra attiva, scegliete dal
menù Window > Final Counties.

Attenzione: Se GeoMedia Professional sembra non rispondere ai comandi assicurarsi
che la finestra attiva sia GeoMedia Professional e non la finestra di tutorial.

Creare le Interrogazioni di Attributo per le Regioni degli Stati Winsconsin e
Minnesota
Andremo a creare due interrogazioni per la feature class “Counties”, della connessione
“Connection to US Data”. Successivamente sarà possibile creare delle feature class a
partire da queste interrogazioni.

1. Selezionate Analysis > Attribute Query.

La finestra di dialogo delle Attribute Query è così visualizzata.

2. Nel campo Select features in aprite la connessione “Connection to US Data” e
selezionate la feature class “Counties”

3. Cliccare su Filter.

4. Nella finestra di dialogo Counties Filter scegliete l’attributo “STATE_NAME”

5. Scegliere L’operatore =.

6. Scegliere Show Values.

7. Scegliere Yes al messaggio e selezionare Wisconsin

La stringa “STATE_NAME = 'Wisconsin'” è correttamente visualizzata nel campo Filtro.

8. Scegliere OK nella finestra di dialogo “Counties Filter”.

9. Digitare “WisconsinCounties” come nome della interrogazione.

10. Togliere la spunta per l’opzione che permette di visualizzare l’ interrogazione nella
map window e data window.

11. L’interrogazione non verrà visualizzata nella finestra di mappa ne nella finestra di
dati

12. Scegliete OK.

L’interrogazione è stata creata, ma non viene aggiunta alla legenda, perché si è scelto di
non visualizzarla né nella finestra di mappa né nella finestra di dati.

13. Si segua nuovamente la procedura come sopra con lo scopo di creare un
interrogazione chiamata Minnesota selezionando Minnesota nella finestra di dialogo
CountiesFilter.

Esportare le Interrogazioni a Feature Class
Le quattro interrogazioni create, verrano utilizzate per creare quattro feature class
all’interno del warehouse learn.mdb.

1. Scegliere Warehouse > Output to Feature Class
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2. Nella scheda General assicurasi che Queries sia all’interno del campo Source
connections and queries.

3. Sceliere Learn come Target Connection.

4. Spuntare Minnesota, MinnesotaCounties, Wisconsin, and WisconsinCounties
interrogazioni di Attributo nel campo “Queries”

5. Assicurarsi che “Display target feature classes in map window” non sia
spuntata.

E’ preferibile che le feature class che sono state create, non vengano visualizzate nella
finestra di mappa.

6. Scegliere OK.

7. Scegliere Yes quando verrà chiesta conferma prima di creare le quattro feature
class.

8. Scegliere OK quando il messaggio di completamento dell’output viene visualizzato.

Creare un Catalogo
Il comando New Catalog permette di creare un nuovo catalogo a partire da un

modello.

1. Scegliete Tools > Catalogs > New Catalog.

2. Nel campo Look in, scegliete la cartella Templates\Catalogs, nella cartella
“GeoMedia Professional”, ad esempio: C:\Program files\GeoMedia
Professional\Templates\Catalogs.

3. Scegliete il file CatalogTempletate.mdb e scegliete Open.

La finestra di dialogo New Catalog è visualizzata.

4. Accertarsi che il tipo di dato scelto sia Access Database (*.mdb)

5. Nel campo nome, digitare LearningCatalog e scegliere Save.

Il nuovo database di catalogo, verrà posizionato nella cartella Warehouses\Catalogs.

6. Ogni volta che un nuovo catalogo viene creato, una connessione di catalogo viene
creata all’interno del Geoworkspace automaticamente.

7. Selezionare Tools > Catalogs > Catalog Connections.

8. Cliccare sul primo elemento di riga per la connessione LearningCatalog.

9. Notare che i bottoni sul lato destro della finestra di dialogo, vengono accesi al
momento appropriato, ad esempio il comando Close Connection è disponibile solo
quando esiste già una connessione, oppure Open Connection, è disponibile quando
la connessione esiste ma non è stata ancora aperta.

10. Scegliere Close per chiudere la finestra di dialogo delle Catalog Connections.
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Importare un Template Catalog Record
In questa fase, verrà creato un nuovo catalogo per la feature class generata
precedentemente. Nel menù di dialogo “Import Catalog Records” sarà importato un
nuovo modello di catalogo. Più avanti nella procedura, il modello verrà utilizzato per creare
nuovi cataloghi. L’utilizzo di un modello permette di creare un catalogo utilizzando una
forma standard che può essere utilizzata come punto di partenza senza dover introdurre
tutte le informazioni manualmente ogni volta che si ha la necessità di creare un catalogo.

1. Selezionare Tools > Catalogs > Import Catalog Records

2. Individuare e localizzare la cartella Learning, ad esempio: C:\Program
files\GeoMedia Professional\Learning.

3. Selezionare il file TemplateCountyBoundary2000.gce che appare nella lista del
campo Available files.

4. Assicurarsi che LearningCatalog sia il catalogo di destinazione Target catalog.

5. Premere il pulsante Apply.

Il messaggio che l’import è stato correttamente terminato viene visualizzato sullo schermo.

6. Una volta chiusa la finestra di messaggio appare la finestra di dialogo Import
Catalog Records.

Utilizzando l’Explorer di Windows, navigare la cartella Learning e localizzare i due files di
LOG: ImportCatalogRecords.log e TemplateCountyBoundary2000.log.

Il file principale, ImportCatalogRecords.log, contiene la lista di tutti i files importati
nell’operazione. Inoltre viene creato un file di log per ogni catalogo importato, in questo
caso, è possibile individuare il file TemplateCountyBoundary2000.log

Aprire entrambi i files e leggerne il contenuto in modo da verificare che la fase di import sia
andata a buon fine, verificare ad esempio che non esistano componenti che non sono
state importate a causa di problemi di contenuto.

Associare Catalog Records
Sarà possibile ora creare un nuovo catalogo per la feature class che è stata creata.

1. All’interno di GeoMedia Professional, selezionare Tools > Catalogs > Associate
Catalog Records

2. Premere il pulsante il bottone New Catalog Record

3. Appare la finestra di dialogo New Catalog Record.

Utilizzando il modello che è stato importato, verrà creato un nuovo record che servirà a
popolare le informazioni di base del catalogo.

Avremo bisogno di creare quattro nuovi cataloghi, uno per ognuna delle due feature class
che rappresentano le regioni ed uno per ognuna delle feature class che individuano gli
Stati.

4. Nel campo Title, digitare: Counties of Minnesota.
5. Accendere l’opzione Create from spuntando la check box.
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6. Dalla lista di Catalog record, selezionare il record importato precedentemente:
Template County Boundary 2000

7. Mantenere la spunta per ogni Sections to include.

8. Scegliere OK.

Ripetere i passi precedenti ripartendo dal passo 2 in modo da creare un nuovo record per
la feature class. Nel passo 3 digitare Counties of Wisconsin.

Ripetere i passi dal 2 al 7, utilizzando State of Minnesota come Title, avendo cura
questa volta di togliere la spunta all’opzione Create from, premere il pulsante poi su OK.

Ripetere nuovamente i passi dal 2 al 7 digitando State of Wisconsin nella finestra del
titolo e lasciando stavolta accesa la spunta Create from, premere il pulsante OK.

La finestra di dialogo Associate Catalog Records, permette ora di visualizzare i quattro
nuovi record creati nel LearningCatalog nel campo Available catalog records

Ora è possibile associare ogni catalog record alla feature class corrispondente.

9. Selezionare Counties of Minnesota all’interno del campo Available catalog
records.

Notare che nella porzione della finestra di dialogo Dataset associations, la maggior parte
dei campi sono stati abilitati. Queste opzioni si applicano solamente quando un singolo
record è stato selezionato.

Ora bisognerà associare la feature class MinnesotaCounties al catalog record Counties of
Minnesota

10. Assicurarsi che il Layer in primo piano sia selezionato.

11. Premere il pulsante Associate Feature Class.

12. Aprire la connessione “Learn” e selezionare la feature class MinnesotaCounties

13. Premere il pulsante OK.

14. Selezionare Background layer.

15. Premere il pulsante il bottone Associate Feature Class.

16. Aprire la connessione “Learn” e selezionare la feature class Minnesota

17. Premere il pulsante OK.

18. Notare che il record catalog che è stato associate ad una feature class ha una
icona differente; infatti l’icona con il mondo sta a rappresentare il fatto che il record di
catalogo è stato associato ad una feature class.

19. Premere il pulsante View Details.

Viene visualizzato un file HTML del catalog record.

20. Questo file contiene riferimenti solamente a due sezioni: Identification Information e
Data Quality Information, che sono state popolate utilizzando il modello di catalog
record.

21. Chiudere il file HTML.
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22. Nel porzione della finestra di dialogo Dataset associations, scegliere il layer in
primo piano.

23. Premere il pulsante Capture.

La feature class è stata così catturata, e posizionata nel catalogo.

24. Cliccare su OK, al messaggio che viene visualizzato.

25. Fare click su View Details.

26. Ci sono ora quattro sezioni, le nuove sezioni sono intitolate Spatial Data
Organization Information e Entity and Attribute Information. Le informazioni per queste
nuove sezioni sono state aggiunte automaticamente grazie alla funzione Capture.

27. Chiudere il file HTML.

28. Ripetere i passi precedenti cominciando dal passo 11, per eseguire per il catalog
record Counties of Wisconsin, le associazioni per il layer di sfondo e il layer in primo
piano.

Ora sarà possibile associare le feature class Minnesota e Wisconsin ai loro cataloghi.

29. Selezionare il catalog record State of Minnesota.

30. Selezionare il Layer in primo piano.

31. Cliccare su Associate Feature Class.

32. Selezionare la feature class Minnesota.

33. Premere il pulsante OK.

34. Ritornare alla finestra di dialogo Associate Catalog Records.

35. Premere il pulsante Capture per caricare le informazioni della Feature all’interno
del catalog record.

Ripetere questo processo per il catalogo State of Wisconsin e la feature class Wisconsin
cominciando ancora dal passo 28.
Abbiamo ora quattro catolog records associati alle feature class ed ai loro dati.

36. Premere il pulsante Close nella finestra di dialogo Associate Catalog Records.

Utilizzo del Catalog Explorer
Ora che le informazioni sulle Feature sono state catturate, per ognuna delle due County
catalog record e per ognuna delle due State catalog record, è possibile utilizzare il Catalog
Explorer che ci permette di navigare ed esplorare il database di catalogo.

1. Selezionare Tools > Catalogs > Catalog Explorer.

Accertarsi che la connessione LearningCatalog, sia aperta nel campo Available catalog
records.

Tutti i record sono visualizzati.

2. E’ possibile, cercare I dati, utilizzando Text/Date Criteria oppure Spatial Criteria.

3. Prima di tutto bisognerà cercare per attributi: nell’operazione di cattura delle
informazioni per le feature class associate ad ogni record, vengo catturati anche gli
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attributi delle feature. Ad esempio si sono catturate le informazioni sulle precipitazioni
nevose annuali (ANNULSNOW).

4. Selezionata la scheda Text/Date Criteria, digitare ANNULSNOW nel campo
Enter attribute accanto al pulsante Add.

5. Premere il pulsante Add.

L’attributo nome, viene spostato nel campo di display sotto, che ci mostra che l’attributo
nome verrà incluso nella prossima ricerca.

6. Premere il pulsante Search nell’angolo in basso a destra della finestra di dialogo.

7. Notare che i quattro catalog records catturati compaiono ora nella lista dei risultati
Search results nell’angolo in basso a sinistra della finestra di dialogo.

Tutte e quattro le feature sono provviste dell’attributo ANNULSNOW.

8. Selezionare la scheda Spatial Criteria in basso al centro della finestra di dialogo.

9. Notare che tutti i record con gli attributi catturati sono inclusi nei risultati di ricerca
per questa interrogazione.

10. Il motivo di ciò è che tutte le feature associate con I quattro cataloghi record,
contengono questo attributo.

11. Ora combineremo una ricerca di tipo testo/data con una ricerca spaziale.

12. Se non viene utilizzato il comando Clear, la query già presente rimane visualizzata
una volta terminata la ricerca.

13. Ora, mantenere la query di tipo Text/Date (non utilizzare ora il bottone Clear), e
verificare che la scheda Spatial Criteria sia selezionata..

14. Innanzitutto è necessario selezionare una feature class georeferenziata nel campo
Select feature class for reference in bounding box definition, all’interno della
scheda Spatial Criteria nella finestra di dialogo.

15. Premere il pulsante Select feature class for reference in bounding box
definition.

La connessione warehouse è così visualizzata a schermo

16. Si apra la connessione learn e si selezioni la feature class OutputStates
La feature class è così visualizzata a schermo.
Si può utilizzare il pulsante con lo scopo di definire un area rettangolare di ricerca che
comprenda l’intero stato del Winsconsin ma non l’interno stato del Minnesota.

17. Premere il pulsante Bounding Extent.

18. Si disponga il cursore sopra e a sinistra dello stato del Winsconsin in modo da
creare l’angolo in alto a sinistra come da figura.
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19. Si prema il pulsante sinistro e, lasciandolo premuto si trascini il cursore in modo da
creare l’angolo in basso a destra.

20. Lasciare il pulsante del mouse.

21. Premere il pulsante Search.

Dipendentemente dalla posizione del rettangolo di ricerca, i risultati ottenuti sono ridotti a
due dei catalog records. Si possono visualizzare così i risultati nell’area della finestra di
dialogo Search Results.

22. Si selezioni Counties of Wisconsin e State of Wisconsin nell’area di Search
Results utilizzando appropriatamente il pulsante CTRL con lo scopo di selezionare più
righe.

23. Si può notare che quando due o più record sono selezionati il bottone Load
Feature Data, diviene disponibile. Questo bottone serve a connettersi al warehouse
che contiene la feature class (se non la connessione non è già avvenuta) e visualizzare
le Features nel map view del presente workspace.

Nota: Non bisogna mantenere le Feature associate a i due catalog records visualizzati nel
map view. Se per qualche ragione avviene ciò, è preferibile uscire dal comando, eliminare
le Features dalla Legenda ed eseguire la query nuovamente.

24. Selezionare Load Feature Data.
25. Il comando permette di connettersi ai warehouse e visualizzare le Features.

26. Premere il pulsante OK quando il messaggio Load Feature Complete viene
visualizzato.

27. Uscire dal Catalog Explorer e osservare la map view.
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Esportare Catalog Records
Si può ora utilizzare il comando di esportazione per generare un report di catalog record.

1. Selezionare Tools > Catalogs > Export Catalog Records.

2. Selezionare la connessione di catalogo LearningCatalog.

Una lista con i cinque record è visualizzata nel campo Records.

3. Selezionare Counties of Wisconsin.

4. Scegliere HTML come formato di esportazione.

5. Nel campo Export Folder utilizzare la cartella di default Warehouses\Catalogs.

6. Cliccando su Apply si generi il report nel formato scelto HTML.

7. Quando il messaggio viene visualizzato, premere il pulsante OK.

8. Premere il pulsante Close nella finestra di dialogo Export Catalog Records.

9. Utilizzando L’Explore di Windows, navigare fino alla cartella di output, ed aprire il
file of Wisconsin.htm.

Può risultare utile leggere i files di log creati durante questo processo.

Congratulazioni! Avete completato il tutorial Utilizzare i Cataloghi Geospaziali di
GeoMedia Professional. Potete ora scegliere di cominciare un altro capitolo di Impariamo
GeoMedia Professional Tutorial.

Se avete completato tutti i flussi di lavoro di questo tutorial, avrete familiarizzato
sufficientemente con GeoMedia Professional tanto da poter decidere di lavorare con i
vostri propri dati. Se invece volete maggiori informazioni su altri comandi di GeoMedia
Professional, potete all’interno del programma selezionare Help > GeoMedia
Professional Help Topics.
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6 – Acquisizione dei dati
6-1 Iniziare ad Acquisire Dati
GeoMedia Professional, è provvisto di un set di dati che permette la produzione, la cattura,
il controllo dei dati attraverso funzioni che facilitano le procedure di editing. Ad esempio le
funzioni di SmartSnap di tipo vettoriale e raster, la creazione automatica di nodi, l’utilizzo
di geometrie già esistenti, sono utilizzate frequentemente perchè permettono di risolvere
alcuni tra i più noti problemi nella fase di editing, come buchi nelle aree, aree incongruenti,
o intersezioni senza nodi. Inoltre quando vengono rilevati errori, si può disporre di funzioni
di correzione automatizzata, funzioni che permettono di estendere o di tagliare le classi di
feature mantenendo la coerenza con le altre feature esistenti.

In questa sessione, si utilizzerà un GeoWorkspace dove sarà possibile digitalizzare dati
provenienti da una pista da sci. Poi ci si connetterà ad un warehouse contenete dati
vettoriali. Saranno così disponibili diverse feature class, di cui tre di tipo lineare. Dapprima
si andrà a modificare una di queste features, poi utilizzando le coordinate contenute in un
file di testo, che saranno inserite come landmarks, si passerà alla georeferenziazione di
una immagine. Questo dato, di tipo raster, verrà utilizzato come fonte su cui digitalizzare
informazioni di tipo vettoriale.

Prima di Cominciare

Prima di cominciare il flusso di lavoro per cattura dei dati, si seguano i seguenti passi:

 Copiare il file SkiResort_orig.gws contenuto nella cartella GeoWorkspaces e
rinominarlo SkiResort.gws, copiare il file SkiResort_orig.mdb contenuto nella cartella
Warehouses e rinominarlo SkiResort.mdb (è in effetti raccomandabile creare una copia
di archivio dei files SkiResort.gws e SkiResort.mdb, con nomi differenti).

 Avviare GeoMedia Professional, e lanciare il file SkiResort.gws.

Attenzione: Se GeoMedia Professional sembra non rispondere ai comandi assicurarsi
che la finestra attiva sia GeoMedia Professional e non la finestra di tutorial.

Connessione ad un Warehouse Access
Il Warehouse SkiResort contiene diverse feature class, alcune delle quali saranno
utilizzate come punto di partenza per l’estrazione di dati.

1. Selezionare Warehouse > New Connection.

2. Il campo Connection type ci permette di visualizzare differenti warehouse a cui
sarà possibile connettersi.

3. Scegliere Access.

4. Nel campo Connection name cancellare il testo corrente e digitare Ski Resort.
5. Per selezionare un file di tipo Access Database premere il pulsante Browse.

6. Selezionare SkiResort.mdb, e premere il pulsante Open.

7. Premere il pulsante OK.

8. Per verificare quali e quante connessioni sono presenti, scegliere Warehouse >
Connections.

9. La connessione Ski Resort dovrebbe apparire alla voce Name.
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10. Premere il pulsante Close.

Aggiungere Voci di Legenda
Si possono ora aggiungere alla map window le voci di legenda contenute nel warehouse
Ski Resort.

1. Selezionare Legend > Add Legend Entries.

2. Nella finestra di dialogo Add Legend Entries si faccia click sul pulsante
contrassegnato dal simbolo + con lo scopo di aggiungere la feature Ski Resort.

Si può notare come tutti gli elementi appartenenti alla connessione siano ora
selezionati.

3. Premere il pulsante OK.

Tutte le feature class appartenenti a questo warehouse sono ora aggiunte alla legenda.

Il confine regionale, mostra che la dimensione della pista

4. Premere il pulsante con il tasto destro l’elemento di legenda County e scegliere
Display Off.

Il confine regionale non è visualizzato sulla mappa.

5. Fare nuovamente click destro sull’elemento di legenda e scegliere Hide.

L’elemento di legenda non è più visualizzato in legenda.

6. Ingrandire la map window e selezionare View > Fit All.

Tutte le feature sono ora visualizzate nella map window.

Cambiare i Settaggi di Highlight e Selezione e Cambiare i settaggi di Style
E’ possibile modificare i colori di highlight e selezione in modo che siano differenti dai
colori di default per gli elementi vettoriali.

1. Selezionare Tools > Options.

2. Premere il pulsante di scheda Map Display.

3. Se il colore scelto per gli elementi selezionati, è differente da navy blue, scegliere
questo colore per l’elemento Select.

4. Se il colore scelto per gli elementi evidenziati, è differente da arancio, scegliere
questo colore per l’elemento Highlight.

5. Premere il pulsante OK.

6. Fare doppio click sulla simbologia dell’elemento Landmarks nella legenda.

7. Selezionare lo stile per Landmarks.

8. Premere il pulsante OK nella finestra di dialogo Legend Entry Properties.

Cambiare lo stile per questo elemento, scegliere elementi triangolari di colore arancione.

Cambiare il sistema di coordinate del Geoworkspace
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Si possono ora cambiare le coordinate del GeoWorkspace in modo che le distanze e le
aree siano espresse in miglia e miglia quadrate.

1. Selezionare View > GeoWorkspace Coordinate System.

2. Premere il pulsante di scheda Units and Formats.

3. Nel campo Type, selezionare Area.

4. Nel campo Unit selezionare miles squared (mi^2).

5. Nel campo Type selezionare Distance.

6. Nel campo Unit selezionare miles (mi).

7. Premere il pulsante OK nella finestra di dialogo GeoWorkspace Coordinate
System.

Selezionare le Opzioni delle Proprietà di Dialogo per le Nuove Features
Prenderemo ora in esame uno dei settaggi della finestra di dialogo Options: Display
Properties dialog for new features, e vedremo come questo comando facilita
l’inserimento degli attributi per una nuova Feature

1. Selezionare Tools > Options.

2. Selezionare la scheda Placement and Editing nella finestra di dialogo Options.

3. Assicurarsi che la funzione Display Properties dialog for new features sia attiva.

4. Premere il pulsante OK.

Nota: E’ possibile accendere e spegnere questo commando anche dalla toolbar Options,
utilizzando il pulsante mostrato nella figura sottostante.

IMPORTANTE:

 Se non riuscite a vedere la toolbar Options, è possibile espandere GeoMedia
Professional a tutto schermo, spostare questa toolbar in un altra area dello schermo,
ad esempio la linea successiva, e far ritornare poi la finestra di GeoMedia Professional
alla dimensione precedente.

 In questa fase, tutte le opzioni su questa toolbar, possono essere accese, eccetto
Break Linear Features, che dovrebbe essere lasciata spenta. Le opzioni saranno
discusse più dettagliatamente nelle prossime sezioni.

Quando l’opzione Display Properties dialog for new features è accesa, e viene creata
una nuova feature, o viene modificata una feature già esistente, utilizzando ad esempio
Insert Feature or Change Feature Class, la finestra di dialogo Feature Properties, è
automaticamente visualizzata a schermo, è così possibile, inserire gli attributi per la
Feature.

Al contrario, quando questa opzione viene spenta, ed una nuova Feature viene creata, la
finestra di dialogo Feature Properties, non viene visualizzata, ed i valori di attributo, per la
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nuova feature possono essere visualizzati in un altro momento, nel caso in cui si
desiderano prima creare le feature class desiderate e poi inserire gli attributi, questa
opzione andrebbe lasciata spenta.

Nel caso in cui la nuova Feature possiede degli attributi obbligatori, la finestra di dialogo
Feature Properties sarà comunque visualizzata a schermo al termine dell’editing, sia nel
caso in cui l’opzione Display Properties dialog for new features sia accesa sia nel caso
in cui l’opzione sia spenta.

Nel prossimo esercizio, verrà mostrato un esempio per chiarire come questa opzione può
essere utilizzata.

Cambiare una Classe di Feature
All’interno di questo warehouse, una delle strade è stata classificata non correttamente,
infatti appare essere una ferrovia. E’ possibile utilizzare il comando Change Feature
Class, con lo scopo di correggere questo errore.

1. Fare doppio click sulla Feature Street C, in modo da far apparire la finestra di
dialogo degli attributi.

Si può osservare come gli attributi appaiano in una finestra di dialogo che si chiama
Trail Properties, ciò significa che la Feature Street C è stata classificata come
Ferrovia (Trail).

2. Premere il pulsante Cancel per uscire dalla finestra di dialogo Trails Properties.

3. Mantenendo la Feature Street C selezionata, utilizzare il comando Edit > Feature >
Change Feature Class.

4. Si selezioni il menù a tendina per il campo Target feature class.

5. Si apra la lista delle feature class disponibili dalla connessione Ski Resort e si
selezioni la feature class Streets.

6. Assicurarsi che le opzioni Copy values from matching attributes e Delete
originali feature siano attive.

7. Premere il pulsante OK.

La finestra di dialogo Streets Properties è ora visibile per la feature riclassificata.

La finestra di dialogo viene visualizzata perché, questa feature ha un attributo
obbligatorio (Street ID). In ogni caso, anche se non ci fosse un attributo obbligatorio,
sarebbe stata visualizzata comunque, proprio perché l’opzione Display Properties
dialog for new features è attiva.

8. Si inseriscano i seguenti valori: nel campo Name il valore Street C, nel campo Type
il valore RD, nel campo Street ID, il valore 3.

9. Premere il pulsante OK.

La feature è ora effettivamente una strada, e la simbologia è stata modificata
congruentemente al valore scritto nel database.

10.Salvare il GeoWorkspace.
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Utilizzare la Funzione Precision Key-ins per inserire dei punti
Possiamo disporre delle coordinate di cinque punti notevoli che ci sono stati forniti tramite
un file di testo, chiameremo questi punti landmarks. E’ possibile copiare questi punti ed
incollarli, nel campo Coordinate display and entry field.

Per prima cosa, è necessario spegnere il settaggio Display Properties dialog for new
features. Fare ciò serve a poter scrivere tutti i punti prima di inserire i loro attributi.

1. Assicurarsi che l’opzione Display Properties dialog for new features, sia spenta;
è possibile verificare lo stato di questa funzione sulla toolbar utilizzando il pulsante
mostrato nella figura sottostante, ma anche utilizzando il menù di controllo
accessibile da Tools > Options. Poi selezionare la scheda Placement and Editing
togliere la spunta al Display Properties dialog for new features, premere il
pulsante OK.

2. Spegnere ora la funzione di Autopanning (questa funzione serve a spostare in
automatico la posizione del map window, nel caso in cui si faccia editing, o si
vogliano misurare Features, che si trovano anche in parte fuori dal bordo dello
schermo) selezionando Tools > Options. Poi selezionare la scheda SmartLocate
dove è possibile spegnere la funzione Pan map windows automatically. E’
preferibile tenere spenta la funzione quando si inseriscono delle nuove Features.
premere il pulsante OK.

3. Utilizzando un qualunque editor di testo come ad esempio il Blocco Note, aprire il
file landmark coordinates.txt che si trova nella cartella Learning.

Nota: Si faccia riferimento alla sezione 1-2 Connettersi ad un Warehouse se non si
conosce la localizzazione della cartella Learning, o non si ha accesso ad essa.

4. Tornare a GeoMedia Professional ed utilizzare la funzione Insert > Feature.

La barra di comando Insert Feature è ora visualizzata a schermo.

5. Dal campo più a sinistra, si selezioni Landmarks dalla connessione Ski Resort.

Nota: Se GeoMedia Professional sembra non rispondere ai comandi assicurarsi che la
finestra attiva sia GeoMedia Professional e non la finestra di tutorial.

6. All’interno del campo Placement Mode selezionare Orient to geometry.

7. Premere il pulsante Coordinate display and entry options pulldown, come
mostrato di seguito.

Nota: Se il commando Coordinate display and entry options pulldown non è
visualizzato, selezionare View > Precision Coordinates.

8. Deselezionare il comando Update coordinates on mouse move, in modo che
risulti spento.
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Accertarsi che questo comando sia spento prima di copiare il testo dal file di notepad.
Se infatti il comando viene lasciato acceso, e al contempo il cursore si trova nella map
window, è possibile che le coordinate inserite siano quelle descritte dal cursore
piuttosto che quelle memorizzate nel file di testo.

9. Accendere le opzioni Update coordinates on click e Clear coordinates after
enter.

10.Se il menù è ancora visualizzato, premere ESC.

11.Accertarsi che il Current coordinate format (il campo che definisce la tipologia
della coordinate utilizzate), sia Lon,Lat(d:m:s).

12.Ritornando al file di testo, copiare la prima riga del testo, dopo averla selezionata,
premendo CTRL-C.

13.Tornare a GeoMedia Professional, selezionare l’intera riga di testo contenuta nel
campo Coordinate display and entry field, premere CTRL-V per incollare
l’informazione precedentemente copiata e premere ENTER.

ATTENZIONE: Dato che ora ci si trova nella modalità Insert Feature, è preferibile non
premere il pulsante la finestra di map window, perché si potrebbe inavvertitamente
aggiungere un landmark.

IMPORTANTE: Accertarsi di aver incollato le linee di testo nel campo Coordinate
display and entry field.prima di premere il tasto ENTER

Ora un punto è stato inserito, lo stile di visualizzazione è corretto, e il simbolo è
collegato dinamicamente al cursore, la finestra di prompt è pronta per ricevere un altro
punto.

Si può allora ripetere la procedura, per posizionare i punti rimanenti utilizzando i valori
contenuti nel file di testo.

Nota: Nel caso in cui venga accidentalmente inserita una feature, è possibile
cancellarla utilizzando il comando Edit > Undo. (Questo comando sarà descritto con
maggiore dettaglio più avanti).

14.Rimanendo nella modalità Insert Feature, copiare dal file di testo le righe
successive, con lo scopo di posizionare gli altri punti, seguendo la stessa
procedura.

Cinque landmarks sono ora posizionati, due sulla Feature Street A e due sulla Feature
Street B.
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Se ci fosse necessità di correggere uno dei punti, è possibile utilizzare il comando Edit
> Feature > Delete.

15.Selezionare il tool Select in modo da uscire dalla modalità di Insert Feature.

16.Chiudere il file di testo.

17.Salvare il GeoWorkspace.

Inserire un Raster
Utilizzando GeoMedia Professional, è possibile generare dati vettoriali a partire da dati di
tipo raster, vedremo ora come usare il comando Image Registration, e i tool di
digitalizzazione. Nel caso delle immagini i comandi di raster snapping possono essere
utilizzati insieme con le funzioni di vector snapping con lo scopo di facilitare la procedura.
Questi tool permettono di individuare i punti di snap in modo automatico, senza dover
continuamente ingrandire o rimpicciolire le feature utlizzando le funzioni di zoom.

1. Selezionare Insert > Interactive Image.

2. Premere il pulsante Browse.

3. Aprire l’immagine raster resort_map.bmp dalla cartella di Learning.

4. Accertarsi che il campo Warehouse sia settato su Ski Resort.

5. Si digiti il nome della Feature nel campo Feature class: ResortImage (senza
spazi).

6. Premere il pulsante OK.

La simbologia di cursore cambia e diviene a croce, viene visualizzato il messaggio
Press and drag to define image size and scale.

Nota: Se necessario spostare la legenda, o chiuderla.

7. Posizionare il cursore dentro la map window, premere il pulsante sinistro del
mouse, e trascinare il cursore in modo da definire un area rettangolare che sia
contenuta all’interno dei cinque punti triangolari che sono stati generati
precedentemente.
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L’immagine è ora posizionata nella map window.

Note:

- Se l’immagine è troppo piccola per vedere i cinque punti, è possibile rimuovere
l’immagine selezionando la corrispondente voce di legenda e premendo DELETE.
Poi è possibile posizionare nuovamente l’immagine con un nuovo nome di Feature.

- Se l’immagine è grande abbastanza da poterne leggere il contenuto, ma non si
trova in una posizione favorevole sullo schermo (ad esempio copre uno o più dei
punti precedentemente inseriti) è possibile spostare l’immagine. Per fare questo
utilizzare il comando Edit > Geometry > Move, sarà così possibile spostare
l’immagine in un zona dello schermo dove è possibile vedere sia l’immagine che i
punti. Utilizzare i comandi Pan e Zoom in modo appropriato.

Modificare il Colore di una Immagine Raster
Utilizzando GeoMedia Professional è possibile cambiare il colore di un immagine binaria di
tipo raster. Cambiando il colore di primo piano, sarà più facile vedere gli snap glyphs (che
saranno descritti nella prossima sezione) mentre si digitalizza.

1. Fare doppio click sulla chiave di legenda dell’immagine raster (ResortImage)

Nota: Se precedentemente è stata chiusa la legenda per facilitare la visualizzazione, è
possibile visualizzarla nuovamente utilizzando il comando View > Legend.

2. Premere il pulsante Properties.

3. Premere il pulsante Foreground color.

4. Nella finestra di dialogo Color, scegliere un coloro chiaro, tipo viola chiaro, rosa o
grigio. Meglio non utilizzare dei colori che si stanno utilizzando per visualizzare
feature evidenziate o selezionate.

5. Premere il pulsante OK nella finestra di dialogo Color.

6. Assicurarsi che non siano stati attivati i settaggi di Invert image o Transparent.

7. Premere il pulsante OK su tutte le finestre di dialogo.

Ora il colore di primo piano è stato cambiato.

8. Salvare il GeoWorkspace.
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Come Registrare una Immagine
Se un immagine viene visualizzata correttamente nella map window, si può procedere
con la georeferenziazione. Con lo scopo di portare a termine questa operazione con la
precisione richiesta, utilizzeremo gli snap glyph di tipo raster e vettoriale.

Nota: Questi strumenti verrano approfonditi nella prossima sezione, per il momento si
utilizzeranno solo i comandi fondamentali con lo scopo di introdurre alla comprensione di
questi utili strumenti di cui dispone GeoMedia Professional.

1. Accertarsi che la toolbar di SmartSnap sia visibile.

Nota: Se la toolbar non è visibile selezionare View > Toolbars, spuntare SmartSnap,
e premere il pulsante OK.

2. Su questa toolbar, accendere il quinto ed il nono pulsante, contando da sinistra,
mentre tutti gli altri andrebbero lasciati spenti.

Solo gli snaps Origin e Intersection (Raster) snap dovrebbero essere attive.

3. Selezionare l’immagine precedentemente inserita cliccandoci sopra.

4. Mantenendo l’immagine selezionata, scegliere Tools > Image Registration.

5. Nella finestra di dialogo Registrations premere il pulsante New.

La finestra di dialogo New Image Registration permette di visualizzare una grigia
dove inserire i punti di controllo. Inoltre si possono osservare dei bottoni che
permettono di disporre di differenti modi di aggiungere punti di controllo.

6. Premere il pulsante Add Points.

Questo pulsante permette di inserire coppie di punti di controllo cliccando nella map
window.

7. Quando viene visualizzato nella barra dei comandi il messaggio Click to place
source control point 1, localizzare il punto L1 sull’immagine raster (si trova vicino
al margine in alto a sinistra dell’immagine)

8. Posizionare il cursore al centro di questo punto. Quando lo snap glyph Intersection
è visualizzato, fare click con il pulsante sinistro.

Come si può osservare, un 1 viene posizionato su questo punto dell’immagine.

9. Quando viene visualizzato il messaggio Click to place target control point 1,
nella barra di prompt posizionare il cursore che corrisponde a L1 sul dato vettoriale
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(il simbolo triangolare più a sinistra posizionato sull’elemento Street A). Quando si
può notare lo snap glyph Origin che appare proprio come mostrato in figura, fare
click con il mouse.

Viene posto un 1 sulla componente vettoriale di questo dato.

10.Quando viene visualizzato il messaggio Click to place target control point 2,
nella barra di prompt, posizionare il cursore che corrisponde a L2 (questo punto si
trova in alto a destra).

11.Quando viene visualizzato il messaggio Click to place target control point 2, che
si riferisce al dato vettoriale L2, (il triangolo che si trova più a destra tra quelli
posizionati lungo il vettore Street A).

12.Si prosegua con il posizionare i punti L3, L4, e L5 sull’immagine raster e sul dato
vettoriale rispettivamente.

13.Fare ora doppio click con il pulsante sinistro del mouse per segnalare che si è finito
di posizionare i punti.

La finestra di dialogo New Image Registration, viene visualizzata e come si può
osservare, è possibile leggere tutte le coppie di punti che sono state create. Quando i
punti sono di un numero superiore a 3, GeoMedia Professional è in grado di calcolare
lo scarto quadratico medio associato.

14.Nel campo Name di questa finestra di dialogo, si sostituisca il testo già presente
con Ski Resort Image Registration.

15.Premere il pulsante Register.

Ora l’immagine è registrata con successo.

16.Utilizzando la scheda di legenda Display Order trascinare l’elemento di legenda
che rappresenta l’immagine (ResortImage), in ultima posizione.
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Con questa disposizione tutti gli altri elementi di legenda presenti hanno priorità
sull’elemento raster, ciò significa che possono essere visti, selezionati ed editati con
maggiore facilità.

L’immagine è visualizzata proprio come nella figura qui sotto, con il colore di primo
piano che è stato precedentemente scelto.

Nota: Se per qualche motivo l’immagine non è stata registrata correttamente è
possibile cancellare la georeferenziazione utilizzata, e ripetere la procedura in modo
appropriato.

17.Selezionare View > Fit All.

18.Salvare il Geoworkpace.

Continuare con la prossima sezione: 6-2 Digitalizzare Edifici e Ferrovia
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6-2 Digitalizzare Edifici e Ferrovia
In questa sezione si utilizzerà l’immagine raster che è stata registrata nella sezione
precedente, con lo scopo di digitalizzare alcuni elementi. Si considerino come dati
vettoriali pre-esistenti, le tre strade e i cinque punti di appoggio presenti in questo
Geoworkspace. Si utilizzerà pertanto l’immagine raster per modificare la strada,
aggiungere degli edifici, ed una ferrovia. Si tenga presente che l’immagine sarà utilizzata
come guida con lo scopo di tracciare dei percorsi e delle aree, che saranno poi
memorizzarti come dati vettoriali.

GeoMedia Professional è provvisto di otto tipi di snap di tipo vettoriale e sei tipi di snap di
tipo raster, che possono essere utilizzati per scrivere o modificare la geometria delle
Feature Fare riferimento allo schema sottostante per comprendere la natura e l’utilizzo
degli snap.

Glyph Snap Description Type

Intersection
(Vector) Snaps to the intersection point of two vector lines Vettoriale

End point Snaps to the end point of a line feature Vettoriale

Vertex Snaps to a vertex of a point, line, or area feature Vettoriale

On element Snaps to any non-vertex point on a line or area feature Vettoriale

Origin Snaps to the origin point of a point, text object, or a
symbol Vettoriale

Mid-point Snaps to the mid-point of a line or area feature Vettoriale

Tangent Snaps to a point that is tangent to an existing arc
segment Vettoriale

Perpendicular Snaps to a point that is perpendicular to an existing arc
or line segment Vettoriale

Intersection
(Raster) Snaps to the intersection point of two raster lines Raster

End of line Snaps to the end of a raster line Raster

Corner Snaps to a corner (an angle close to 90 degrees) Raster

Open symbol Snaps to the center of an open symbol (unfilled circle) Raster
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Closed symbol Snaps to the center of a closed symbol (filled circle) Raster

Center Snaps to the center of a raster line Raster

Note:

 Se si incontrano difficoltà nella fase di digitalizzazione e nelle operazioni di
inserimento dei punti durante la scrittura o la modifica delle Feature, selezionare
Start > Settings > Control Panel > Mouse. Selezionare la scheda Motion dove è
possibile modificare la velocità del mouse attraverso il controllo Pointer Speed.
Selezionando la scheda Button è inoltre possibile modificare la velocità di doppio
click attraverso il controllo Double-Click Speed. Premere il pulsante OK dopo aver
modificato a piacere questi settaggi.

 Durante la fase di modifica, o di inserimento di dati vettoriali, fare un click con il
mouse quando uno snap glyph è visibile, serve a posizionare un punto od un nodo
nella posizione indicata dallo snap glyph.

 Nel caso in cui più di un tipo di snap risulta appropriato per una data posizione,
viene utilizzato lo snap glyph con priorità più alta. In generale tutti gli snap di tipo
vettoriale hanno precedenza sugli snap di tipo raster. All’interno degli snap
vettoriali, lo snap di tipo On Element viene preceduto dagli altri, che hanno tutti la
stessa priorità, mentre invece tra gli snap di tipo raster, è Center che deve dare la
precedenza a tutti gli altri che hanno tra loro stessa priorità.

 Il comando Tools > SmartSnap Tolerances, serve a gestire la tolleranza sia degli
snap di tipo vettoriale quanto quella degli snap di tipo raster.

IMPORTANTE: Tutti e sei gli snaps di tipo raster (Intersection, End of line, Corner, Open
Symbol, Closed Symbol, e Center) funzionano solamente con immagini di tipo binario,
come ad esempio l’immagine resort_map.bmp.

Gestire l’Opzione di Copia dei Valori di Attributo Provenienti da altre
Features
Prenderemo ora in esame uno dei settaggi della finestra di dialogo Options: Copy
attribute values from previous feature, questa funzione permette di aggirare la noiosa
operazione che consiste nel ripetere l’inserimento della stessa informazione di attributo,
nella tavola di attributi di Features che hanno gli stessi valori di attributo o valori di attributo
molto simili.

1. Selezionare Tools > Options.

2. Selezionare la scheda Placement and Editing della finestra di dialogo Options.

3. Assicurarsi che l’opzione Copy attribute values from previous feature sia
abilitata.

4. Premere il pulsante OK su questa finestra di dialogo.

Quando l’opzione Copy attribute values from previous feature è attiva, e si vanno a
scrivere più Features utilizzando i comandi Insert Feature, Insert Text, o Interactive
Label il valore di attributo, viene copiato dalla prima Feature a quelle successive. Inoltre
se l’opzione Display Properties dialog for new features è attiva, i valori saranno
visualizzati nella finestra di dialogo Properties quanto la scrittura è terminata. Siccome i
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valori di attributo della prima feature vengono copiati nelle feature successive, è possibile
utilizzarli o fare delle modifiche piuttosto che digitare i valori manualmente di volta in volta.
Questa funzione risulta particolarmente utile nel caso in cui si stanno scrivendo Features
con attributi uguali o molto simili.

Vedremo nell’esercizio successivo un esempio di utilizzo della funzione.

Definire lo Stile per il Costruito, la Ferrovia, le Strade e le Aree di Ristoro
Si procederà ora con il modificare lo stile di visualizzazione delle voci di legenda, per gli
elementi come il costruito, le strade, la ferrovia, le aree di ristoro.

1. Si faccia doppio click sull’elemento di legenda Buildings.

2. Si selezioni lo stile Buildings.

3. Premere il pulsante OK sulla finestra di dialogo.

Lo stile della feature Buildings è stato modificato coerentemente con lo stile scelto.

4. Si esegua il passo precedente per gli elementi di legenda Trails, Streets, e
RecreationalAreas, andando a scegliere lo stile predefinito, che ha il nome
dell’elemento di legenda.

Aggiungere elementi di tipo Building alla mappa attraverso l’immagine
Si possono ora aggiungere alcuni elementi alla mappa utilizzando il dato raster. In seguito
si utilizzeranno gli strumenti Split e Copy per creare delle opportune modifiche.

1. Si rendano attivi, sulla barra SmartSnap, tutti i controlli di snap disponibili, ad
eccezione dell’ultimo controllo di snap raster (Center), in modo che tutti i controlli
tranne l’ultimo risultino operativi.

2. Si accenda la funzione Display properties dialog for new features, utilizzando la
toolbar o utilizzando la scheda Placement and Editing del comando Tools >
Option.

3. Selezionare Insert > Feature.

4. Selezionare la feature class Buildings nel campo più a sinistra della barra dei
comandi Insert Feature.

Il pulsante Area risulta ora attivo per evidenziare il fatto che si sta per inserire una
feature di tipo areale.

5. Selezionare dalla menù a tendina Placement mode, il comando Place by rotated
rectangle.

Quando si utilizza questo tipo di controllo, è possibile disegnare dei rettangoli ruotati.
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6. Si utilizzi il controllo di zoom per visualizzare, approssimativamente alla scala
rappresentata dalla figura sotto, il gruppo delle costruzioni contraddistinte da un
numero. Si prema ESC per tornare al menù Insert Feature.

7. Quando viene visualizzata la finestra di prompt Click to place first point for
Buildings, si ponga il cursore sul margine sinistro dell’elemento Building 1 per
posizionare il primo punto.

Nota: Lavorando a questa scala, può risultare più comodo posizionare i punti
manualmente, senza tenere conto degli snap, essi sono infatti più utili quando si lavora
ad una scala minore.

8. Quando viene visualizzata la richiesta nella barra di prompt Click to place next
point, posizionare il cursore nell’angolo in alto a destra e disegnare il secondo
punto.

Nota:

 Se durante la fase di editing, si desidera fare una correzione, si può tornare
indietro di un passo utilizzando il pulsante BACKSPACE della tastiera, oppure
utilizzando la funzione Undo, come vedremo nei passi successivi.

 Se i risultati della digitalizzzione non coincidono perfettamente con le aree
descritte dall’immagine raster, non è necessario fare ulteriori modifiche.

9. Si posizioni ora il terzo punto coerentemente con lo spigolo della costruzione
descritta dall’immagine raster.

Il costruito è stato così posizionato, e la finestra di dialogo Buildings Properties viene
visualizzata sulla schermo.

10.Digitare i seguenti valori: Building 1 per l’attributo Name, For ski lodge per
l’attributo Notes e 221 per l’attributo Building ID.

11.Cliccare OK.

12.Si utilizzi la stessa procedura per digitalizzare l’elemento Building 2. Si proceda
posizionando i due punti in alto prima, e poi il terzo punto in basso.

Dopo che l’elemento Building 2 è stato digitalizzato, la finestra di dialogo Buildings
Properties, viene visualizzata, siccome il comando Copy attribute values from
previous feature è stato attivato, i valori di attributo vengono copiati dalla feature
precedente Building 1.

13.Si possono ora digitare gli attributi per Building 2, (il comando in esame permette di
sveltire il processo in quanto sarà necessario digitare solo i caratteri differenti da
Building 1) si digiti Building 2 per l’attributo Name, For ski lodge per l’attributo
Notes, e 222 per l’attributo Building_ID.

14.Premere il pulsante OK sulla finestra di dialogo Buildings Properties.
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I primi due elementi building sono stati correttamente inseriti.

Si continuerà ad utilizzare il commando Insert Feature anche nel prossimo esercizio.

15.Salvare ora il GeoWorkspace.

Utilizzo dei comandi Undo e Redo
Suppose you have made an error and want to undo or redo a feature that you have
placed.

Si supponga di aver inserito un errore e si vogliano utilizzare le funzioni di undo e redo.

1. Selezionare Tools > Options.

2. Scegliere la scheda Placement and Editing.

Notare la presenza del comado Undo su questa scheda, qui si possono gestire i
controlli della funzione Undo/Redo.

3. Assicurarsi che il commando Undo sia attivato.

Questa opzione serve ad abilitare il comando Undo, che può essere comodamente
utilizzato durante le operazioni di disegno, all’interno di una sessione di editing.

4. Accertarsi che l’opzione Limit undo operations sia stata attivata e che il valore
Number sia impostato su 5.

Questa opzione serve a definire un limite massimo per il numero delle operazioni
memorizzate da GeoMedia Professional che possono essere sfruttate per tornare ad
uno stato precedente durante le operazioni di editing. Non esiste un limite massimo per
le operazioni che si possono memorizzare anche se un valore troppo alto può avere
effetto sulle prestazioni del computer.

5. Premere il pulsante OK nella finestra di dialogo Options.

Utilizzeremo ora la funzione Undo per ripristinare uno stato precedente della fase di
editing, e la funzione Redo per ripristinare uno stato più avanzato.

6. Selezionare Edit > Undo Insert Feature.

L’elemento Building 2 è stato rimosso.

7. Selezionare nuovamente Edit > Undo Insert Feature.

L’elemento Building 1 è stato rimosso.

Utilizzeremo ora la funzione Redo per ripristinare gli elementi rimossi.

8. Selezionare Edit > Redo Insert Feature.

L’elemento Building 1 è ora ripristinato.

9. Selezionare nuovamente Edit > Redo Insert Feature.

L’elemento Building 2 è ora ripristinato.

10.Si provi a selezionare ora Edit > Redo Insert Feature per la terza volta.

Si può notare come, ora che tutte le operazioni sono state annullate prima e ripristinate
poi, il comando Redo, rimanga disabilitato.

11.Si può ora digitalizzare l’elemento Building 3 utilizzando la procedura che si è
utilizzata per le features Building 1 e Building 2.
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12.Digitare i seguenti attributi per la feature Building 3: Building 3 per l’attributo
Name, For ski lodge per l’attributo Notes, e 223 per l’attributo Building_ID.

13.Si può ora digitalizzare l’elemento Building 4 sempre utilizzando la stessa
procedura.

14.Si inseriscano ora gli attributi per Building 4: Building 4 per l’attributo Name, For
ski lodge per l’attributo Notes, e 224 per l’attributo Building_ID.

15.Salvare il GeoWorkspace.

Anche nel prossimo esercizio utilizzeremo la funzione Insert Feature.

Digitalizzare l’elemento Trail 1
Si utilizzerà ora il comando Insert Feature per disegnare la prima parte della ferrovia, che
verrà tracciata utilizzando l’immagine di sfondo come riferimento.

1. Accertarsi che l’opzione Display Properties dialog for new features sia attiva,
utilizzare pertanto la scheda Placement and Editing dal comando Tools >
Options, o alternativamente la barra dei controlli Option.

2. Selezionare la feature class Trails, dal menù a tendina del comando Insert
Feature.

3. Selezionare View > Fit All.

4. E’ possibile ora digitalizzare l’elemento Trail 1, seguendo le istruzioni della tabella
sottostante. Utilizzare pertanto la tipologia di Placement e Snap Glyph indicate in
tabella, avendo cura di attivare i comandi suggeriti dalla barra di controllo.

Si utilizzerà per ora solo la modalità di Placement di tipo Point by Point.

Placement Snap glyph Point Location on raster image

Point by point 1 End point of Trail 1

Point by point 2 Intersezione di Trail 1 and Street B

Point by point or 3 Point along Trail 1

Point by point or 4 Point along Trail 1

Point by point 5 Intersezione di Trail 1 and Street A

Si utilizzeranno ora le altre opzioni di posizionamento.

5. Nel menù a tendina Placement mode, selezionare Arc by start, end, point on
edge.

Il controllo Arc by Start, End, Point on Edge, si è perciò pronti per disegnare un arco
di curva.

Non servirà modificare nessuno dei settaggi.
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6. Fare click destro, per visualizzare il menù.

7. Spegnere l’opzione Arc Tangency Constraint.

8. Uscire dal menù

9. Digitalizzare come segue:

Placement Snap
glyph Point Location on raster

image

Arc by Start, End, Point on
Edge 6 End point of arc

Arc by Start, End, Point on
Edge none 7 Point along arc

L’arco di curva è ora posizionato.

Note: la modalità di posizionamento Arc by Start, End, Point on Edge risulta ottimale
quando si conoscono il punto di inizio e il punto di fine, proprio come nel caso in cui si
utilizza un immagine di sfondo come sorgente. Se invece si sta creando un arco di
curva senza utilizzare un riferimento, il comando Arc by Start, Point on Edge, End
può risultare più efficiente.

10.Tornare alla modalità Point by Point.

11.Continuare a digitalizzare seguendo la tabella sottostante:

Placement Snap glyph Point Location on raster image

Point by point 8 Point along Trail 1

Point by point 9 Point along Trail 1

Point by point or 10 Point along Trail 1

12.La feature è ora completa, è possibile uscire dalla modalità di editing, utilizzando il
comando ALT + Click, doppio click, o il comando End Feature, disponibile dal
menù di tasto destro.

13.Nella finestra di dialogo Trails Properties, digitare i seguenti valori: Trail 1 per
l’attributo Name, Intermediate per l’attributo Rating, e 12 per l’attributo Trail_ID.

14.Premere il pulsante OK.

15.Premere ESC per uscire dal comando Insert Feature.

La parte della ferrovia che va dal punto 1 al punto 10 è stata effettivamente creata.

16.Salvare il GeoWorkspace.
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Utilizzare l’Opzione Break Linear Features
L’opzione Break linear features presente all’interno della finestra di dialogo Options,
permette di dividere una feature in due parti dove è presente un punto di snap. Inoltre è
possibile decidere se si intende dividere contemporaneamente tutte le features coincidenti,
o solamente la feature che si sta modificando.

1. Selezionare Tools > Options.

2. Scegliere la scheda Placement and Editing.

3. Attivare l’opzione Break linear features.

Anche l’opzione Break all feature classes deve essere selezionata.

4. Premere il pulsante OK per uscire dalla finestra di dialogo.

Nota: è possibile utilizzare il pulsante mostrato nella figura sottostante, localizzato nella
barra delle opzioni, per attivare o disattivare il comando.

Estendere una Feature Lineare, Dividere una Strada in Due Parti
Verrà utilizzato il comando Extend to Intersection con lo scopo di estendere la feature
Street C all’intersezione con la feature Street A, specificando solo un punto. Inoltre
essendo stata attivata l’opzione Break linear features quando viene utilizzato il comando
Extend to Intersection la feature, Street A verrà divisa in due features.

1. Utilizzare i controlli di zoom, in modo da poter visualizzare comodamente la
porzione di feature compresa tra i punti 15, e 18.

2. Selezionare Edit > Geometry > Extend to Intersection.

3. Quando viene visualizzato il comando Select a feature to be extended nella barra
di prompt, posizionare il cursore nel punto 15.

Il segmento che si vuole estendere viene evidenziato.
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4. Con il segmento della feature evidenziato, premere il pulsante per confermare che
si vuole accettare la nuova componente.

La feature Street C è stata estesa fino alla feature Street A, contemporaneamente la
feature Street A è stata spezzata in due parti, e la finestra di dialogo the Streets
Properties, viene visualizzata per entrambe le componenti, una alla volta.

5. Si inseriscano gli attributi per il lato sinistro della feature Street A: Street A per
l’attributo Name, RD per l’attributo Type, e 17 per l’attributo Street_ID.

6. Premere il pulsante OK.

7. Si inseriscano gli attributi per il lato destro della feature Street A: Street A per
l’attributo Name, RD per l’attributo Type, e 16 per l’attributo Street_ID.

8. Premere il pulsante OK.

Le nuove strade sono state correttamente inserite nel database.

9. Premere ESC per uscire dal comando Extend to Intersection.

10.Accertarsi che che il tool Select sia selezionato, poi spostare il cursore sopra la
feature Street A e poi sopra la feature Street A2.
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Questi elementi sono due feature distinte e per questo motivo si evidenziano
separatamente.

11.Spegnere l’opzione Break linear features utilizzando il pulsante sulla toolbar, o la
scheda Placement and Editing accessibile dal comando Tools > Options.

Nel caso in cui fosse stato utilizzato il comando Extend to Intersection,
mantenendo disattivata l’opzione Break linear features, sarebbe stato comunque
possibile estendere la feature così come si è fatto, ma non si sarebbe spezzata la
feature Street A in due features.

12.Salvare il Geoworkspace.

Ridigitalizzare la Feature Street C
Il comando Redigitize Geometry, permette di cancellare e ridigitalizzare una parte
qualunque di una feature lineare o di una feature areale, in questo esempio si convertirà in
linea curva, un tratto rettilineo.

1. Utilizzare i controlli di zoom, in modo da poter visualizzare comodamente la
porzione di feature compresa tra i punti 15, e 18.

2. Selezionare la feature class Street C.

Sarà ora possibile ridigitalizzare quella porzione di strada compresa tra i punti 15 e 16.
Al momento la linea tra i due punti è retta, la si convertirà in linea curva, seguendo il
tratto descritto dall’immagine di sfondo.
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3. Dopo aver selezionato l’elemento, scegliere il comando Edit > Geometry >
Redigitize.

Viene visualizzata la barra di controllo Redigitize Geometry.

Il comando serve a ridigitalizzare qualunque parte di una feature areale o lineare.

4. Selezionare il comando Arc by start, point on edge, end dal menù Placement
Mode.

5. Ora sarà necessario specificare il punto di inizio e il punto di fine della portione di
feature che si vuole ridigitalizzare.

Placement Snap
glyph Point Location on raster image

Arc by Start, Point on
Edge, End o 15 Intersezione di Street C e

raster Trail 1

Arc by Start, Point on
Edge, End 16 Intersezione di Street C e

raster Trail 1

Il punto di inizio viene posizionato automaticamente sul punto 15: il punto selezionato
come punto di inizio nel passo precedente.

6. Fare click destro per visualizzare il menù.

7. Disattivare l’opzione Arc Tangency Constraint.

8. Se necessario utilizzare il pulsante ESC per uscire dal menù.

9. Indicare un punto lungo l’arco e poi il punto di fine dell’arco:

Placement Snap
glyph Point Location on raster image

Arc by Start, Point on
Edge, End nessuno 17 Punto lungo la curva Street

C

Arc by Start, Point on
Edge, End 16 Intersezione di Street C e

raster Trail 1
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La feature Street C è ora ridigitalizzata.

10.Salvare il GeoWorkspace.

Utilizzo dell’opzione Use Existing Geometry When Digitizing
Nel prossimo esercizio, si continuerà a scrivere la geometria della feature Trail 1. Questo
elemento contiene alcuni elementi che sono coincidenti con Street A, B e C. Sarà allora
possibile utilizzare la geometria descritta da questi elementi mentre si disegna la feature
Trail 1.

1. Selezionare Tools > Options.

2. Dalla finestra di dialogo Options, selezionare la scheda Placement and Editing.

3. Disattivare l’opzione Use existing geometry when digitizing per visualizzare
come la grafica al di sotto di questa opzione cambia.

4. Attivare ora l’opzione Use existing geometry when digitizing.

5. Premere il pulsante OK.

Nota: è possibile attivare o disattivare il comando Use Existing Geometry When
Digitizing utilizzando la toolbar Options.

Utilizzare il Comando Continue Geometry
Il comando Continue Geometry viene utilizzato quando si vuole estendere la geometria
primaria di una feature. Oltre a poter aggiungere, in modo continuo o discontinuo, la
geometria ad una feature esistente, è anche possibile utilizzare questo strumento per
aggiungere geometria a delle feature che possiedono attributi ma non geometria, e per
aggiungere dei buchi a delle features già esistenti.

Si può utilizzare il comando Continue Geometry, per finire di digitalizzare la feature Trail
1.

1. Selezionare View > Fit All.

2. Selezionare quella parte della feature Trail 1 che è già stata digitalizzata.

3. Mentre questa selezione è attiva, selezionare select Edit > Geometry > Continue.

Viene visualizzata la barra di controllo Continue Geometry, mentre Trail è la feature
class che deve essere modificata.

4. Selezionare il posizionamento di tipo Point by Point.

5. Continuare la geometria della feature Trail 1 seguendo le indicazioni della tabella
sottostante:

Placement Snap
glyph Point Location on raster image
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Point by
point 10 Ultimo punto digitalizzato da Trail 1

Point by
point 11 Intersezione di Street C e raster Trail

1

6. Selezionare Arc by Start, End, Point on Edge, oppure premere il tasto A.

7. Fare click con il pulsante destro del mouse per visualizzare il menù.

8. Disattivare l’opzione Arc Tangency Constraint.

9. Uscire dal menù di tasto destro del mouse.

10.Continuare la geometria della feature Trail 1 come suggerito dalla tabella
sottostante:

Placement Snap
glyph Point Location on raster image

Arc by Start, End, Point
on Edge 12 Intersezione di Trail 1 and

Street B

Arc by Start, End, Point
on Edge none 13 Curve of Trail 1

11.Selezionare il posizionamento di tipo Point by point, o premere il pulsante L sulla
tastiera.

12.Continuare la Geometria della feature Trail 1 come segue:

Nota: La geometria della feature Trail 1 compresa tra i punti 15 e 16, coincide con la
geometria della feature Street C. Si potrà osservare come quando si digitalizza questo
segmento, sarà necessario posizionare lo snap solamente al punto di inizio e al punto
di fine (i punti 15 e 16 rispettivamente), mentre l’arco di curva verrà copiato.

Placement Snap glyph Point Location on
raster image

Point by
point o 14 Intersezione di

Trail 1 e Street A

Point by
point o 15 Inizio della Curva

di Street C

Point by
point

o Accertarsi che il
segmento curvo sia evidenziato

16 Fine della curva di
Street C

13.Si continui a descrivere la geometria dell’elemento Trail 1 come segue:

Nota: La geometria della feature Trail 1 compresa tra i punti 19 e 22, coincide con la
geometria della feature Street A, mentre tra i punti 23 e 25, coincide con la geometria
della feature Street B. Esattamente come prima, quando si digitalizzano questi
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segmenti, sarà necessario, posizionare lo snap sul punto di inizio e sul punto di fine, ed
il resto del segmento sarà copiato.

Placement Snap glyph Point Location on raster
image

Point by
point 19 Intersezione di Trail

1 e Street A

Point by
point

Accertarsi che il
segmento di Street A sia

evidenziato
22 Intersezione di Trail

1 e Street A

Point by
point or or 23 Intersezione di Trail

1 e Street B

Point by
point

Accertarsi che il
segmento di Street B sia

evidenziato
25 End point of Street

B

14.La feature è ora completa, è possibile uscire dalla modalità di editing, utilizzando il
comando ALT + Click, doppio click, o il comando End Feature, disponibile nel
menù di tasto destro.

La geometria della feature Trail 1 è completa.

15.Salvare il GeoWorkspace.

I Construction Aids
I comandi Insert Feature, Redigitize Geometry, e Continue Geometry, utilizzano dei
controlli detti construction aids, che permettono di facilitare la costruzione o la modifica
della geometria durante le fasi di editing. Per esempio nel caso in cui si stia disegnando
una feature lineare, se si vuole che il punto successivo sia localizzato ad una specifica
distanza orizzontale o verticale si possono utilizzare i comandi Delta X e Delta Y, del
comando Insert Feature, per poi continuare l’editing utilizzando gli strumenti classici.
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In questo esercizio, si utilizzeranno i construction aids Distance Along Feature,
Perpendicular From, e Perpendicular To per poter aggiungere una strada addizionale
che sarà utilizzata dagli impiegati della pista da sci come strada di servizio.

Utilizzare il Comando Distance Along Feature
1. Accertarsi che la funzione Break linear features sia attiva.

2. Utilizzare il comando di zoom out, o il controllo di pan, per visualizzare
correttamente il punto di fine a destra della feature Street A, che è ora la feature
Street A2 perché si è divisa la feature in due parti quando si è utilizzato il comando
Extend to Intersection, per estendere la feature Street C.

3. Selezionare il comando Insert Feature e selezionare la feature class Streets.

4. Selezionare il posizionamento di tipo Point by point.

5. Fare click con il pulsante destro del mouse per visualizzare il menù del comando
Insert Feature.

6. Selezionare Distance Along Feature.

Viene visualizzato il controllo Distance Along Feature.

7. Digitare il valore 1.2 per la distanza (1.2 miglia).

8. Posizionare il cursore sul punto di fine sul lato destro della feature Street A.

9. Quando viene visualizzato lo snap glyph, fare click per posizionare il punto.

Un nuovo punto è stato posizinato lungo la feature Street A2, ad 1,2 miglia dal punto di
fine. La nuova strada di servizio servirà a connettere la feature Street A2 alla feature
Street B e sarà perpendicolare ad entrambe le strade.

Si utilizzerà la modalità Insert Feature anche nel prossimo esercizio.

Posizionare una Perpendicolare
I comandi Insert Feature, Redigitize Geometry, e Continue Geometry permettono di
posizionare una linea perpendicolare ad un’altra.

1. Fare click con il tasto destro del mouse, per visualizzare il menù di Insert Feature.

2. Selezionare l’opzione Perpendicular From.

Si può osservare come il vertice successivo formi un angolo di 90 gradi con la feature
Street A2.

3. Posizionare un punto a metà tra la feature Street A e la feature Street B.

La linea è ora posizionata.

4. Fare click con il tasto destro del mouse, per visualizzare il menù di Insert Feature.

5. Selezionare l’opzione Perpendicular To.

6. Premere il pulsante sulla feature Street B.

La linea viene disegnata dinamicamente a 90 gradi dalla linea che è stata selezionata.

E’ possibile posizionare la linea su qualunque feature lungo l’estensione della
perpendicolare a questo punto (il vertice non avrà lo snap automatico per la feature
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selezionata), in questo caso però si avrà cura di chiudere la linea facendo
coincidere lo snap sul segmento lineare selezionato.

7. Posizionare il cursore sopra la feature Street B, e fare poi premere il pulsante per
attivare lo snap.

La nuova strada è stata posizionata.

8. La feature è ora completa, è possibile uscire dalla modalità di editing, utilizzando il
comando ALT + Click, doppio click, o il comando End Feature, disponibile dal
menù di tasto destro.

9. Nella finestra di dialogo Streets Properties, inserire i seguenti valori: Service
Road per l’attributo Name, RD per l’attributo Type, e 5 per l’attributo Street_ID.

10.Premere il pulsante OK.

11.Premere ESC per uscire dal comando Insert Feature.

12.Salvare il GeoWorkspace.

Congratulazioni! Avete completato la sezione di digitalizzazione di questo tutorial. Si tenga
presente che esistono altri strumenti di digitalizzazione ed editing, tra cui:

 Construct Circular Fillet

 Extend Two Lines to Intersection

 Insert Circle

 Partial Delete

Per avere maggiori informazioni su questi comandi, si faccia riferimento all’help in linea,
accessibile da Help > GeoMedia Professional Help Topics.

E’ possibile ora proseguire con la prossima sezione: 6-3 Modificare i Dati



167 di 213

6-3 Modificare i Dati
In questa sessione, si faranno delle modifiche ai dati che sono stati create
precedentemente. Si comincerà con il rimuove l’immagine raster, che è stata utile durante
la fase di digitalizzazione. Si procederà poi con il dividere uno degli elementi building, per
poi crearne una copia. Si utilizzerà il comando Insert Interactive Area By Face, con lo
scopo di inserire delle aree di ristoro contenute all’interno di features lineari. Si
apporteranno poi delle modifiche a queste aree, e si potrà osservare come utilizzando
GeoMedia Professional, sia possibile modificare contemporaneamente le geometrie
coincidenti, alla feature che si sta modificando. Si utilizzerà il comando Merge per unire
delle feature separate, il comando Trim to Intersection per dividere una feature lineare in
un punto specifico, e di seguito il comando Insert Intersection per concludere l’editing.

IMPORTANTE: Prima di cominciare questa sezione, accertarsi che l’opzione Break linear
features si spenta, mentre gli altri comandi della toolbar possono rimanere attivi.

Rimuovere l’Immagine
La fase di digitalizzazione, si può ora considerare completa, è perciò possibile rimuovere
l’immagine di sfondo.

1. Fare click destro sull’elemento di legenda immagine (ResortImage).

2. Selezionare Display Off.

Ora il raster non è più visibile all’interno della map window.

3. Salvare il Geoworkspace.

Analisi delle Informazioni sulla Geometria di una Feature
Il comando Geometry Information permette di leggere le informazioni di geometria per i
differenti tipi di feature, che siano punti, linee, archi, o poligoni. Questo comando è
particolarmente utile quando si stanno cercado dei punti duplicati. Utilizzeremo ora questo
comando per esporre la geometria dell’elemento Trail 1.

1. Selezionare Trail 1.

2. Selezionare Tools > Geometry Information.

La finestra di dialogo Geometry Information è ora visualizzata. L’elemento Trail 1
è descritto come una polilinea complessa, e la sua geometria è evidenziata
all’interno della map window.

3. Si faccia doppio click sulla prima riga di PolylineGeometry, in modo da esplicitarne
la sotto geometria, si può ottenere lo stesso risultato, esplodendo l’elemento
facendo cioè click sul simbolo + più alla sua sinistra.

4. Facendo click su ognuno dei punti appartenenti alla sottogeometria, è possibile
localizzare gli elementi sulla polilinea all’interno della map window.

Ogni punto selezionato viene contestualmente evidenziato nella map window.

5. Fare ora doppio click sul punto 4 nella finestra di dialogo di questa prima
PolylineGeometry.
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Sono visualizzate ora le coordinate del punto.

6. Fare doppio click con lo scopo di aprire un elemento di tipo ArcGeometry, per
visualizzare le informazioni in esso contenute.

Parametri di arco quali la lunghezza, la lunghezza di corda, il punto medio, l’angolo
sotteso, sono ora visualizzati insieme con il punto di inizio, il punto di fine, il raggio,
e il vettore normale.

Naturalmente è possibile utilizzare questo comando cancellare per uno o più vertici.

7. Selezionare il Punto 4 (il punto della prima PolylineGeometry che corrisponde al
punto evidenziato dalla figura sottostante).

8. Fare click destro sul punto nella finestra di dialogo Geometry Information.

Il menù di tasto destro è ora visualizzato, e mostra l’opzione Delete.

9. Selezionare Delete.

Il punto è stato cancellato.

10.E’ possibile modificare il colore e la grandezza della geometria visualizzata, inoltre
è possibile scegliere la modalità di visualizzazione delle coordinate del punto.

11.Premere il pulsante Options.

Si presti attenzione alle possibilità offerte dal menù di visualizzazione.

12.Premere il pulsante Cancel.

13.Premere il pulsante Close nella finestra di dialogo Geometry Information.

Una volta cancellato il vertice, la mappa dovrebbe rispecchiare a figura sottostante.

Questo esercizio ci mostra che si può Utilizzare la finestra di dialogo Geometry
Information non solo per recuperare le informazioni di geometria, ma anche per
portare a termine alcune tra le operazioni di editing, come cancellare vertici.
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14.Selezionare Edit > Undo Edit Geometry per ripristinare il vertice cancellato
precedentemente.

15.Salvare il Geoworkspace.

Dividere una Feature Areale
Si supponga di voler creare due edifici separati invece di uno singolo edificio come quelli
generati precedentemente. Si utilizzerà di seguito la funzione Split con lo scopo di
dividere uno degli edifici in due parti distinte.

1. Accertarsi che la funzione Display properties dialog for new features sia attiva.

2. Selezionare l’elemento Building 4, cioè l’edificio più a destra lungo l’elemento
lineare Street A2.

3. Selezionare Edit > Feature > Split.

4. Quando nella barra di prompt viene visualizzato il messaggio Click to place first
point for split, si posizioni un punto fuori dall’elemento Building, al di sopra di esso
e approssimativamente al centro.

Il primo degli estremi della linea che funge da intersezione è posizionato, e la linea
che viene generata è ora attiva e dinamica.
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5. Quando nella barra di prompt viene visualizzato il messaggio Click to place next
point, or double click to end, si vada a posizionare il secondo punto, ancora
esterno all’elemento Building 4, ed opposto al primo.

6. Si faccia doppio click ad indicare che si è completata la fase di split.

L’operazione di split è ora completa: la finestra di dialogo Buildings Properties
viene visualizzata, mostrando gli attributi di Building 4.

7. Premere il pulsante OK per confermare gli attributi di Building 4.

La finestra di dialogo Building Properties viene nuovamente visualizzata con lo
scopo di identificare gli attributi per Building 5.

8. Si inseriscano ora i seguenti attributi per Building 5: Building 5 per l’attributo
Name, For ski lodge per l’attributo Notes, and 225 per l’attributo Building_ID.

9. Premere il pulsante OK.

10.Selezionare il nuovo elemento Building 5, e selezionare Edit > Geometry > Move
per trascinare l’elemento sulla destra nella direzione in cui sono stati posizionati gli
edifici più piccoli.

Copiare un Elemento
Il comando Copy si utilizza per copiare le features. In questa sezione verrà creata una
copia identica dell’elemento Building 5.

1. Selezionare il nuovo elemento Building 5, che è l’elemento più a destra lungo la
feature Street A2.

2. Selezionare Edit > Feature > Copy.

Si rendono ora disponibili per l’editing i vertici dell’elemento Building 5.

3. Premere il pulsante sull’elemento in alto a sinistra di questa feature come punto di
partenza per l’operazione di copia.

4. Spostare ora il cursore in una posizione a sinistra dell’elemento Building 5 lungo
l’elemento strada e premere il pulsante per posizionare il nuovo elemento.

La finestra di dialogo Building Properties, è ora visualizzata ed è possibile
visualizzare gli attributi che sono stati copiati dall’elemento Building 5.
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5. Digitare ora i seguenti attributi per l’elemento Building 6: Building 6 per l’attributo
Name, For ski lodge per l’attributo Notes, e 226 per l’attributo Building_ID.

6. Premere il pulsante OK.

7. Premere il pulsante ESC per uscire dalla modalità Copy.

Ruotare un Elemento
E’ possibile utilizzare il comando Rotate con lo scopo di ruotare una o più features, lineari
o areali. Mentre i punti orientati e il testo possono essere ruotati utilizzando il commando
Spin. In questo esercizio verrà ruotato il sesto tra gli elementi appartenenti all classe
Building.

1. Selezionare l’elemento della classe Building che si trova più a destra, e che è stato
creato nell’esercizio precedente.

2. Selezionare Edit > Geometry > Rotate.

Verrà richiesto di selezionare un punto di base. Questo punto servirà a definire la
linea attorno la quale la feature sarà ruotata.

3. Selezionare l’angolo in alto a destra dell’elemento.

4. Muovere il mouse per verificare come la feature viene ruotata dinamicamente
intorno al punto base.

5. Quando l’edificio è ruotato in una posizione simile a quella mostrata nella figura,
fare click per accettare la nuova posizione.

L’elemento Building è ora correttamente rotato.

Creare Tre Nuovi Elementi Utilizzando il Comando Interactive Area By Face
In questa sezione si offre la possibilità di creare dei nuovi elementi areali circoscritti dagli
elementi Trail 1 e Street B utilizzando la funzione Interactive Area By Face. Questo
comando permette di creare delle feature areali a partire da uno o più elementi lineari. La
nuova area viene generata puntando un area sottesa ad una feature lineare. In questo
esempio si creeranno delle aree di ristoro (recreational areas).

1. Accertarsi che la funzione Display properties dialog for new features sia
disabilitata: è possibile utilizzare tanto la toolbar dei comandi quanto il controllo
fornito dal menù Options.
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2. Selezionare gli elementi di legenda Streets e Trails utilizzando il tasto CTRL con lo
scopo di creare una selezione multipla.

3. Selezionare Edit > Select By Legend Entry.

Ora gli elementi trail e streets sono selezionati nella map window.

4. Selezionare Insert > Interactive Area By Face.

Il menù di controllo Insert Interactive Area By Face è ora visualizzato a schermo.

5. Quando nella barra di prompt viene visualizzato il messaggio Select feature class,
selezionare la feature class RecreationalAreas.

L’opzione Include Holes permette di decidere se eventuali buchi saranno o non
saranno inclusi nella feature areale generata. In questo caso la feature scelta, non
contiene buchi quindi è possibile lasciare l’opzione disattivata.

6. Quando nella barra di prompt viene visualizzato il messaggio Move cursor to
closed region of line work, spostare il cursore sulla regione sottesa dalle feature
Trail 1 e Street B.

Quest’area viene evidenziata.

7. Premere il pulsante sulla regione selezionata per selezionarla.

Ora la nuova area viene posizionata.
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8. Premere ESC per uscire dal commando.

9. Fare doppio click sull’elemento appena creato, in modo da visualizzare la finestra di
dialogo RecreationalAreas Properties.

10. Inserire ora i seguenti valori di attributo per la nuova feature areale: Area 1 per
l’attributo Name, Sunrise to Sunset per l’attributo Hours, and 14 per l’attributo
RecArea_ID.

11.Premere il pulsante OK nella finestra di dialogo RecreationalAreas Properties.

Gli attributi sono stati aggiornati.

12.Mantendo selezionati gli elementi Streets e Trails, scegliere Edit > Select By
Legend Entry.

13.Selezionare Insert > Interactive Area By Face, per posizionare la prossima area di
ristoro.

Il controllo Insert Interactive Area By Face viene visualizzato a schermo.

14.Accertarsi che la feature class RecreationalAreas sia selezionata nel menù di
controllo Insert Interactive Area By Face.

15.Quando nella barra di prompt viene visualizzato il messaggio Move cursor to
closed region of line work, spostare il cursore sopra la regione sottesa alla
feature Street A e Trail 1.

Questa regione è ora evidenziata.
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16.Premere il pulsante l’area evidenziata per selezionarla.

La nuova area è posizionata.

17.Spostare il cursore sopra la regione sottesa dalle features Streets B e C and by
Trail 1.

18.Premere il pulsante sulla regione evidenziata per selezionarla.

La nuova area è ora posizionata.

19.Premere ESC per uscire dal comando Insert Interactive Area Bey Face.

Utilizzo della Funzione Maintain Coincidence
L’opzione Maintain coincidence permette, durante la fase di editing di posizionare vertici
facendo coincidere lo snap con altre features. Se mentre si disegna una feature, questa
opzione viene attivata, sarà possibile posizionare nuovi vertici in coincidenza di tutti i
vertici di tutte le features confinanti che sono visualizzate e definite locatable. (Il controllo
di localizzazione è disponile dal menù di tasto destro sulla voce di legenda di ogni feature
visibile). Se questo comando viene lasciato spento, i punti della nuova feature
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corrispondenti a vertici di feature adiacenti, non saranno vertici.

L’opzione Maintain coincidence permette inoltre di modificare più features allo stesso
tempo, se per esempio si hanno due strade, che si intersecano in un vertice, accendendo
l’opzione si potrà spostare il vertice ed entrambe le strade. Inoltre in casi in cui due
features hanno un confine comune, come nel caso di un fiume o di una particella
catastale, sarà possibile utilizzando l’opzione Maintain coincidence di modificare il confine
come una geometria a se.

1. Selezionare Tools > Options.

2. Dalla finestra di dialogo Options, selezionare la scheda Placement and Editing.

3. Accertarsi che l’opzione Maintain coincidence sia attiva e che l’opzione Segment
arcs when inserting vertex sia disattiva.

4. Premere il pulsante OK per chiudere la finestra di dialogo.

Nota: Questa opzione può essere attivata o disattivata utilizzando la toolbar Options.

Modificare la Geometria di Features Coincidenti
Il comando Edit Geometry, permette di modificare un vertice di una feature. Sarà
possibile cancellare un vertice appartenente all’area di ristoro, che coincide con vertici
appartenenti alle features Trail 1 e Street A. Si potrà notare come, essendo l’opzione
Maintain coincidence attiva, i vertici coincidenti saranno modificati conseguentemente.

1. Selezionare la più grande tra le aree di ristoro.

2. Selezionare Edit > Geometry > Edit.

Tutti i nodi sono visibili e sarà possibile modificarli od eliminarli.
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3. Se necessario si utilizzino i controlli di zoom per visualizzare i nodi in modo
appropriato.

4. Quando nella barra di prompt viene visualizzato il messaggio Click to add vertex,
or select vertices to move or delete, si può selezionare un vertice appartenente
all’area di ristoro, si selezioni ad esempio il vertice al di sotto dell’etichetta di Street
A, come mostrato nella figura sottostante.

Lo stile di visualizzazione del vertice cambia ad indicare che è stato selezionato.

5. Utilizzare il tasto DELETE per cancellare il vertice.

6. Si faccia click su Yes quando viene richiesta conferma per l’operazione scelta.

Ora il vertice è stato cancellato, la linea risultante è ora dritta, e l’area di ristoro è
stata ingrandita fino al nuovo confine.
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Nota: Nel caso in cui si abbia l’esigenza di cancellare più di un vertice, e non uno
solamente, è possibile usare il comando in modalità di selezione multipla: una volta
selezionato il primo vertice utile, è possibile tenere premuto il pulsante SHIFT mentre si
seleziona l’ultimo dei vertici interessati: utilizzando questa combinazione di pulsanti,
tutti i vertici compresi tra il primo ed il secondo saranno selezionati.

7. Premere il pulsante ESC per uscire dal comando Edit Geometry.

8. Fare ora click destro sulla voce di legenda RecreationalAreas e selezionare
Display Off questa operazione permetterà di visualizzare come sia stato cancellato
lo stesso vertice anche per le features Trail 1 e Street A.

9. Si evidenzi la feature Street A spostando il cursore al di sopra di essa, fare la
stessa cosa con la feature Trail 1.

Evidenziando le features si può notare come, le regioni componenti delle feature
Trail 1 e Street A che erano coincidenti con l’area di ristoro, siano state modificate
coerentemente.

10.Per visualizzare nuovamente le area di ristoro si faccia click destro sulla voce di
legenda associata e si selezioni Display On.

11.Salvare il GeoWorkspace.

Nota: Come specificato precedentemente, se l’opzione Maintain Coincidence viene resa
attiva, i vertici delle feature coincidenti vengono modificati coerentemente con la feature
che si sta modificando. Se non si vuole modificare il vertice coincidente di altre features, si
può operare come segue: 1) Spegnere l’opzione Maintaince Coincidence dalla finestra di
dialogo Options, 2) Rendere l’elemento di legenda non Locatable facendo click con il
pulsante destro sulla corrispondente voce di legenda e selezionando Locatable Off, 3)
Rendere l’elemento di legenda invisibile, facendo click con il pulsante destro e
selezionando Display Off. Questi tre modi seppure diversi daranno lo stesso risultato:
durante la fase di editing, una feature coincidente con la feature interessata da modifiche
rimane invariata dopo le operazioni di modifica.

Unire Feature Class Areali
Il comando Merge, sarà invece utilizzato per unire tre features areali e crearne una più
grande.
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1. Utilizzando la scheda Display Order della legenda, accertarsi che le features
Streets e Trails siano disposte al di sopra della feature RecreationalAreas.

Questo renderà l’operazione di merge più chiara.

2. Utilizzando la finestra di dialogo Option oppure il comando da toolbar, accendere
l’opzione Display properties dialog for new features.

3. Selezionare le tre aree di ristoro, selezionando prima la più grande, poi, tenendo
premuto il pulsante CTRL sulla tastiera, selezionare anche quelle più piccolo.

Nota: Quando si utilizza la funzione Merge, gli attributi della prima feature selezionata
sono quelli che vengono utilizzati per la feature di nuova creazione.

4. Selezionare Edit > Feature > Merge.

Gli elementi sono stati uniti. La nuova feature è stata scritta nel database, mentre le
feature di origine sono state cancellate. La finestra di dialogo RecreationalAreas
Properties è ora visualizzata e come si può osservare, i valori di attributo utilizzati
sono stati importati dalla prima delle features selezionate.

5. Nel campo Name digitare Resort Rec Area.

6. Premere il pulsante OK.
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7. Fare doppio click sull’area di ristoro con lo scopo di verificare che sia una unica
feature e che gli attributi siano corretti. Poi premere il pulsante sul pulsante Cancel
all’interno della finestra di dialogo della feature RecreationalAreas.

8. Utilizzando la scheda Display Order della legenda, accertarsi che le features
Streets e Trails siano disposte al di sopra della feature RecreationalAreas.

9. Salvare il Geoworkspace.

IMPORTANTE: Per gli esercizi successivi, all’intero di questa sezione, se si sta
visualizzando la finestra di Tutorial accanto alla finestra di GeoMedia Professional, è
opportuno accertarsi prima di eseguire comandi da tastiera (come ESC ad esempio) che
la finestra attiva sia quella di GeoMedia Professional e non quella di Tutorial.

Tagliare un Elemento su di una Intersezione
Si utilizzerà ora il comando Trim to Intersection per tagliare una parte della feature Street
C. Il comando sarà utilizzato per tagliare una feature all’altezza dell’intersezione più vicina
al punto finale.

Prima di utilizzare questo comando utilizzare la funzione Edit geometry per verificare come
non sia necessario che ci sia un vertice all’intersezione quando si intende utilizzare il
comando Trim to Intersection.

1. Selezionare View > Fit All.

2. Selezionare la Feature Street C.

3. Selezionare Edit > Geometry > Edit.

Notare che non esiste un vertice all’intersezione tra la feature Street B e la feature
Street C.

4. Premere il pulsante ESC per uscire dal comando Edit Geometry.

5. Selezionare Edit > Geometry > Trim to Intersection.

6. Quando la finestra di prompt visualizza il comando Select a feature to be
trimmed, si posizioni il cursore sopra l’elemento che si vuole tagliare, e cioè sulla
parte di strada della feature Street C che si estende oltre l’intersezione con la
feature Street B.
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La porzione di strada che si vuole tagliare è ora evidenziata.

7. Quando compare la finestra di prompt Click to trim the highlighted feature, si
faccia click per rendere l’operazione effettiva.
La feature è ora tagliata.

8. Premere il pulsante ESC per uscire dal comando Trim to Intersection.

9. Si farà ora un passo indietro per ripristinare la feature ad uno stato precedente.

10.Selezionare Edit > Undo Trim to Intersection, o premere CTRL Z.

L’operazione è stata annullata, si utilizzerà nella prossima sezione il comando
Insert Intersection per posizionare un nuovo vertice.

Inserire un Vertice Dove c’è Un Intersezione
Si utilizzerà ora il comando Insert Intersection per inserire un vertice all’intersezione di
due o più geometrie. Non è ancora presente un vertice all’intersezione delle Features
Street B e Street C. Questo comando risulta particolarmente utile nel caso in cui si voglia
modificare un intersezione: perché ciò sia possibile, un vertice all’intersezione deve essere
presente.

Questo comando ha priorità sul comando Maintain Coincidence, ciò significa che
indipendentemente da come questa ultima opzione sia stata impostata, saranno inseriti
vertici alle intersezioni per tutte le feature coincidenti che siano visibili e definite locatable.
Al contrario questo comando non ha priorità sull’opzione Break Linear Features: essendo
stata lasciata spenta questa opzione le features non sono state tagliate ai punti di
intersezione.

1. Accertarsi che la finestra di GeoMedia Professional sia attiva.

2. Selezionare Edit > Geometry > Insert Intersection.

3. Quando nella barra di prompt viene visualizzato il messaggio Select a feature
containing the intersection, si posizioni il cursore all’intersezione delle feature
Street B e Street C.

Un punto in modalità di localizzazione dinamica viene evidenziato all’intersezione.
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4. Quando nella barra di prompt viene visualizzato il messaggio Click to insert
intersection, si faccia click per accettare il punto di intersezione.

Il vertice è ora inserito nel punto di intersezione, e visibile.

5. Si prema il pulsante ESC per uscire dal comando Insert Intersection.

6. Selezionare la feature Street C, poi selezionare Edit > Geometry > Edit per
verificare che sia presente un vertice all’intersezione.

7. Premere il pulsante ESC per uscire dal comando Edit Geometry.

8. Salvare il GeoWorkspace.

Dividere una Feature Lineare
Il comando Trim permette di dividere una feature e, a differenza del comando Trim to
Intersection utilizzato precedentemente, è capace di dividere una feature in qualunque
punto e non solamente dove si è in presenza di un punto di intersezione.

1. Selezionare il comando Edit > Geometry > Trim.

La barra di prompt chiede di selezionare un feature per poterla dividere.

2. Si disponga il cursore intorno al punto di inizio della feature Trail 1.
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La feature che rappresenta la ferrovia è ora evidenziata, sarà necessario selezionare
il secondo punto per decidere dove la feature verrà tagliata.

Nota: Si presti attenzione alla selezione effettuata: essendo lo stile di visualizzazione di
questo elemento lineare di tipo tratteggiato, la selezione potrebbe non essere evidente.

3. Premere il pulsante sul punto di inizio dell’elemento Trail 1, così come mostrato
nella figura sottostante.

Viene ora richiesto di premere il pulsante per dividere la feature selezionata.

4. Si sposti il cursore in alto verso il punto di inizio della feature Trail 1, cercando di
tagliarla alla distanza mostrata nella figura sottostante.
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5. Fare click per dividere la feature.

La feature è stata tagliata.

6. Premere ESC per uscire dal comando Trim.

Estendere una Feature Lineare
E’ possibile utilizzare il comando Extend per estendere una feature ad una distanza
specificata. A differenza del comando Extend to Intersection, che è stato utilizzato
precedentemente, il comando Extend permette di estendere una feature ad una
qualunque distanza, piuttosto che estendere una feature fino ad un punto di intersezione.
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In questo esercizio utilizzeremo l’opzione Lock per specificare fino a dove la feature da
estendere sarà estesa.

1. Selezionare il comando Edit > Geometry > Extend.

2. Si disponga il cursore nell’intorno del punto di inizio della feature Trail 1.

La ferrovia è ora evidenziata, e viene richiesto di selezionare il punto di fine della
feature che si è deciso di dividere.

Nota: Si presti attenzione alla selezione effettuata: essendo lo stile di
visualizzazione di questo elemento lineare di tipo tratteggiato, la selezione potrebbe
non essere evidente.

3. Premere il pulsante il punto di inizio della feature Trail 1, come mostrato nella figura
sottostante.

4. Viene richiesto di premere il pulsante per estendere la feature evidenziata.

5. Sulla barra di comando Extend si abiliti la funzione Lock utilizzando il pulsante
mostrato nella figura sottostante.

6. Si digiti 0.6 (si intende 0.6 miglia) nel campo Distance all’interno della barra di
controllo Extend.

7. Accertarsi che il cursore sia posizionato all’interno della map window.

La feature è stata ora estesa dinamicamente di 0.6 miglia.

8. Fare ora click per accettare l’estensione.

La ferrovia è stata estesa.
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9. Premere ESC per uscire dal comando Extend.

10.Salvare il GeoWorkspace.

Si proceda ora con la sezione 6-4 Aggiornare gli Attributi
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6-4 Aggiornare gli Attributi
In questa sessione, si utilizzerà GeoMedia Professional con lo scopo di creare degli
elementi di tipo particella catastale, gestire ed aggiornare gli attributi associati. Prima di
tutto verrà creata una nuova feature class, poi utilizzando il comando Insert Area By
Face, si creeranno delle parcelle. Il tool Update Attributes Using Text, permetterà invece
di scrivere gli attributi, utilizzando le etichette che sono contenute all’interno dei confini
della particella catastale. Il comando Update Attributes servirà a scrivere il valore
dell’area in un campo apposito. In oltre, sarà possibile importare un file di testo,
contenente altri attributi, che verranno associati alle parcelle tramite un operazione di
Join, il risultato di questa operazione verrà esportato come feature class. In ultimo si
potranno aggiornare le tavole degli attributi con delle nuove informazioni.

Creare una Nuova Feature Class
All’interno del dataset contenente i dati della pista da sci, sono presenti delle feature areali
che rappresentano delle particelle catastali e che provengono da file di tipo CAD. Per
prima cosa, con lo scopo di convertire le particelle in aree e di riempire gli attributi che le
distinguono, si creerà una nuova feature class.

1. Selezionare Warehouse > Feature Class Definition.

2. Accertarsi che la connessione Ski Resort sia selezionata.

3. Fare Click New.

4. All’interno della scheda General digitare la stringa Parcels per l’attributo Name.

5. Nel menù a tendinaGeometry Type selezionare Area.

6. Scegliere la scheda Attributes.

7. Premere il pulsante di una riga vuota all’interno del campo Name e digitare
Parcel_Label. Accertarsi che il campo Type sia di tipo Text.

Si tenga presente che non è consentito agli attributi di tipo nome di contenere degli
spazi vuoti.

8. Premere il pulsante sulla riga successiva del campo Name e digitare Parcel_Area
come valore per questo attributo. Accertarsi che il campo Type per questo
attributo, sia di tipo Double.

9. Nel campo Format che si trova in basso nella finestra di dialogo, selezionare dal
menù a tendina il tipo Standard (3,456.79).

10.Per scrivere nel campo Name di questo terzo attributo, si faccia click su Name, e si
digiti Assessed_Value. Procedere come sopra per attribuire a questo attributo il
tipo di dato Double.

11.Nel campo Format selezionare dal menù a tendina il tipo Standard (3,456.79).

12.Nella finestra di dialogo, premere il pulsante OK.

Un messaggio chiederà se si vuole che GeoMedia crei una chiave primaria.

13.Premere il pulsante Yes.

La feature class Parcels è ora aggiunta nel campo Feature Classes.

14.Premere il pulsante Close.
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Utilizzare l’opzione che permette di aggiungere automaticamente gli
elementi alla legenda
Alcuni comandi utilizzati da GeoMedia Professional, come ad esempio Insert Feature e
Insert Area By Face, possono generare delle features che non sono delle voci di legenda,
e quindi non essere visualizzati automaticamente. L’opzione Automatically add legend
entries, permette di aggiungere automaticamente gli elementi alla legenda una volta
generati.

1. Selezionare Tools > Options.

2. All’interno della finestra di comando Options, selezionare la scheda Placement
and Editing.

3. Assicurarsi che l’opzione Automatically add legend entries sia attiva.

4. Premere il pulsante OK sulla finestra di dialogo.

Quando questa opzione viene abilitata, per ogni feature class che viene creata, verrà
creata la corrispondente voce di legenda, se invece la feature già esiste, ma è spenta, il
comando la renderà nuovamente visibile.

Nota: Se una feature class è particolarmente grande, la fase di visualizzazione può
prendere più tempo.

Nel prossimo esercizio, vedremo un esempio di utilizzo di questa opzione. La feature class
creata precedentemente, Parcels, non è stata ancora aggiunta alla legenda. Quando
invece l’opzione viene abilitata, una nuova feature creata attraverso il comando Insert
Area By Face, viene automaticamente aggiunta alla legenda.

Utilizzare il Comando Using Insert Area By Face
Il comando Insert Interactive Area By Face è stato utilizzato precedentemente per
inserire una feature areale a partire da una feature lineare, ora verrà utilizzato il comando
Insert Area By Face con lo scopo di inserire più di un elemento areale allo stesso tempo.

E’ importante notare che questo comando permette di creare features areali a partire da
features lineari, anche se la feature di partenza non è provvista di nodi alle intersezioni.

1. Selezionare le voci di legenda ParcelBoundaries e Streets.

2. Mantenere selezionati questi elementi di legenda Edit > Select by Legend Entry.

Tutte le particelle catastali e le strade presenti nella map window sono ora
selezionate.

3. Spegnere l’opzione Display properties dialog for new features.
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IMPORTANTE: I risultati del comando Insert Area By Face vengono mostrati in
sequenza, e questa sequenza può variare attivando o disattivando questa opzione.
Perché questo esercizio sia completato correttamente, è necessario che questa
opzione venga lasciata disattivata.

Non è necessario inserire gli attributi per ogni feature ora, ma sarà possibile
svolgere questa operazione successivamente, inserendo i valori per più di una
feature contemporaneamente utilizzando il comando preposto.

4. Selezionare Insert > Area By Face.

La finestra di dialogo Insert Area By Face viene visualizzata a schermo.

5. Nel campo Feature Class selezionare la feature Parcels appartenete alla
connessione Ski Resort.

6. Accertarsi che l’opzione Ignore holes sia selezionata.

7. Premere il pulsante OK.

Si può osservare come l’area sia ora evidenziata, mentre il messaggio Do you
want to place the highlighted area features? viene visualizzato a schermo.

8. Premere il pulsante Yes.

Le particelle catastali sono ora create e disposte al di sopra della feature originale
utilizzata per crearle. La feature creata è automaticamente aggiunta alla legenda in
quanto l’opzione Automatically add legend entries è stata attivata.

9. Si faccia doppio click sulla chiave di stile per l’elemento di legenda Parcels.

10.Selezionare lo stile predefinito Parcels.

11.Fare click su OK.

Si potrà ora cancellare l’elemento centrale di questo gruppo, perché sembra
assomigliare ad un vicolo cieco.

12.Selezionare il centro della particella e scegliere Edit > Feature > Delete.



189 di 213

13.Premere il pulsante Yes quando verrà chiesta conferma al comando.

Di seguito, verrà utilizzata la stessa procedura con lo scopo di eliminare la particella
esterna, creata partire dall’area chiusa contenuta tra la nuova strada di servizio e le
altre strade.

14.Selezionare l’area esterna subito al di fuori del gruppo delle particelle, compresa tra
la strada di servizio e le strade A2, B, e C, poi scegliere Edit > Feature > Delete.

15.Verrà chiesta conferma prima di eseguire il comando, premere il pulsante Yes.

16.All’interno della scheda Display Order di legenda, si posizioni la feature
FeatureLabels al di sopra della feature Parcels.

17.Salvare il GeoWorkspace.

Scrivere le Etichette come Attributi della Feature Parcels
Il comando Update Attributes Using Text, serve ad aggiornare un attributo utilizzando
delle feature di testo che siano in rapporto spaziale con la feature che di vuole aggiornare.
Per le features areali, l’attributo può essere aggiornato utilizzando il testo di una feature
testuale, il cui punto di origine è contenuto all’interno dell’area. Per una feature di tipo
puntuale o lineare, l’attributo può essere aggiornato utilizzando il testo della feature
testuale più vicina.

E’ possibile utilizzare questo comando per aggiornare gli attributi dell’elemento Parcels
con l’etichetta posta al di sopra delle parcelle.
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1. Selezionare Edit > Attribute > Update Attributes Using Text.

2. All’interno del campo Update features in selezionare la feature class Parcels dalla
connessione Ski Resort.

Tutte le particelle create in quest’ultimo esercizio sono state aggiornate.

3. All’interno del campo Attribute to update selezionare Parcel_Label dal menù a
tendina.

4. All’interno del campo Update text from selezionare l’elemento FeatureLabels
appartenente alla connessione Ski Resort.

Questa è una feature class testuale che verrà utilizzata per aggiornare l’attributo
Parcel_Label.

In questo caso, non verrà utilizzato il campo Distance che può essere utilizzato per
features lineari.

Se durante questa fase vengono commessi degli errori, gli errori saranno riportati
all’interno di un file testuale il cui nome verrà visualizzato nel campo Output errors
to. Vengono segnalati errori quando non viene trovata nessuna feature di testo
all’interno di un area, o quando più di una feature testuale viene individuata.

5. Premere il pulsante Apply.

L’attributo Parcel_Label viene così aggiornato per tutti gli elementi della feature
class Parcels utilizzando i valori dalle stringhe di testo che sono visualizzati
all’interno di ogni particella.

6. Premere il pulsante OK quando viene visualizzato il messaggio che avverte che gli
attributi degli elementi per una data feature sono stati aggiornati. In questo caso
dovrebbero essere 7 le features che sono state aggiornate.

7. Premere il pulsante Close nella finestra di dialogo Update Attributes Using Text.

8. E’ possibile fare doppio click su alcune particelle, per verificare che l’attributo
Parcel_Label è stato aggiornato utilizzando valori appropriati.

9. Salvare il GeoWorkspace.

Aggiornamento degli Attributi delle Features Parcel_Area e
Assessed_Value
Il comando Update Attributes permette di aggiornare i valori di attributo all’interno del
database. IMPORTANTE: Utilizzare con cautela questo comando in quanto modifica i
valori di attributo presenti nel database.

Il valore scritto può essere una costante o il risultato di una espressione matematica.
Inoltre è possibile aggiornare una colonna inserendo i valori Area, Length, o Perimeter
facendo click con il pulsante destro nel campo Value field of the specific attribute.

Nota: Questo comando utilizza la finestra di dialogo dei Functional Attributes per creare
delle espressioni matematiche. Nonostante ciò, differentemente dagli altri comandi (come
Aggregation, Analytical Merge e Functional Attribute) i cui risultati sono delle query
dinamiche, questo comando genera dei risultati di tipo statico. Questo significa che se il
dato iniziale viene modificato il risultato non viene modificato, sarà quindi necessario
eseguire nuovamente il comando per calcolare il nuovo risultato.
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In questo esercizio, verrà utilizzato questo comando per aggiornare i valori degli attributi di
Parcel_Area e Assessed_Value della feature class Parcels.

1. Selezionare il comando Edit > Attribute > Update Attributes.

La finestra di dialogo Update Attributes viene ora visualizzata a schermo.

2. Dal campo Update Features in selezionare la feature class Parcels appartenente
alla connessione Ski Resort.

Tutti gli attributi della feature class Parcels vengono ora mostrati.

Nota: Posizionare il cursore sopra il nome di un attributo permette di visualizzare il
tipo di dato.

Sarà ora possibile aggiornare l’attributo Parcel_Area. L’area è uno dei campi che
può essere calcolato utilizzando il campo Value in modo appropriato.

3. Premere il pulsante il campo Value dell’attributo Parcel_Area. Poi si faccia click
destro, per visualizzare il menù.

4. Selezionare Area.

L’espressione AREA(Input.Geometry, Constant.ProjectedMeas,
Constant.SquareMile) viene visualizzata nel campo Value.

E’ ora possibile selezionare un secondo attributo con lo scopo di aggiornarlo
attraverso la finestra di dialogo Update Attributes.

5. Selezionare l’attributo Assessed_Value cliccando il campo Value.

6. All’interno del campo Value digitare Output.Parcel_Area * 50 , dove "*" è
l’operatore di moltiplicazione.

L’espressione Output.Parcel_Area * 50 sarà visualizzata nel campo Value.

Nota: Siccome il valore di output dipende da un altro attributo (Parcel_Area), sarà
necessario calcolare il primo valore

7. Nella finestra di dialogo Update Attributes premere il pulsante Apply.

L’espressione è stata calcolata, e gli attributi sono stati aggiornati.

In alcuni casi è possibile utilizzare il pulsante Expression, che è provvisto di un
cospicuo numero di attributi funzionali.

8. Fare click sul pulsante Close.

9. Fare doppio click su uno degli elementi della feature parcel.

Gli attributi sono stati aggiornati e sono visualizzati nella finestra di dialogo Parcels
Properties.

Collegare una Tabella Contenente delle Informazioni Aggiuntive
Il comando Attach è stato utilizzato per importare un file contenente le coordinate di alcuni
punti. Lo stesso comando può essere utilizzato per importare un file di testo contenente
degli attributi che verranno collegati alla feature class Parcels. Il file di testo può contenere
delle informazioni addizionali come ad esempio il numero della particella catastale, il tipo
di suolo, il nome del proprietario, che saranno aggiunte e visualizzate. Lo scopo del
prossimo esercizio è quello di combinare queste informazioni con altre contenute nel
database.
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Per prima cosa diamo un’occhiata alle informazioni contenute nel file.

1. Utilizzando un editor di testo, come ad esempio il Blocco Note di Windows, si apra il
file parcel_info.txt, che si trova nella cartella Learning.

La prima riga del file contiene l’intestazione. Questo file verrà importato come file di
sola lettura, dove l’intestazione servirà a dare il nome ai campi, mentre le righe
rimanenti saranno i valori degli attributi.

Si può notare come questo file utilizzi l’operatore virgola come separatore di campo.

2. Chiudere il file di testo.

3. Selezionare Warehouse > Feature Class Definition.

4. Fare ora Click su Ski Resort per selezionare questa connessione.

5. Premere il pulsante il pulsante Attach.

La finestra di dialogo Attach viene ora visualizzata.

6. All’interno del menù a tendina, scegliere il valore Text.

Si può osservare come GeoMedia Professional, disponga della capacità di
collegarsi a numerosi tipi di file, comunque in questo caso, si utilizzerà un file di tipo
testuale.

7. Premere il pulsante Browse.

Aprire il file di testo parcel_info.txt, che si trova nella cartella Learning.

Una volta ritornati alla finestra di dialogo Attach si può notare come il file di testo
compaia ora nella lista Tables to attach. Inoltre come valore di default il file da
aggiungere è già spuntato, che sta ad indicare che il file sarà correttamente
aggiunto.

E’ possibile modificare il nome della tabella di output, questo nome sarà il numero
della feature class generata.

8. Fare doppio click sulla prima riga del campo Target table, che contiene il nome
parcel_info_txt.

9. Cambiare il nome con Parcel_Info.

10.Premere il pulsante OK sulla finestra di dialogo Attach.

Si è ora tornarti alla finestra di dialogo Feature Class Definition e come si può
notare, la feature class Parcel_Info è visualizzata nella connessione Ski Resort
come attached table.

E’ possibile controllare nuovamente la tabella e visualizzarne gli attributi.

11.Mantenendo selezionato l’elemento Parcel_Info premere il pulsante Review.

12.Premere il pulsante di scheda Attributes.

I seguenti attributi sono ora visualizzati: P_Label, Parcel_Number, Owner, e
Soil_Type.

13.Premere il pulsante OK sulla finestra di dialogo Review.

14.Premere il pulsante Close nella finestra di dialogo Feature Class Definition.
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Creare un Join tra la Feature Class Parcels e la Tabella Aggiunta
Come si potrà ricordare dalla sezione precedente, il comando “join” permette di creare una
relazione tra due classi di feature, o tra due interrogazioni, in modo che gli attributi di
entrambe possano essere contenute in una singola query.

Si procederà ora con il creare un join per le particelle della feature class Parcels, e le
informazioni aggiuntive che sono contenute nel file importato precedentemente.

1. Selezionare Analysis > Join.

2. Nella finestra di dialogo Join utilizzando il menù a tendina Left side of join,
selezionare la feature class Parcels dalla connessione Ski Resort.

3. Selezionare la feature class Parcel_Info dalla connessione Ski Resort utilizzando
la finestra di dialogo Right side of join.

4. Selezionare gli attributi Parcel_Label e P_Label, dai campi destro e sinistro di
Available attributes sui quali verrà effettuato il join.

5. Premere il pulsante la freccia verso il basso per aggiungere gli attributi al campo
Selected attribute pairs.

Nel campo Selected attribute pairs è possibile visualizzare la stringa
Parcel_Label = P_Label.

Nel caso in cui si abbia la necessità di scegliere quali tra gli attributi selezionare, o
di rinominare gli attributi da visualizzare, è possibile utilizzare il pulsante Attributes,
in questo caso si vogliono visualizzare tutti gli attributi.

6. Accertarsi che il Type of join, scelto sia Inner.

7. Nel campo Query name, è possibile inserire un nome, scegliere il nome Join of
Parcels and Parcel_Info.

8. Accertarsi che l’opzione Display join in data window sia attiva.

Il risultato verrà visualizzato solamente nella data window.

9. Mantenere il nome della data window di default: Data Window1.

10.Premere il pulsante OK.

Il join è visualizzato con il titolo scelto all’interno della data window. Ci sono sette
record visualizzati, uno per ogni particella catastale.

11.E’ possibile scorrere la data window verso destra per visualizzare tutti i campi
presenti.

12.Chiudere questa finestra, ed ingrandire la finestra di map window.

13.Salvare il GeoWorkspace.

Esportare i Risultati del Join come Feature Class
Si può procedere ora con l’esportazione dei risultati dell’operazione di Join. Se necessario
questa operazione permetterà di modificare la tavola degli attributi. Nel prossimo esercizio
si avrà la possibilità di aggiornare alcuni degli attributi.
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1. Selezionare Warehouse > Output to Feature Classes.

2. Nella sezione Source connections and queries, selezionare Queries.

3. Selezionare la query Join of Parcels and Parcel_info nel campo Queries.

La connessione SkiResort è scelta come Target connection.

4. Mantenere selezionato Display target feature classes in map window.

5. Premere il pulsante sulla scheda Advanced.

6. Premere il pulsante sul primo record al di sotto dell’intestazione Target Feature
Class e digitare CompleteParcels.

7. Cliccare OK.

8. Premere il pulsante Yes quando viene visualizzato il messaggio di conferma.

La nuova feature class, CompleteParcels è stata ora creata.

9. Premere il pulsante OK quando il messaggio di Output complete viene
visualizzato.

10.Fare doppio click sulla chiave di stile dell’elemento di legenda CompleteParcels.

11.Selezionare lo stile predefinito CompleteParcels.

12.Premere il pulsante OK.

13.Fare doppio click sulla feature CompleteParcels all’interno della mappa in modo
da visualizzare gli attributi presenti.

14.Premere il pulsante sulla scheda di legenda Display Order, posizionare la feature
FeatureLabels al di sopra della feature CompleteParcels.

Le etichette dell’elemento Parcel sono ora visualizzate.

15.Salvare il GeoWorkspace.

Aggiornare gli Attributi delle Particelle Catastali
You will use the Update Attributes command again to update the Owner attribute value
of just two parcels.

Il comando Update Attributes può essere nuovamente utilizzato per aggiornare i valori
del campo Owner per due delle sette particelle catastali.

1. Selezionare la prima e la seconda particella catastali nella map window, avere cura
di selezionare gli elementi della classe di feature ma non le etichette associate.

2. Selezionare il comando Edit > Attribute > Update Attributes.

La finestra di dialogo Update Attributes è ora visualizzata.

3. Con lo scopo di modificare gli attributi delle due feature che sono state selezionate,
fare click sul simbolo + situato accanto a Select Set, ora è possibile aprire Ski
Resort, e selezionare CompleteParcels.

Tutti gli attributi sono visibili per l’elemento CompleteParcels.

4. Selezionare il campo Value per l’attributo Owner e digitare'B.
Cauliflower' (inscrivere tra apici la stringa). Poi si può procedere con
l’aggiornamento di altri campi.



195 di 213

5. Cliccare su Apply nel dialog box Update Attributes,

Gli attributi sono stati aggiornati.

6. Cliccare Close.

7. Selezionare le due particelle, una per volta, facendo doppio click.

Nella finestra di dialogo CompleteParcels Properties è possibile visualizzare
l’attributo aggiornato.

8. Salvare il GeoWorkspace.
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Se si è completata con successo questa sezione è possibile procedure con la sezione 6-5
Completare i Risultati
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6-5 Completare i Risultati
Questa ultima sezione sulla cattura dei dati, servirà a comprendere come fare delle
ulteriori modifiche ai dati geografici. Si vedrà come inserire delle nuove etichette, come
inserire delle nuove immagini, come posizionare la freccia del nord e la barra di scala
all’interno della map window. Si passerà in ultimo alla creazione di una nuova map window
e all’inserimento dei dati.

Posizionare Etichette Interattive
Come si potrà ricordare, le strade che si trovano nel warehouse a cui ci si è connessi
precedentemente, possedevano già delle etichette identificative. Sono poi state aggiunte
altre features, come la strada, la ferrovia, l’area di ristoro. Si può ora utilizzare il comando
Insert Interactive Label con lo scopo di creare delle etichette per queste features. Questo
comando serve a creare etichette per alcune features, piuttosto che per tutte le features
contenute nella feature class corrispondente. Si comincerà con il creare un etichetta per
l’elemento Street A2.

In oltre si scoprirà come posizionare elementi di tipo curved text.

1. Accertarsi che l’opzione Display properties dialog for new features si attiva.

2. Selezionare Insert > Interactive Label.

3. Selezionare la feature class Streets contenuta nel warehouse Ski Resort,
utilizzando il menù a tendina Label features in nella finestra di dialogo Interactive
Label.

4. Nel menù a tendina Output labels to, selezionare la feature class FeatureLabels
appartenente al warehouse Ski Resort.

5. Nel campo Attributes selezionare Name.

L’attributo è ora contenuto nel campo Layout.

6. Selezionare Top left come Alignment.

7. Selezionare Orient to geometry come Orientation.

Questa opzione permette di ruotare un etichetta nella direzione della geometria a
cui si sta applicando l’etichetta.

8. Cliccare OK.

9. Premere il pulsante sul lato destro della feature Street A, per selezionare la feature
a cui sarà applicata l’etichetta.

Nota: Quando si seleziona una feature è opportuno scegliere un punto che sia
vicino alla zona dove si vuole che l’etichetta sia posizionata, si può verificare come
il punto scelto serva ad orientare la feature rispetto alla geometria.

10.Premere il pulsante ora intorno alla posizione dove ci si aspetta che l’etichetta sia
posizionata.

L’etichetta è ora posizionata.

11.Fare click destro per portare in primo piano la finestra di dialogo.

12.Nella finestra di dialogo Interactive Label, si mantengano invariati tutti i settaggi
con l’eccezione di Alignment.
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13.Tra le possibilità offerte per il settaggio di Alignment scegliere Bottom left.

14.Accertarsi che l’opzione Orient to geometry sia attiva.

15.Premere il pulsante OK.

16.Premere il pulsante sulla feature Service Road e selezionarla quale feature a cui
applicare l’etichetta.

17.Premere il pulsante sulla zona, accanto alla feature, proprio dove si vuole che
l’etichetta venga posizionata.

L’etichetta è ora posizionata.

18.Fare click destro per portare in primo piano la finestra di dialogo.

19.Nel menù a tendina Label features in scegliere ora la feature Trails.

20.Nel campo Attributes selezionare Name.

L’attributo viene visualizzato nel campo Layout.

21.Scegliere Center center come tipo di Alignment.

22.Selezionare Place along arc come tipologia di Orientation.

23.Cliccare OK.

24.Fare click sulla feature Trail e selezionarla quale feature a cui applicare l’etichetta.

25.Premere il pulsante sul punto iniziale dell’arco, nella zona mostra dalla figura
sottostante.

26.Premere il pulsante ora su un punto che individui approssimativamente il centro
dell’arco.
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Dopo aver scelto il secondo punto d’arco, è possibile premere il tasto BACKSPACE,
in modo da tornare un passo indietro, come per annullare un operazione non
corretta.

27.Premere il pulsante il punto di fine arco.
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28.Fare click sotto l’arco per posizionare l’etichetta in questa area.

L’etichetta è ora posizionata.

29.Fare click destro per portare in primo piano la finestra di dialogo.

30.Posizionare l’etichetta utilizzando l’attributo Name utilizzando qualunque tra le
opzioni che sembrano appropriate.

31.Preme il pulsante ESC per uscire dalla modalità di Insert Interactive Label.

32.Salvare il GeoWorkspace.

Inserire un Immagine
Abbiamo visto è facile inserire delle etichette di testo, tanto che ora si è in grado di creare
un site key che descriva tutti gli edifici posizionando una opportuna etichetta di testo,
questa volta invece utilizzeremo un immagine per questo scopo.

1. Selezionare View > Fit All.

2. Selezionare Insert > Interactive Image.

3. Fare Click sul comando Browse.

4. Scegliere di aprire l’immagine site_key.bmp contenuta nella cartella Learning.

5. Accertarsi che il campo Warehouse nella finestra di dialogo Insert Interactive
Image sia impostato sulla connessione Ski Resort.

6. Digitare SiteKey come nome della Feature class.

7. Premere il pulsante OK.
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Si può osservare come il puntatore del mouse sia ora a croce, mentre sulla barra di
stato compare il messaggio Press and drag to define image size and scale.

8. Si posizioni il cursore nell’angolo in basso a sinistra della mappa, al di sotto della
feature Street B. Si faccia click con il pulsante sinistro e si trascini il cursore in modo
da descrivere un’area rettangolare, che si può dimensionare come l’immagine sotto.
Lasciare il pulsante del mouse.

L’immagine site key è ora posizionata nella map window.

Nota: Se si desidera posizionare nuovamente l’immagine, è possibile selezionare la
voce di legenda associata, ed utilizzare il tasto DELETE. Poi è possibile ripetere la
ripetizione. O nel caso in cui si desideri spostare l’immagine si può utilizzare il
comando Edit > Geometry > Move.

Numerare gli Edifici Utilizzando il Comando Insert Text

Sarà ora possibile numerare gli edifici presenti nella Map Window utilizzando il comando
Insert Text che da la possibilità di incrementare in modo automatizzato il testo numerico.
In questo esercizio, non si utilizzeranno gli snap, ma si individuerà in modo approssimativo
la posizione per gli elementi di testo.

1. Utilizzando la scheda Display Order, spostare la feature class FeatureLabels in
testa alla legenda, in modo che abbia priorità sulla feature Buildings.

2. Spegnere tutti gli snap vettoriali, cioè i primi otto pulsanti della toolbar degli snap,
contando da sinistra.

3. Selezionare Insert > Text.

Il controllo Insert Text è ora visualizzato.

Utilizzare i tooltips come suggerimento per selezionare questo controllo.

4. Nel campo più a sinistra, selezionare la feature class FeatureLabels appartenente
alla connessione Ski Resort utilizzando il campo Feature Class.

5. Scegliere Center center come tipo di Alignment.

6. Digitare il numero 1 nel campo di inserimento testo, quando si ha la necessità di
creare una nuova finestra, si utilizzi la combinazione di tasti

7. All’interno del campo Increment, digitare 1.
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Questo valore permette di incrementare il testo numerico, ogni volta che il testo
viene posizionato.

8. Scegliere l’opzione Rotate dynamically per il valore Orientation Mode.

Non è necessario selezionare il campo più a destra, in quanto questo campo si
utilizza solo per la modalità di rotazione Place at Angle.

9. Posizionare il cursore al centro dell’elemento Building 1, come nella figura
sottostante.

10.Premere il pulsante all’interno dell’edificio per posizionare l’origine del testo.

Il testo è posizionato dinamicamente, permettendo di scegliere un verso di
rotazione.

11.Premere il pulsante nella posizione che permette di allineare il testo interattivo, e di
inscriverlo completamente all’interno dell’edificio.

Il testo è ora posizionato, e sarà incrementato automaticamente di una unità alla
prossima operazione.

12.Si disponga ora l’etichetta di testo per l’edificio 2 seguendo la stessa procedura.

Anche la seconda etichetta è stata posizionata.

13.Disporre le etichette di testo per gli edifici rimanenti, sempre seguendo le stesse
istruzioni.

Il comando Insert Text sarà utilizzato anche nel prossimo esercizio.

Posizionare le Restanti Etichette
Si potranno ora posizionare le restanti etichette di testo per la pista da sci, mentre si è
ancora in modalità Data Capture Ski Resort.

1. Fare doppio click sull’elemento di stile della chiave dei legenda ResortLabel.

2. Si scelga il font Arial, la grandezza di 18 punti e il colore nero. Cliccare OK nella
finestra di dialogo Legend Entry Properties.

3. Nel campo più a sinistra selezionare la feature class ResortLabel.

4. Nel campo di inserimento testo digitare il nome della pista da sci: Data Capture
Ski Resort.
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5. Scegliere Center center come tipo di Alignment.

6. Scegliere Place at angle come tipo di Orientation Mode.

7. Accertarsi che il campo più a destra (Angle) abbia valore di rotazione 0.

8. Posizionare ora il cursore in alto e al centro della mappa, sopra gli edifici.

9. Si faccia ora click per posizionare il testo in questa posizione.

10.Premere il pulsante ESC per uscire dal comando Insert Text.

11.Selezionare View > Fit All.

12.Salvare il GeoWorkspace.

Posizionare la Freccia del Nord e la Barra di Scala
Con lo scopo di preparare una mappa stampabile, si vedrà come posizionare la barra di
scala e la freccia del Nord all’interno della map window.

1. Selezionare View > North Arrow per posizionare la freccia del nord.

2. Fare ora click con il tasto destro sulla freccia del nord e scegliere Properties per
visualizzare la finestra di dialogo associata con questo elemento.

3. Premere il pulsante sul pulsante Browse per scegliere un’altra freccia del nord.

4. Selezionare una freccia del nord a piacere, come arrow10.wmf.

5. Accertarsi che l’opzione Save As Default non sia spuntata.

Se si desidera utilizzare questa freccia del nord all’interno di un processo di batch
plotting, bisognerà invece salvarla come default.

6. Premere il pulsante OK.
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Ora la north arrow è posizionata.

7. Si trascini la freccia del nord in una posizione che si reputa adeguata, come ad
esempio l’angolo in alto a destra.

8. Per posizionare la barra di scala, scegliere View > Scale Bar.

9. Fare click destro con il tasto destro e selezionare Properties per visualizzare la
finestra di dialogo per questo elemento.

10.Scegliere Double Block come Type.

11.Si può notare come nel campo Preview si possa previsualizzare il tipo di barra si
scala che si andrà ad utilizzare.

12.Selezionare la scheda Intervals and Units.

13.Scegliere nel campo Interval Unit, il valore mi che sta per miglia.

L’etichetta di testo cambia in Miles.

14.Mantenere l’opzione Define intervals disattivata.

15.Premere il pulsante di scheda Style.

16.Si scelgano dei colori differenti per gli elementi Lines, Major fill, e Minor fill.

17.Non scegliere l’opzione Save As Default.

Se, successivamente si avrà la necessità di utilizzare questa barra di scala in
un’altra map window, o all’interno di una procedura di batch plotting, sarà opportuno
salvare la barra di scala scelta come barra di default.

18.Premere il pulsante OK.

La barra di scala è ora posizionata.

19.E’ possibile spostare la bassa di scala nella posizione che si ritiene più opportuna,
ad esempio in basso a sinistra, al di sotto delle particelle.

20.Salvare il GeoWorkspace.

Dare un Nome alla Legenda
Ora si assegnerà alla legenda, un nome conveniente. Dare un nome alla legenda
permette inoltre di applicarla ad un'altra map window, all’interno dello stesso
GeoWorkspace. Le Features appartenenti alla legenda verrano inoltre visualizzate con la
stessa simbologia.

1. Selezionare Legend > Name Legend.

2. Nel campo Name si digiti ResortLegend1.

3. Fare Click su OK.

Rinominare la Map Window
E’ possibile dare alla map window un nome più significativo.

1. Selezionare Window > Map Window Properties.

2. All’interno del campo Map window name digitare Resort Map.
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3. Premere il pulsante OK.

Aprire una Nuova Map Window
E’ possibile aprire una nuova map window che verrà utilizzata per visualizzare alcune
zone della pista da sci.

1. Selezionare Window > New Map Window per aprire una nuova map window.

2. Nella finestra di dialogo New Map Window, all’interno del campo Window Name
digitare County come nome della nuova map window.

3. Selezionare ResortLegend1.

4. Premere il pulsante OK.

La nuova map window: County, è ora visualizzata.

5. Facendo click destro sulla legenda, si può accedere al comando Show Legend
Entries.

6. Selezionare la voce di legenda County, con lo scopo di visualizzare la feature in
legenda.

7. Premere il pulsante OK.

8. Fare click con il tasto destro sulla voce di legenda County e scegliere Display On.

9. Premere il pulsante OK.

L’elemento county è ora di nuovo visualizzato nella legenda.

10.Selezionare, utilizzando il pulsante CTRL, le features ResortLabel e
FeatureLabels, fare poi click con il tasto destro del mouse e selezionare Display
Off.

Se si vuole utilizzare questa finestra di mappa, come mappa finale di overview,
questi elementi possono non essere utilizzati.

11.Selezionare View > Fit All.

12.Salvare il GeoWorkspace.
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Congratulazioni! Avete completato il flusso di lavoro Acquisizione dei Dati. E’ ora
possibile sceglierne un altro tra i tutorial proposti nel manuale Impariamo GeoMedia
Professional.
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7 - Utilizzo del CAD Data Server
In questa sessione, utilizzeremo files nativi MicroStation (.dgn) e, per maneggiare oggetti
di questo tipo, identificheremo il criterio di ricerca CAD (il livello, il nome del layer, il colore,
ed altri). Quindi creeremo un file Server Definition del CAD (.csd) tramite l’apposita l’utility
Define CAD Server Schema File. In ultimo, utilizzeremo un GeoWorkspace per la
creazione di una nuova connessione verso il warehouse CAD con lo scopo di visualizzare
i dati.

NOTA: In questa sessione, utilizzeremo l’utility Define CAD Server Schema File per
creare un file .csd prima, e poi per visualizzare i dati CAD. Questo processo ci da il
controllo dell’inizializzazione e dell’assegnazione di nome alle features nel warehouse
CAD. In alternativa, esiste il comando Display CAD Files, che permette di visualizzare i
dati MicroStation senza dover creare un file .csd. Sebbene questo comando non verrà
utilizzato in questa sessione di lavoro, sarà possibile usarlo quando si intende caricare
files di mappe o per visualizzare dati oppure quando non si sta direttamente lavorando sul
progetto, ma si desidera solamente indagare come le features sono definite, e leggerne gli
attributi.

Prima di Cominciare
Prima di cominciare si compiano i seguenti passi:

1. Se il flusso di lavoro “Creare una Versione Stampabile dei Risultati” è stato
completato utilizzando il file learn.gws (di modo che sia learn.gws che learn.mdb
sono già stati salvati a questo punto), aprire GeoMedia Professional e lanciare il
file learn.gws. (Non fa differenza se le sezioni 4 e 5 non sono state completate.)
Passare al punto 4.

OPPURE -

1. Se il flusso di lavoro “Creare una Versione Stampabile dei Risultati” non è stato
completato copiare il file learn_afterplot.gws contenuto nella cartella
GeoWorkspaces come learn.gws, poi copiare il file learn_afterplot.mdb contenuto
nella cartella Warehouses come learn.mdb (è fortemente raccomandato creare una
copia di back-up dei files learn.gws e learn.mdb, utilizzando nomi differenti). Poi
avviare GeoMedia Professional e lanciare il file learn.gws.

2. Se I files USSampleData.mdb e learn.mdb sono contenuti in cartelle differenti da
C:\Warehouses, quando si aprirà il file learn.gws, verrà visualizzato il seguente
messaggio di errore: "An error occurred while attempting to open connection
'<connection name>'. Verify that your connection parameters are correct and try
again." Per correggere questo errore, utilizzare il pulsante Browse per localizzare il
file, poi Premere il pulsante OK.

3. Se GeoMedia Professional è stato installato in un percorso diverso da C:\Program
files\GeoMedia Professional, quando si tenterà di aprire il file learn.gws, verrà
visualizzato il seguente messaggio di errore: "An error was encountered loading
data for Usable Area Labels legend entry. Do you want to continue loading
remaining legend entries?" Per risolvere il problema, Premere il pulsante Yes per
questo e per I seguenti messaggio, poi selezionare Window > Final Counties.
Selezionare Warehouse > Feature Class Definition. Selezionare
Restricted_Sites dalla connessione learn poi Premere il pulsante Edit. Nel campo
Data source digitare il percorso della cartella Learning dopo il simbolo di uguale.
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Premere il pulsante OK, poi Close. Fare doppio click per la chiave di stile della
voce di legenda Leader Terminators, Premere il pulsante Properties. Utilizzare il
pulsante Browse per localizzare il file terminator.fsm. Nel menù a tendina Name
selezionare Terminator 4, poi impostare l’attributo Size a 10.000, inoltre spuntare
l’opzione Define override color e selezionare il colore nero. Premere il pulsante
OK su tutte le finestre di dialogo. Fare doppio click sulla chiave di stile della voce di
legenda Major Cities, poi Premere il pulsante Properties. Utilizzare il pulsante
Browse per localizzare il simbolo transportation.fsm. Nel menù a tendina Name
,selezionare City Symbol #4, impostare l’attributo Size a 10.000, poi accertarsi
che l’opzione Define override color sia spuntata, prima di Premere il pulsante OK
su tutte le finestre di dialogo.

4. Per scoprire come affiancare verticalmente la finestra di tutorial e quella del
programma, riferirsi a Come Porre le Finestre (Sezione 1-1).

Avvertenza: Se GeoMedia Professional sembra non rispondere ai comandi assicurarsi
che la finestra attiva sia GeoMedia Professional e non la finestra di tutorial.

Definizione del Sistema di Coordinate
Per I dati CAD di tipo MicroStation che si utilizzeranno le coordinate spaziali X e Y sono
state associate al sistema di coordinate Wisconsin State Plane South Zone, 1987 datum.
Utilizzando questo tipo di proiezione sarà possibile creare un file di tipo .csf file a partire da
uno qualunque dei files .dgn.

1. Rimpicciolire la finestra di GeoMedia Professional.

I files che si vogliono utilizzare sono localizzabili nella cartella Learning.

Nota: Si faccia riferimento alla sezione 1-2 Connettersi ad un Warehouse se non
si conosce la localizzazione della cartella Learning, o non si ha accesso ad essa.

2. Copiare e rinominare uno qualunque dei files .dgn come .csf, ad esempio,
adams.dgn in adams.csf.

3. Fare doppio click sul file adams.csf per aprire l’utility Define Coordinate System
File.

La finestra di dialogo Define Coordinate System File è ora visualizzata a scherno.

4. Premere il pulsante di scheda Storage Space.

Rinominare il file .dgn come .csf, ci permette di leggere le unità, lets the Define
Coordinate System File command correctly read the storage units and storage
center point of the design file.

5. Selezionare la scheda Projection Space.

A meno che il sistema di coordinate non sai stato memorizzato all’interno del file di
MGE, Gomedia Professional interpreterà il file come Rectangular Grid, come si
può leggere nel campo Projection algorithm.

6. Modificare l’attributo Projection algorithm da Rectangular Grid a State Plane
Coordinate System 1983 scegliendo questo valore nel menù a tendina.

7. Premere il pulsante Projection Parameters, per impostare l’attributo Zone name
come Wisconsin South.

8. Premere il pulsante OK nella finestra di dialogo Projection Parameters.
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9. Selezionare la scheda General.

10.Nel menù Optional information, digitare Wisconsin South Zone come Name.

11.Premere il pulsante OK nella finestra di dialogo Define Coordinate System File.

Viene visualizzata la finestra di dialogo Save Coordinate System File As.

12.Accertarsi che la cartella scelta per salvare il file sia la cartella Learning , poi
digitare topos nel campo File name, infine Premere il pulsante Save.

Il nuovo sistema di coordinate topos.csf, è stato creato. Siccome tutti I files CAD
hanno lo stesso sistema di coordinate avremo bisogno solamente un file .csf.

13.E’ ora possibile cancellare il file adams.csf.

Definire un File di tipo CAD Server
Un CAD Server Definition (.csd) file serve a specificare a GeoMedia Professional Server
quale file si intende processare, quale feature si vuole estrarre, dove trovare i riferimenti
allo stile grafico, e quale è la proiezione geografica con cui il file è stato archiviato. Il file
.csd file serve inoltre a specificare le opzioni di database di MicroStation in modo che da
poter portare in GeoMedia i files di tipo CAD.

1. Selezionare ora Start > All Programs > GeoMedia Professional > Utilities >
Define CAD Server Schema File.

Viene visualizzata la finestra di dialogo Define CAD Server Schema File.

2. Selezionare File > New.

3. E’ ora necessario confermare che si intende utilizzare il template
MstnTemplate.csd, contenuto nella cartella Templates\CADSchemaDefinition,
selezionare il file per farlo apparire nel campo File name, selezionare Document,
poi Premere il pulsante New.

4. Nella finestra di dialogo Select Map Files Premere il pulsante New.

5. Nella finestra di dialogo Browse for Folder selezionare la cartella Learning, poi
Premere il pulsante OK.

Nel campo Map files sono ora visualizzati 20 files.

6. Premere il pulsante Select All, poi Premere il pulsante OK.

La finestra di dialogo Select Coordinate System Files viene visualizzata sullo
schermo.

Tutti i files hanno lo stesso sistema di coordinate.

7. Nel campo Coordinate system files spuntare il file topos.csf, poi Premere il
pulsante OK.

La finestra di dialogo Define Feature Class viene visualizzata sullo schermo.

Definire le Features
Prima di poter definire nuove feature classes, sarà opportune recuperare le informazioni di
proiezione e datum geografici. La simbologia CAD dovrebbe inoltre essere nota (gli
attributi level, color, weight, line style, layer name, block name, cell name, ed altri) in modo
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da utilizzare queste informazioni come criterio di ricerca all’interno di GeoMedia
Professional. Ad esempio, la simbologia CAD può voler indicare che tutto ciò che tutte le
features lineari che sono rosse e collocate sul livello 10 saranno autostrade, oppure che
tutti gli elementi che sono sul livello 11 with e hanno il colore 4, sono percorsi da
escursione.

La tavola sottostante serve schematizzare e riassumere la simbologia che si vuole
adottare in questo workflow.

Livello Feature Name Element Type (MicroStation) Geometry Type (GeoMedia Professional)

1 Landmark Names Text Primary:SpatialPoint Secondary:GraphicText

Cell=EV Landmark Points Cell (Cellname = 'EV') SpatialPoint

3 Topomap Names Text Primary:SpatialPoint Secondary:GraphicText

4 Roads Line SpatialLine

5 Streams Line SpatialLine

6 Topo Areas Area SpatialArea

7 Water Bodies Area SpatialArea

Si vogliano ora definire le features utilizzando il seguente ordine: 1) Water Bodies (Area),
2) Roads (Linear), 3) Landmark Points (Cell), and 4) Landmark Names (Text).

1. Nella finestra di dialogo Define Feature Class Premere il pulsante New.

2. Nella scheda General, utilizzare l’attributo Name per la feature class WaterBodies
(no spaces).

3. Attivare AreaGeometry nella lista Geometry type.

AreaGeometry è compresa nella lista Primary geometry.

4. Non spuntare l’opzione This feature has database linkages.

Nessuna delle features è provvista di link al database.

5. Premere il pulsante di scheda Graphic Attributes.

Questa finestra contiene gli attributi che possono essere scelti nella finestra di
dialogo Select Set Properties per la feature class che si vuole definire.

In questo esercizio, nessuno degli attributi verrà scelto.

6. Premere il pulsante di scheda Criteria.

Questa scheda serve a specificare I criteri con cui GeoMedia Professional costruirà
la nuova feature class. Ad esempio sarà possibile specificare che tutto ciò che si
trova nei livelli 20 e 21 ed ha l’attributo di colore impostato su rosso, sarà una
strada.
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Nota: Quando si definiscono I criteri di ricerca per le celle, utilizzare l’attributo
CellName. Le celle sono memorizzate su livelli o strati differenti, quindi un tale
criterio di ricerca potrà non essere sempre utile.

7. Spuntare l’opzione ElementLevel per la feature areale che si sta creando.

8. Digitare 7 nella riga ElementLevel nel Classification Criteria.

9. Premere il pulsante OK.

Ora la feature class WaterBodies appare nel campo Feature Classes.

10.Aggiungere ora una feature class lineare e chiamarla Roads. Come da tabella il
livello di riferimento è 4.

Seguire i seguenti passaggi:

- Premere il pulsante New, e definire una feature class con il nome Roads.

- Attivare LinearGeometry all’interno della lista Geometry type.

- Nella scheda Criteria spuntare ElementLevel, poi digitare 4 nella riga
ElementLevel sotto Classification Criteria.

- Premere il pulsante OK.

La feature class Roads compare nel campo Feature classes.

11.Aggiungere una nuova feature class chiamata LandmarkPoints. Il nome CAD della
cella associate è 'EV'. Pere le celle si voglia utilizzare l’attributo CellName invece
che i livelli come criterio di ricerca.

Seguire le seguenti indicazioni:

 Premere il pulsante New e definire una nuova feature class con il nome di
LandmarkPoints.

 Attivare PointGeometry nella lista Geometry type.

 Nella scheda Criteria attivare CellName, e digitare EV nella riga CellName per
Classification Criteria.

 Premere il pulsante OK.

La feature class LandmarkPoints appare nel campo Feature classes.

12.Aggiungere una feature class testuale, chiamata LandmarkNames. Il suo livello
CAD è 1.

Seguire i seguenti passi:

 Premere il pulsante New, per definire una feature class con il nome di
LandmarkNames.

 Spuntare PointGeometry e TextGeometry nella lista Geometry type.

PointGeometry appare nella lista Primary geometry.

 Nella scheda Criteria attivare ElementLevel, e digitare 1 nella riga
ElementLevel per Classification Criteria.

 Premere il pulsante OK.

La feature class LandmarkNames appare nella finestra di dialogo Feature
classes.
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13.Premere il pulsante Close.

14.Selezionare File > Exit con lo scopo di uscire da questa finestra di dialogo.

Verrà richiesto se si vuole salvare.

15.Premere il pulsante Yes.

16.Selezionare la cartella Learning nel campo Save in.

17.Digitare topos come nome per il nuovo file di definizione CAD,CAD definition file,
and click Save.

Il file topos.csd è stato creato nella cartella Learning.

Creare una Connessione CAD
Ora che è stato creato un file di tipo CAD Server Definition si può creare una connessione
CAD.

1. All’interno di GeoMedia Professional, selezionare Window > Final Counties.

2. Selezionare Warehouse > New Connection.

3. Scegliere CAD come Connection type.

4. Nominare la connessione CAD Topo Data.

5. Premere il pulsante Browse per specificare il file CAD Server Schema topos.csd
dalla cartella Learning.

6. Premere il pulsante OK.

7. Selezionare Legend > Add Legend Entries, ed attivare CAD Topo Data per
selezionare tutte le Quattro connessioni CAD Topo Data ed aggiungere nella map
window.

8. Premere il pulsante OK.

I dati vengono visualizzati nello stato del Winsconsin.

9. Utilizzare I controlli di zoom e pan per visualizzare lo stato del Winsconsin.

Se una delle feature classes importata da CAD ha il valore 0 nelle statistiche di
legenda, significa che il file CAD Server Definition è errato per la feature class, per
correggere l’errore sarà necessario correggere il file .cd.

10.Modificare lo stile di visualizzazione delle feature classes utilizzando gli stili
predefiniti contenuti nella cartella Learning, poi Premere il pulsante OK nelle
finestre si dialogo. Il nome degli stili associati alle voci è riportato nella lista:

- LandmarkNames
- LandmarkPoints
- Roads
- TextGeometry of LandmarkNames
- WaterBodies

Nota: Se GeoMedia è stato installato in cartelle differenti da C:\Program
files\GeoMedia Professional, sarà necessario fare doppio click per la voce di
legenda LandmarkPoints e scegliere Properties. Utilizzare il pulsante Browse per
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localizzare il file recreation.fsm. Nel menù a tendina Name selezionare Point of
Interest.

Cancellare la Connessione CAD
Quando si è finito di utilizzare I dati CAD, è possibile chiudere e cancellare la connessione
associata.

1. Selezionare Warehouse > Connections.

2. Premere il pulsante il selettore di riga per le connessioni CAD Topo Data che
dovrebbe essere il primo degli elementi di riga.

Cancelleremo ora la connessione CAD.

3. Premere il pulsante Delete.

4. Quando viene visualizzato il messaggio di conferma, Premere il pulsante Yes.

5. Premere il pulsante Close.

Congratulazioni! Il flusso di lavoro CAD Data Display è stato completato. Potete ora
selezionare uno degli altri flussi di lavoro dall’indice dei contenuti del Learning GeoMedia
Professional.

Se tutti i flussi di lavoro di GeoMedia Professional, sono stati completati, l’utente dovrebbe
avere una buona confidenza con i comandi fondamentali di GeoMedia Professional. Se si
desidera avere più informazioni su i comandi e le possibilità offerte da GeoMedia
Professional selezionare Help > GeoMedia Professional Help Topics.


